Download it now!
Bug 98376 - Update button in Extension Manager causes app hang on OSX
Summary: Update button in Extension Manager causes app hang on OSX
Status: RESOLVED DUPLICATE of bug 70607
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
4.4.5.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2016-03-03 09:05 UTC by Alex Thurgood
Modified: 2016-04-02 23:30 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
SAL LOG debug bt (515.51 KB, application/zip)
2016-03-03 09:07 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2016-03-03 09:05:39 UTC
Clone of bug 95573

When attempting to update an installed extension via the Extensions Manager GUI, LO hangs on OSX
Comment 1 Alex Thurgood 2016-03-03 09:07:47 UTC
Created attachment 123182 [details]
SAL LOG debug bt
Comment 2 Michael Meeks 2016-03-03 12:02:46 UTC
Interesting log. How long did you leave it before exiting ?

  3564	info:vcl.schedule:45624:1:vcl/source/app/scheduler.cxx:268: Calculated minimum timeout as 17 and has active idles
  3565	info:vcl.schedule:45624:17:vcl/source/app/scheduler.cxx:268: Calculated minimum timeout as 12 and no idles
  3566	info:vcl.schedule:45624:1:vcl/source/app/scheduler.cxx:268: Calculated minimum timeout as 8575 and has active idles
  3567	info:vcl.schedule:45624:17:vcl/source/app/scheduler.cxx:268: Calculated minimum timeout as 8575 and no idles
  3568	info:vcl.schedule:45624:1:vcl/source/app/scheduler.cxx:268: Calculated minimum timeout as 8573 and no idles
  3569	info:vcl.schedule:45624:17:vcl/source/app/scheduler.cxx:268: Calculated minimum timeout as 8572 and no idles
  3570	info:vcl.schedule:45624:1:vcl/source/app/scheduler.cxx:268: Calculated minimum timeout as 8572 and no idles
  3571	info:vcl.schedule:45624:17:vcl/source/app/scheduler.cxx:268: Calculated minimum timeout as 8572 and no idles
  3572	info:vcl.schedule:45624:1:vcl/source/app/scheduler.cxx:268: Calculated minimum timeout as 8571 and no idles
  3573	info:vcl.schedule:45624:1:vcl/source/app/scheduler.cxx:268: Calculated minimum timeout as 8571 and no idles
  3574	info:vcl.schedule:45624:17:vcl/source/app/scheduler.cxx:268: Calculated minimum timeout as 8571 and no idles
  3575	info:vcl.schedule:45624:1:vcl/source/app/scheduler.cxx:268: Calculated minimum timeout as 8571 and no idles
  3576	info:vcl.schedule:45624:17:vcl/source/app/scheduler.cxx:268: Calculated minimum timeout as 8569 and no idles
  3577	info:vcl.schedule:45624:1:vcl/source/app/scheduler.cxx:268: Calculated minimum timeout as 8568 and no idles
  3578	info:vcl.schedule:45624:17:vcl/source/app/scheduler.cxx:268: Calculated minimum timeout as 8568 and no idles
  3579	info:vcl.schedule:45624:1:vcl/source/app/scheduler.cxx:268: Calculated minimum timeout as 8567 and no idles
  3580	info:vcl.schedule:45624:17:vcl/source/app/scheduler.cxx:268: Calculated minimum timeout as 8567 and no idles
  3581	info:vcl.schedule:45624:1:vcl/source/app/scheduler.cxx:268: Calculated minimum timeout as 8567 and no idles

It seems like there is no busy idle handler at the end anyway.

Did you leave this for around 20 minutes before force killing it ? =)

If so - then (I guess) we are going to need a series of back-traces with all symbols for this; it doesn't look like a busy-loop.

Thanks !
Comment 3 Alex Thurgood 2016-03-03 18:08:01 UTC
Hmm don't remember exactly how long, possibly at least 15min, I had nothing else runnning on that machine :)
Comment 4 Shunesburg69 2016-03-18 18:02:50 UTC
The bug is older than 5.2 it's present in 4.4.5
Comment 5 Shunesburg69 2016-03-18 18:04:16 UTC
Same bug here: https://bugs.documentfoundation.org//show_bug.cgi?id=70607

*** This bug has been marked as a duplicate of bug 70607 ***
Comment 6 Marc Grober 2016-04-02 23:30:13 UTC
Have run this up to 30 minutes with no change.