Bug Hunting Session
Bug 98384 - After upgrading to libreoffice 5.1, certain Basic macros work strangely.
Summary: After upgrading to libreoffice 5.1, certain Basic macros work strangely.
Status: RESOLVED DUPLICATE of bug 97193
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2016-03-03 13:17 UTC by Gitsy
Modified: 2016-03-06 16:41 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
One of the macros which which is functioning differently in LO5.1 (8.12 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-03-03 17:00 UTC, Gitsy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gitsy 2016-03-03 13:17:59 UTC
The Basic macros which were working in previous versions are currently not working or working strangely after upgrading to 5.1. 

For example, the following code in previous LO versions doesn't shift or move cells. Now it does

  args1(5).Name = "MoveMode"
    args1(5).Value = 4
    dispatcher.executeDispatch(document, ".uno:InsertContents", "", 0, args1())

The above is just an example. In it, the value should be changed as 6 to make it work as in previous versions.

Tested in both Ubuntu and Windows
Comment 1 raal 2016-03-03 16:08:54 UTC
Please attach test file with macro.
Comment 2 Gitsy 2016-03-03 17:00:47 UTC
Created attachment 123205 [details]
One of the macros which which is functioning differently in LO5.1

Done.
The attachment is just an example. The previous LO versions don't shift or move cells. Now it does. If the value is changed as 6 from 4, it works as in previous versions.
Comment 3 raal 2016-03-06 09:26:27 UTC
Version: 5.2.0.0.alpha0+
Build ID: aaca25d67eb5ea252730cdcf555ecc04ce04a5e6
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-02-24_23:58:47


run macro and nothing happens.
steps:
 - open file, cursor is in cell E19
 - run macro
 - nothing. Cursor is in cell E19

What should happen?
Comment 4 Maxim Monastirsky 2016-03-06 09:41:22 UTC
Looks to me as a duplicate of Bug 97193.

*** This bug has been marked as a duplicate of bug 97193 ***
Comment 5 Gitsy 2016-03-06 16:41:20 UTC
@raal

1.copy a cell having itself and all adjacent cell have contents. 
2.Run the macro
3.The macro shift cells a paste the macro. (Previous LO versions doesn't shift or move cells. Now it does)