Bug Hunting Session
Bug 98456 - Confusing effects from write-protected field
Summary: Confusing effects from write-protected field
Status: RESOLVED DUPLICATE of bug 62879
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2016-03-06 01:52 UTC by Luke Kendall
Modified: 2018-07-26 16:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document (10.20 KB, application/vnd.oasis.opendocument.text)
2016-03-06 14:16 UTC, Luke Kendall
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke Kendall 2016-03-06 01:52:14 UTC
I wished to do some work on a few chapters of my book, and wanted to use a paragraph style available in the main document.  So I Saved a Copy of the main document to a new file, then opened the new file and tried to delete all the unwanted chapters before the chapters of interest, by selecting from there to the start of the document and hitting Delete.

Instead of the expected deletion, I got the error message "write-protected content cannot be changed".

It took some time to determine that this was because near the beginning of my book I have a write-protected table of contents.

That this element prevented the deletion of everything else in the selection seems very counter-intuitive to me.

Also, as I understand it, the write-protection option on the ToC is to prevent you editing the contents of the ToC. But the expectations, when selecting the entire table (and more besides) is clearly not /editing/ the table but deleting it.  And since it /is/ possible to delete the Toc by clicking on it and choosing "Delete", clearly deletion is allowed.  But let's ignore that possibility for the sake of simplicity.

The situation would not have been so confusing if the error message had been more specific, and stated "The selection includes a write-protected element and therefore cannot be changed", at a minimum.  Slightly better still would be "The write-protected element on page <N> prevents changing the selection which includes it".

Personally, I think the user intention is perfectly clear when a write-protected element is included in a larger selection: at a minimum, the user would expect everything except the write-protected element(s) to be changed as per the operation they then performed - leaving the write-protected elements unchanged.

But please at least change the error message so that it is clearer.
Comment 1 Cor Nouws 2016-03-06 12:43:38 UTC
Hi Luke,

Thanks for the prose .. report ;)
Can you please attach a simple test document?
Cheers - Cor
Comment 2 Luke Kendall 2016-03-06 14:16:46 UTC
Created attachment 123347 [details]
Sample document
Comment 3 Luke Kendall 2016-03-06 14:17:48 UTC Comment hidden (obsolete)
Comment 4 Cor Nouws 2016-03-07 10:09:09 UTC
(In reply to Luke Kendall from comment #3)
> Any document with a ToC would suffice.
> Just remember to select all, then hit Delete.

Thanks, that helps.
So to summarize: if there is a selection with any protected element in it, and one hits DEL, the text "write-protected content cannot be changed" does not always give good guidance of what is going on. Is that correct?

Cheers,
Cor
Comment 5 Luke Kendall 2016-03-07 11:04:35 UTC
Yes, precisely: and the longer the document (the smaller the part the write-protected element is), the more unexpected the message is.
Comment 6 Luke Kendall 2016-03-15 06:35:03 UTC Comment hidden (no-value)
Comment 7 raal 2016-03-15 13:59:32 UTC
UX Team -- please take a look at this - maybe message can contain more informations.
Comment 8 Robinson Tryon (qubit) 2016-08-25 05:49:17 UTC Comment hidden (obsolete)
Comment 9 Timur 2018-07-26 16:52:19 UTC
Basically this is a duplicate of Bug 62879 if we understand  that one is about custom message.

*** This bug has been marked as a duplicate of bug 62879 ***