Bug Hunting Session
Bug 98527 - Improve OpenType feature 'locl' support
Summary: Improve OpenType feature 'locl' support
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.3.0
Keywords:
Depends on: HarfBuzz
Blocks: Font-Rendering CJK
  Show dependency treegraph
 
Reported: 2016-03-08 18:10 UTC by Volga
Modified: 2016-11-06 18:33 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
sample formatted with FreeSerif regular, in italics, and in italics formatted as Serbian (63.13 KB, image/png)
2016-03-14 12:24 UTC, Christian Lohmaier
Details
Sample formatted with FreeSerif regular and italics, formatted as Serbian (Windows 10) (156.30 KB, image/png)
2016-03-15 13:32 UTC, Volga
Details
Sample formatted with Source Han Sans SC, formatted as Korean (222.03 KB, image/gif)
2016-03-15 13:58 UTC, Volga
Details
Screenshot from LibreOfficeDev Writer (74.88 KB, image/png)
2016-11-02 04:20 UTC, Volga
Details
Screenshot from LibreOfficeDev Writer (77.13 KB, image/png)
2016-11-02 07:33 UTC, Volga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Volga 2016-03-08 18:10:39 UTC
Since Bug 62154 the 'locl' feature become actived, but this support still limited. 

Steps to reproduce:

Using FreeSerif to type five cyrillic letters б д г п т, make them italic and mark them as Serbian via the “Language” option at Character dialog, they have no localized form appearing. 

Then switch Doulos SIL (version 5.0) to display the same letters, the problem looks the same.
Comment 1 Volga 2016-03-08 18:46:35 UTC
Several language specific version of Source Han Sans (Source Han Sans, Source Han Sans SC, Source Han Sans TC, Source Han Sans K) also has some localized glyphs. Type 骨 (U+9AA8) and 曜 (U+66DC), mark them as Simp/Trad Chinese, Japanese or Korean via the “Language” option at Character dialog, they still have no localized form appearing.

See: https://github.com/adobe-fonts/source-han-sans/raw/release/SourceHanSansReadMe.pdf
Comment 2 Christian Lohmaier 2016-03-14 12:24:06 UTC
Created attachment 123556 [details]
sample formatted with FreeSerif regular, in italics, and in italics formatted as Serbian

cannot reproduce.
Enter the characters and format them with FreeSerif font, make it italic.

Then format one of the italic lines with Serbian language → different shapes are used.
Comment 3 Buovjaga 2016-03-14 12:38:40 UTC
I can repro the problem with Serbian Cyrillic (Serbia) under Win.

Used FreeSerif from: http://ftp.gnu.org/gnu/freefont/freefont-ttf-20120503.zip

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: b89feb8018bf3610faf01e73995d576f6566e20b
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-03-07_03:36:17
Locale: fi-FI (fi_FI)
Comment 4 Volga 2016-03-15 13:19:27 UTC
(In reply to Christian Lohmaier from comment #2)
> Created attachment 123556 [details]
> sample formatted with FreeSerif regular, in italics, and in italics
> formatted as Serbian
> 
> cannot reproduce.
> Enter the characters and format them with FreeSerif font, make it italic.
> 
> Then format one of the italic lines with Serbian language → different shapes
> are used.

It seems to me you are not using Windows.
Comment 5 Volga 2016-03-15 13:32:18 UTC
Created attachment 123593 [details]
Sample formatted with FreeSerif regular and italics, formatted as Serbian (Windows 10)
Comment 6 Volga 2016-03-15 13:32:53 UTC
Comment on attachment 123556 [details]
sample formatted with FreeSerif regular, in italics, and in italics formatted as Serbian

You can see what I have seen: Attachment #123593 [details]
Comment 7 Volga 2016-03-15 13:58:24 UTC
Created attachment 123594 [details]
Sample formatted with Source Han Sans SC, formatted as Korean
Comment 8 Volga 2016-07-02 16:21:26 UTC
I have found HarfBuzz has a very easy and reliable API to get localized glyph(s), and this library has optimized for many compliers and platforms, so I think intergrate HarfBuzz on Windows version would be helpful.
Comment 9 Buovjaga 2016-07-02 18:11:46 UTC
(In reply to General Kutuzov from comment #8)
> I have found HarfBuzz has a very easy and reliable API to get localized
> glyph(s), and this library has optimized for many compliers and platforms,
> so I think intergrate HarfBuzz on Windows version would be helpful.

It is coming: https://summerofcode.withgoogle.com/projects/#6122433102741504
Comment 10 Volga 2016-07-05 07:25:35 UTC
(In reply to Buovjaga from comment #9)
> (In reply to General Kutuzov from comment #8)
> > I have found HarfBuzz has a very easy and reliable API to get localized
> > glyph(s), and this library has optimized for many compliers and platforms,
> > so I think intergrate HarfBuzz on Windows version would be helpful.
> 
> It is coming: https://summerofcode.withgoogle.com/projects/#6122433102741504

Good, I have found bug 89870 is also prepared for this, I hope this bug is resolved on Windows when bug 89870 is fixed.
Comment 11 Volga 2016-11-02 04:20:05 UTC
Created attachment 128422 [details]
Screenshot from LibreOfficeDev Writer

Congratulations! It was resolved in LODev 5.3, I can see the effect when I setting SAL_USE_COMMON_LAYOUT=1

Version: 5.3.0.0.alpha1+
Build ID: 4b4abb73fcd7f2802e73102b3e7c30face8d309c
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-10-31_02:54:50
Locale: zh-CN (zh_CN); Calc: group
Comment 12 Volga 2016-11-02 04:38:58 UTC
(In reply to General Kutuzov from comment #11)
> Created attachment 128422 [details]
> Screenshot from LibreOfficeDev Writer
> 
> Congratulations! It was resolved in LODev 5.3, I can see the effect when I
> setting SAL_USE_COMMON_LAYOUT=1
> 
> Version: 5.3.0.0.alpha1+
> Build ID: 4b4abb73fcd7f2802e73102b3e7c30face8d309c
> CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; Layout Engine:
> new; 
> TinderBox: Win-x86@39, Branch:master, Time: 2016-10-31_02:54:50
> Locale: zh-CN (zh_CN); Calc: group

Errata: this is not use ZWJ, instead is ZWNJ
Comment 13 Volga 2016-11-02 07:33:01 UTC
Created attachment 128430 [details]
Screenshot from LibreOfficeDev Writer
Comment 14 Buovjaga 2016-11-02 07:50:52 UTC
Should we change to RESOLVED FIXED?
Comment 15 Volga 2016-11-04 03:25:23 UTC
(In reply to Buovjaga from comment #14)
> Should we change to RESOLVED FIXED?

OK, I think this is fixed. Since LODev enabled new text layour engine by default.

Version: 5.3.0.0.alpha1+
Build ID: a6ce5d391476e4b6a2cb2d92ff45548c1d75684b
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-11-04_00:03:22
Locale: zh-CN (zh_CN); Calc: group