Download it now!
Bug 98548 - Try to acess remote server when off-line
Summary: Try to acess remote server when off-line
Status: RESOLVED DUPLICATE of bug 89394
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: All Mac OS X (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2016-03-09 12:06 UTC by André João Telöcken
Modified: 2016-05-11 08:37 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
LO crashlog (1.06 MB, text/plain)
2016-05-08 08:48 UTC, steve -_-
Details

Note You need to log in before you can comment on or make changes to this bug.
Description André João Telöcken 2016-03-09 12:06:24 UTC
Hi there,

Have critical problem. 

When I offline with my computer and try do copy, paste or open a file the Libre Office Vanilla frequently try to access the files on "recent documents history". This operation expend a lot of time while the Libre office check the server. It repeat this operation a lot times a then we lost a lot time waiting. 

I think when the "recent documento" is located on a offline server/computer it must flag to not search every time.

Thanks a lot to solve it,

Best Regards,

André João Telöcken.
Comment 1 Yousuf Philips (jay) (retired) 2016-03-09 19:36:08 UTC
Hi Andre,

Thank you for reporting the bug. Can you confirm that this is happening with the latest LibreOffice Vanilla 5.1.1?
Comment 2 steve -_- 2016-03-09 19:47:18 UTC
Could you please elaborate in greater detail, which files are in recent files. Are those local files? Or files from an online storage?

Also you say "this operation expend a lot of time while the Libre office check the server". Which server are you referring to that is being checked?

Setting to NEEDINFO until more detail is provided.

After providing the requested info, please reset this bug to UNCONFIRMED (should it be persisting) or WORKSFORME (should it be solved with a newer LO version).
Comment 3 André João Telöcken 2016-03-10 18:49:13 UTC
I updated my libreoffice vanilla to the version 5.1.1.3.

To you understand better my situation I can explain a sample to you:

1) I work on my office and access a file with Libreoffice on my Samba Server;
2) When I am at home I would like to access other local file and then the libre office are looking if my file that I have accessed on my office is available. 
This procedure expend a lot of time.

After a few seconds I get a message that file is not available. 

Thanks,

André João Telöcken.
Comment 4 Yousuf Philips (jay) (retired) 2016-03-11 05:37:53 UTC
Hi Andre,

So this is what i tried

1) Open a document on my linux desktop from my windows laptop as well as one in Google Docs
2) Close libreoffice and disconnect the internet on the laptop
3) Open libreoffice and open another document or open writer

and i didnt have any problems.

@Steve: Can you try the same and see if you have problems.
Comment 5 steve -_- 2016-05-08 08:38:11 UTC
Tried

1. open LO file from second computer on same network via afp://
2. close LO and disable WIFI
3. open LO and another document

→ all good. what issue are we discussing?

NeedInfo. André can you please post precise reproduce steps similar to the form above.
Comment 6 steve -_- 2016-05-08 08:44:53 UTC
Sorry, wifi / network was behaving oddly here.

I reproduced this problem and it's really ugly.

1. open file from remote share (in my case, I used afp:// which comes on board with OS X: system preferences > sharing > file sharing)
2. access machine 1 from machine 2 via afp://
3. open file from machine 1 on machine 2
4. close LO
5. disable WIFI / network connection
6. reopen LO

Currently
Crash (log attached). I can't even force quick LO, something is very stuck / borken here.

Expected
LO should continue to operate even without a network connection.

→ NEW
Comment 7 steve -_- 2016-05-08 08:48:07 UTC
Created attachment 124907 [details]
LO crashlog
Comment 8 steve -_- 2016-05-11 08:37:04 UTC
This seems to be a dupe of #89394

*** This bug has been marked as a duplicate of bug 89394 ***