Bug 98593 - base form button control will not show multi line text with image on control
Summary: base form button control will not show multi line text with image on control
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: medium normal
Assignee: Caolán McNamara
QA Contact:
URL:
Whiteboard: target:5.4.0 target:5.3.1 target:5.2.6
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2016-03-11 01:48 UTC by Dave
Modified: 2017-01-19 15:42 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample odb with form and test button (12.03 KB, application/vnd.sun.xml.base)
2016-03-11 19:57 UTC, Dave
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dave 2016-03-11 01:48:30 UTC
I have several forms in Base with button controls that use an image on the button and two lines of text to describe button action. In LO 4.4.7 the text shows correctly. In LO 5.1.0.3 release only part of the first line of text shows and it is truncated with three periods "..." 

Resizing the button has no affect. However, if I put characters on 4 lines of button text, the first two will display full length, but to high on the control.

Something seems to be amiss.
Comment 1 raal 2016-03-11 17:25:49 UTC
Hello,

Thank you for filing the bug. Please send us a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO', so please do change it back to 'UNCONFIRMED' once you have attached a document.
(Please note that the attachment will be public, remove any sensitive information before attaching it.)
How can I eliminate confidential data from a sample document?
https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F
Thank you
Comment 2 Dave 2016-03-11 19:57:16 UTC
Created attachment 123507 [details]
Sample odb with form and test button

I have attached a sample HSQLDB database with one form containing a button with an embedded image and two lines of text.

Hope this helps.

-dave
Comment 3 raal 2016-03-11 20:49:34 UTC
I can confirm with Version: 5.2.0.0.alpha0+
Build ID: aaca25d67eb5ea252730cdcf555ecc04ce04a5e6
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-02-24_23:58:47
Comment 4 Terrence Enger 2016-06-30 14:14:50 UTC
Setting keyword bibisected.

Working in (an old and somewhat broken version of) the linux daily
dbgutil bibisect repository, I have narrowed the introduction of the
bug to the 43 commits between ...
    good : 02f749e... 2015-07-09 s-h 85ce6a2...
    bad  : 1b45cef... 2015-07-10 s-h 83b5316...
Comment 5 Aron Budea 2017-01-08 04:44:05 UTC Comment hidden (bibisection)
Comment 6 Aron Budea 2017-01-08 04:46:23 UTC
Thsi bug started with the commit quoted below. Adding Cc: to Simon Long, please take a look. Also adding Cc: to Caolán McNamara.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=74407aef94b6d8dfdd69891c4a6e578587ef3e71
author	Simon Long <simon@raspberrypi.org>	2015-07-08 17:02:50 (GMT)
committer	Caolán McNamara <caolanm@redhat.com>	2015-07-09 15:07:24 (GMT)

"tdf#92630 Enable auto-accelerator behaviour for gtk"
Comment 7 Caolán McNamara 2017-01-13 15:42:58 UTC
It appears to be because of DrawText -> DrawControlText change.

The different code path for drawing text thinks the text is slightly larger than the box provided so the text "doesn't fit" and is ellipsed to fit. hacking the bounding box to be 2 pixels higher makes it work, so perhaps a rounding error
Comment 9 Caolán McNamara 2017-01-19 10:07:00 UTC
yeah, seems broken. Fixed in master towards 5.4. Backports to 5.3 and 5.2 in gerrit
Comment 10 Commit Notification 2017-01-19 15:21:39 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b05f85a3fd247baea4f2dd975f2178e04ea5dd6a&h=libreoffice-5-3

Resolves: tdf#98593 buttons in writer show different text at different zooms

It will be available in 5.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2017-01-19 15:42:56 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4fd0f5715efb435160814e8c5f514b9ad1752c49&h=libreoffice-5-2

Resolves: tdf#98593 buttons in writer show different text at different zooms

It will be available in 5.2.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.