Download it now!
Bug 98634 - Cutting or copying text from comments to document body brings comment formatting
Summary: Cutting or copying text from comments to document body brings comment formatting
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Paste Writer-Comments Writer-Styles Cut-Copy
  Show dependency treegraph
 
Reported: 2016-03-13 17:56 UTC by Nick Bugs
Modified: 2019-11-07 12:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Bugs 2016-03-13 17:56:42 UTC
I'm using LibreOffice on Debian Jessie, in KDE.

I find, and this is always reproducible, that cutting/copying text from inside comments into the main document brings the comment formatting with them.

This can be a bit of a pain when using comments for writing bits of text that the user later may want to use within the main document, etc.

I'm not sure there's many use cases where the (default) comment formatting is something that users are going to want ported using the clipboard into the document itself. 

I don't know much about what is going on behind the scenes in this case, and perhaps this relates to the linux or KDE clipboard, but generally I don't think that formatting (font size, type, etc) from comments should be copied. If there are specific circumstances when comment formatting is customised by users and users would want that copied to clipboard, then perhaps comment formatting should instead default to the document default style - which would mean that for many users the formatting would then be similar when copied into the document.

Thanks!
Nick
Comment 1 Cor Nouws 2016-03-13 19:46:54 UTC
Hi Nick,

Thanks, I confirm this. Tested in 5.0.5.2

It would be my expectation that pasting in a paragraph with text, pastes without formatting. ANd pasting in an empty paragraph, with formatting.
As is common.

(In reply to Nick Bugs from comment #0)
> This can be a bit of a pain when using comments for writing bits of text
> that the user later may want to use within the main document, etc.

Ctrl+Shft+V .. paste as "Text only" does help here.

Cheers,
Cor
Comment 2 QA Administrators 2017-05-22 13:18:48 UTC Comment hidden (obsolete)
Comment 3 Dieter 2017-05-31 09:09:36 UTC
I confirm it with Win10 x64 and LO 5.3.3.
Comment 4 Arnold Ejiofor 2017-11-15 08:26:17 UTC Comment hidden (spam)
Comment 5 Thanos 2018-05-22 07:42:11 UTC Comment hidden (spam)
Comment 6 QA Administrators 2019-05-23 02:50:21 UTC Comment hidden (obsolete)
Comment 7 Dieter 2019-05-23 09:52:59 UTC
Still repro with

Version: 6.3.0.0.alpha1+ (x64)
Build ID: e92dcfdc7bd7b237e0bee26ff226a102d9e8e766
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-05-14_00:00:57
Locale: en-US (de_DE); UI-Language: en-US
Calc: threaded
Comment 8 lexaplay 2019-08-16 08:51:46 UTC Comment hidden (spam)
Comment 9 Cor Nouws 2019-08-18 20:23:28 UTC
In master 6.4, copy pasting from a comment changes font from Liberation 10 in to 14, where Standard is 12 ;)

Since there is no use of para of character styles in the comments, there is just a situation with 'direct formatting'. So it is expected that pasting keeps the formatting.

I see no solution for this situation. One could suggest to always paste as text without formatting if the source is a comment.. but then it is impossible to copy text with formatting..
Using Paste special (or one of the nice relatively new context or menu entries) is the way to go here.

So I think it best to close as NotABug, Nick.
Comment 10 Ezron 2019-11-07 12:05:11 UTC Comment hidden (spam)