Bug 98643 - Calc: "Scope" listbox in "Name Manager" and "Create Name" dialog does not have online help text
Summary: Calc: "Scope" listbox in "Name Manager" and "Create Name" dialog does not hav...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: medium normal
Assignee: Gabor Kelemen
URL:
Whiteboard: target:5.4.0
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-14 11:13 UTC by Daniel Rentz
Modified: 2017-01-03 11:13 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Rentz 2016-03-14 11:13:01 UTC
1. Create a new Calc document with the sheets "Sheet1" and "Sheet2"
2. Create a named range "name1" with scope "Sheet2" (instead of "Document global")
3. Try to use that name in Sheet1:
- entering =name1 results in #NAME? which is exprected
- but entering =Sheet2.name1 does not work either

4. Try to get help for the "Scope" listbox in the "Manage Names" dialog by pressing F1
==> there is none.
Comment 1 Eike Rathke 2016-03-14 11:51:15 UTC

*** This bug has been marked as a duplicate of bug 96915 ***
Comment 2 Daniel Rentz 2016-03-14 12:42:23 UTC
Let's keep this open for the missing online help...

1. Open a Calc document
2. Open the "Manage Names" dialog (Ctrl+F3)
3. Create a new name
3. Move focus to "Scope" listbox
4. Press F1
Comment 3 Buovjaga 2016-10-21 17:52:41 UTC
(In reply to Daniel Rentz from comment #2)
> 2. Open the "Manage Names" dialog (Ctrl+F3)

This does nothing for me. What is another way to open it?
Comment 4 Gabor Kelemen 2016-12-09 09:29:56 UTC
(In reply to Buovjaga from comment #3)
> (In reply to Daniel Rentz from comment #2)
> > 2. Open the "Manage Names" dialog (Ctrl+F3)
> 
> This does nothing for me. What is another way to open it?

This is the Sheet - Named ranges and expressions - Manage menu item in 5.2+.
It was Insert - Names - Manage up to 5.1.x

Currently pressing the Help button takes me here: 
https://help.libreoffice.org/scalc/modules/scalc/ui/managenamesdialog/names

In theory this is referenced in the Define Names windows help, so it should work: 
http://opengrok.libreoffice.org/xref/help/source/text/scalc/01/04070100.xhp#42

But apparently it doesn't.
Comment 5 Gabor Kelemen 2016-12-20 10:38:24 UTC
The Scope listbox has help, but it is linked to the "more" expander instead of the "scope" listbox.

The Help button takes me to the Scalc/modules/scalc/ui/managenamesdialog/names link, but only the /name item is linked in the xhp, that belongs to the Name input box, so that should not work despite my previous comment.
Comment 6 Commit Notification 2016-12-31 14:21:22 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=92e858687cb974b9f6074e9643f5377f24eb73a0

tdf#98643 Fix links between UI and the 'Define Names' page