Bug 98663 - Save Writer document seems initially unresponsive
Summary: Save Writer document seems initially unresponsive
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.1.3 release
Hardware: All Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-14 22:40 UTC by Ben
Modified: 2020-11-03 06:18 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Test document (9.12 MB, application/vnd.oasis.opendocument.text)
2016-03-31 23:05 UTC, Ben
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ben 2016-03-14 22:40:47 UTC
After pressing the save button it takes several seconds before a Saving document message appears at the bottom of the screen.
Comment 1 raal 2016-03-22 07:13:58 UTC
I can not confirm with  5.1.1.3, win7. Is it a big document or you see the problem in a small documents too?
Comment 2 Buovjaga 2016-03-29 14:40:34 UTC
Yeah - do we need an example document?

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.
Comment 3 Ben 2016-03-31 23:02:49 UTC
Document attached for your testing.
Comment 4 Ben 2016-03-31 23:05:00 UTC
Created attachment 123999 [details]
Test document
Comment 5 Buovjaga 2016-04-04 10:46:16 UTC
Confirmed.

Win 7 Pro 64-bit, Version: 5.1.1.3 (x64)
Build ID: 89f508ef3ecebd2cfb8e1def0f0ba9a803b88a6d
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: fi-FI (fi_FI)

Version: 5.2.0.0.alpha0+
Build ID: 7a7be32e5265f897174f3880adc061dac0203f1f
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-03-31_07:39:11
Locale: fi-FI (fi_FI)
Comment 6 QA Administrators 2017-05-22 13:19:30 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2019-12-03 14:59:10 UTC Comment hidden (obsolete)
Comment 8 Ben 2020-11-02 20:55:04 UTC
Issue can be closed. Writer seems to be more responsive.
Comment 9 Buovjaga 2020-11-03 06:18:50 UTC
Indeed, re-tested just now and with 5.2 it takes 5,5 seconds while with master it takes 1,3 seconds.

Version: 7.1.0.0.alpha1+ (x64)
Build ID: b61bf7c7cfcf97a5ade6d130873af146670bc2ee
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: default; VCL: win
Locale: fi-FI (fi_FI); UI: en-US
Calc: threaded