Bug Hunting Session
Bug 98666 - Green "progress bar" widget not correct with OpenGL rendering
Summary: Green "progress bar" widget not correct with OpenGL rendering
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.1.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.3.0 target:5.2.0.1 target:5.1.4
Keywords:
: 98664 (view as bug list)
Depends on:
Blocks: VCL-OpenGL
  Show dependency treegraph
 
Reported: 2016-03-14 22:46 UTC by Ben
Modified: 2016-10-25 18:54 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ben 2016-03-14 22:46:38 UTC
Loading a document into Writer does not show a progress bar.
Comment 1 Usama 2016-03-15 11:32:35 UTC
Hello Ben,

Thank you for reporting this.

I clearly can see the loading progress on Version: 5.2.0.0.alpha0+, however it's so fast.

what do you see instead of the loading progress, do you see something not in it's place or the document just take time to open without showing the progress.

Can you try with a bigger file maybe with images too? what do you see instead of the loading progress, do you see something not in it's place or the document just take time to open without showing the progress.

If it happens only with one file, please attach it after removing sensitive or personal informations that you do not want it to be published.

Tested on Version: 5.2.0.0.alpha0+ Build ID: 129d199d27f6961ea0c850686f76c83e2fc1953d CPU Threads: 1; OS Version: Windows 6.1; UI Render: default; TinderBox: Win-x86@42, Branch:master, Time: 2016-03-11_06:16:01 Locale: en-US (en_US)
Comment 2 Ben 2016-03-15 14:29:23 UTC
Usama,

I have a 450 page document with lots of tables and formulas, and also a few images. I see the text "Loading Document" at the bottom of the screen. I see no progress bar next to it. I see the spinner. With a much smaller document, opening goes so fast that "Loading Document" is not even shown. It will take me quite while to remove the personal info.
Comment 3 Armin Le Grand 2016-03-16 14:55:25 UTC
Ben's test documrnt is contained in https://bugs.documentfoundation.org/show_bug.cgi?id=93553
Comment 4 Ben 2016-03-16 18:07:08 UTC
This issue is resolved per configuration change mentioned in ticket 98697: Any cleaner glyph rendering if you disable OpenGL rendering from Tools -> Options -> View.
Comment 5 Usama 2016-03-16 18:58:11 UTC
I've tested the issue with the file linked without issue using LO: 5.2.0 alpha from master. on both Windows 7 and Ubuntu 15.10

I even doubled the file size by duplicating it's content to reach +300 page.

It works well. OpenGL is not enabled in options in both of my systems.
Comment 6 V Stuart Foote 2016-03-16 20:18:22 UTC
OP reports disabling OpenGL rendering resolved.
Comment 7 V Stuart Foote 2016-03-25 13:13:56 UTC
*** Bug 98664 has been marked as a duplicate of this bug. ***
Comment 8 V Stuart Foote 2016-03-25 13:15:33 UTC
With OpenGL rendering enabled, the advancing "progress bar" widget displayed over the status bar is not rendered when opening or saving a document.

The "Loading document..." or "Saving document..." label appears, but the green advancing progress bar is not rendered.

Disabling OpenGL and restarting LibreOffice, the green progress bar is rendered.

On Windows 10 Pro 64-bit en-US with
Version: 5.2.0.0.alpha0+
Build ID: 15b53976e5d119877e53f34b34cee33a5f2883fd
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-03-22_23:57:30
Locale: en-US (en_US)

Version: 5.1.1.3 (x64)
Build ID: 89f508ef3ecebd2cfb8e1def0f0ba9a803b88a6d
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; 
Locale: en-US (en_US)
Comment 9 Michael Meeks 2016-03-25 17:45:16 UTC
Interesting; this is almost certainly because we now swap-buffers at idle, to get correct screen refreshing ... I suspect that we need to dig into what idle handling is going on during writer load; and how this works on Mac (where there is a similar rendering approach).

Marco - perhaps worth looking at as your next issue; my feeling is that we're going to need an Update(bool bReallyDoIt); type separation, and to go audit all of the Window:;Update() calls (or is it Window::Flush()) - and actually do the swap-buffers for the few of these cases where there really is no main-loop running and we want to update the screen from the back-buffer.

Of course - we really also need that fix for a nice solution to synchronously render inside a re-size callback etc.
Comment 10 Tor Lillqvist 2016-05-25 09:09:37 UTC
It is interesting that if I add CTRL_PROGRESS to the controls that are not cached in ControlCacheKey::canCacheControl(), I do get the initial progress bar for 'Load Document', but not the one for 'calculating'.
Comment 11 Commit Notification 2016-05-27 19:49:27 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=483b4d6bfdb4800811e87a07f25b24e3f6019e38

tdf#98666: Don't cache progress bars either

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2016-05-30 07:20:55 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0e999353c53cf1aa357cc6769f4ece1a8d8a74db&h=libreoffice-5-2

tdf#98666: Don't cache progress bars either

It will be available in 5.2.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2016-05-30 13:12:53 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d4374477255c1189ad193ae3f5fa1b80a28fc1ba&h=libreoffice-5-1

tdf#98666: Don't cache progress bars either

It will be available in 5.1.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Jan Holesovsky 2016-06-24 12:36:45 UTC
The loading progress bar is fixed by this; but probably this does not affect the progressbar in the splash screen.

Stuart: Can you please create a separate bug for that (if that indeed does not work), and make it block the bug 93529?  Thank you!
Comment 15 V Stuart Foote 2016-06-24 16:45:54 UTC
(In reply to Jan Holesovsky from comment #14)
> ...
> Stuart: Can you please create a separate bug for that (if that indeed does
> not work), and make it block the bug 93529?  Thank you!

@Kendy, on 5.2.0.1 and current 5.3.0alpha0+ the Splash screen loading bar does appear, it is Black over a Green background, but it advances smoothly.

Don't believe there is an issue.