Download it now!
Bug 98684 - Impress crashes when running in presentation mode
Summary: Impress crashes when running in presentation mode
Status: RESOLVED DUPLICATE of bug 100151
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-15 14:23 UTC by Thomas Hehl
Modified: 2016-09-23 15:16 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Attachment causing the crash (67.18 KB, application/vnd.oasis.opendocument.presentation)
2016-03-15 14:23 UTC, Thomas Hehl
Details
WinDbg trace file (6.76 KB, text/plain)
2016-03-17 07:07 UTC, Usama
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Hehl 2016-03-15 14:23:28 UTC
Created attachment 123600 [details]
Attachment causing the crash

Open the attached impress presentation and hit F5. It crashes for me on the first two slides.
Comment 1 Usama 2016-03-15 17:22:12 UTC
Hello Thomas,

Thank you for reporting the bug. I can confirm that the bug is present in master.
However it crashes for me after finishing the presentation. 

Version: 5.2.0.0.alpha0+ Build ID: 129d199d27f6961ea0c850686f76c83e2fc1953d CPU Threads: 1; OS Version: Windows 6.1; UI Render: default; TinderBox: Win-x86@42, Branch:master, Time: 2016-03-11_06:16:01 Locale: en-US (en_US) VirtaulBox Image.
Comment 2 Julien Nabet 2016-03-15 21:28:07 UTC
On pc Debian x86-64 with master sources updated today, no crash here.
I just noticed these on console:
App path: /home/julien/compile-libreoffice/libreoffice/instdir/program/
bootstap: file:///home/julien/compile-libreoffice/libreoffice/instdir/program/bootstraprc
user installation: file:///home/julien/compile-libreoffice/libreoffice/instdir/
Generate pipe md5 for 'file:///home/julien/compile-libreoffice/libreoffice/instdir/'
result: /tmp/OSL_PIPE_1000_SingleOfficeIPC_519e59a99639aa84d1279b4bc9799ca
Failed to connect to pipe: /tmp/OSL_PIPE_1000_SingleOfficeIPC_519e59a99639aa84d1279b4bc9799ca
warn:vcl:4653:1:vcl/unx/generic/fontmanager/fontmanager.cxx:1343: Could not OpenTTFont "/usr/share/fonts/woff/font-awesome/fontawesome-webfont.woff"

warn:ucb.ucp.gio:4653:1:ucb/source/ucp/gio/gio_content.cxx:399: ignoring GError "Opération non prise en charge" for <>
warn:legacy.osl:4653:1:vcl/source/image/ImageList.cxx:142: ImageAryData::Load: failed to load image 'cmd/sc_displaymode.png'
warn:legacy.osl:4653:1:vcl/source/image/ImageList.cxx:142: ImageAryData::Load: failed to load image 'cmd/sc_displaymode.png'
warn:ucb.ucp.gio:4653:1:ucb/source/ucp/gio/gio_content.cxx:399: ignoring GError "Opération non prise en charge" for <.uno:NewDoc>
warn:legacy.tools:4653:1:sfx2/source/control/bindings.cxx:2124: No cache for OfficeDispatch!
warn:legacy.osl:4653:1:include/cppuhelper/interfacecontainer.h:479: object is disposed
warn:legacy.osl:4653:1:include/cppuhelper/interfacecontainer.h:479: object is disposed
warn:legacy.osl:4653:1:include/cppuhelper/interfacecontainer.h:479: object is disposed
warn:legacy.osl:4653:1:include/cppuhelper/interfacecontainer.h:479: object is disposed

Perhaps Windows only bug?
Comment 3 Usama 2016-03-16 05:06:14 UTC
Yes, I've tested it on Mater on Ubuntu 15.10 and no crash there too.

Version: 5.2.0.0.alpha0+
Build ID: aaca25d67eb5ea252730cdcf555ecc04ce04a5e6
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-02-24_23:58:47
Locale: en-US (en_US.UTF-8)
OS: Ubuntu 15.01
Comment 4 Armin Le Grand 2016-03-16 10:25:10 UTC
Could not reproduce in Version: 5.2.0.0.alpha0+ on Win7
Comment 5 Usama 2016-03-17 07:07:20 UTC
Created attachment 123644 [details]
WinDbg trace file

I've used to WinDbg to trace the crash. file attached.
Comment 6 HFM 2016-03-17 19:35:44 UTC
I don't know if this is related to this bug. Yesterday, I upgraded some LibreOffice packages (Ubuntu 15.10). After that, Impress crashed when I tried to start a slide show (with F5 or Shift+F5). It didn't even show the first slide, crashed right away. Today, I saw that there were some other LibreOffice packages to be upgraded, I upgraded those and now slide show works.
The problem started after I upgraded these packages:
 libreoffice-base-core:amd64 (5.0.5~rc2-0ubuntu2, 5.1.1~rc2-0ubuntu1~wily0)
 libreoffice:amd64 (5.0.5~rc2-0ubuntu2, 5.1.1~rc2-0ubuntu1~wily0)
 libreoffice-writer:amd64 (5.0.5~rc2-0ubuntu2, 5.1.1~rc2-0ubuntu1~wily0)
 libreoffice-impress:amd64 (5.0.5~rc2-0ubuntu2, 5.1.1~rc2-0ubuntu1~wily0)
 libreoffice-base:amd64 (5.0.5~rc2-0ubuntu2, 5.1.1~rc2-0ubuntu1~wily0)
 libreoffice-style-breeze:amd64 (5.0.5~rc2-0ubuntu2, 5.1.1~rc2-0ubuntu1~wily0)
 libreoffice-draw:amd64 (5.0.5~rc2-0ubuntu2, 5.1.1~rc2-0ubuntu1~wily0)
 libreoffice-core:amd64 (5.0.5~rc2-0ubuntu2, 5.1.1~rc2-0ubuntu1~wily0)
 libreoffice-gnome:amd64 (5.0.5~rc2-0ubuntu2, 5.1.1~rc2-0ubuntu1~wily0)
 libreoffice-style-human:amd64 (5.0.5~rc2-0ubuntu2, 5.1.1~rc2-0ubuntu1~wily0)
 libreoffice-l10n-pt-br:amd64 (5.0.5~rc2-0ubuntu2, 5.1.1~rc2-0ubuntu1~wily0)
 libreoffice-kde:amd64 (5.0.5~rc2-0ubuntu2, 5.1.1~rc2-0ubuntu1~wily0)
 libreoffice-common:amd64 (5.0.5~rc2-0ubuntu2, 5.1.1~rc2-0ubuntu1~wily0)
 libreoffice-gtk:amd64 (5.0.5~rc2-0ubuntu2, 5.1.1~rc2-0ubuntu1~wily0)
 libreoffice-java-common:amd64 (5.0.5~rc2-0ubuntu2, 5.1.1~rc2-0ubuntu1~wily0)
 libreoffice-style-tango:amd64 (5.0.5~rc2-0ubuntu2, 5.1.1~rc2-0ubuntu1~wily0)
 libreoffice-style-galaxy:amd64 (5.0.5~rc2-0ubuntu2, 5.1.1~rc2-0ubuntu1~wily0)
 libreoffice-style-oxygen:amd64 (5.0.5~rc2-0ubuntu2, 5.1.1~rc2-0ubuntu1~wily0)
 libreoffice-base-drivers:amd64 (5.0.5~rc2-0ubuntu2, 5.1.1~rc2-0ubuntu1~wily0)
 libreoffice-math:amd64 (5.0.5~rc2-0ubuntu2, 5.1.1~rc2-0ubuntu1~wily0)
 libreoffice-calc:amd64 (5.0.5~rc2-0ubuntu2, 5.1.1~rc2-0ubuntu1~wily0)

After I upgraded these, the problem went away:
 libreoffice-pdfimport:amd64 (5.0.5~rc2-0ubuntu2, 5.1.1~rc2-0ubuntu1~wily0)
 libreoffice-avmedia-backend-gstreamer:amd64 (5.0.5~rc2-0ubuntu2, 5.1.1~rc2-0ubuntu1~wily0)
 libreoffice-help-pt-br:amd64 (5.0.5~rc2-0ubuntu2, 5.1.1~rc2-0ubuntu1~wily0)
 libreoffice-sdbc-firebird:amd64 (5.0.5~rc2-0ubuntu2, 5.1.1~rc2-0ubuntu1~wily0)
 libreoffice-style-elementary:amd64 (15.10.5, 5.1.1~rc2-0ubuntu1~wily0)
 libreoffice-report-builder-bin:amd64 (5.0.5~rc2-0ubuntu2, 5.1.1~rc2-0ubuntu1~wily0)
 libreoffice-help-en-us:amd64 (5.0.5~rc2-0ubuntu2, 5.1.1~rc2-0ubuntu1~wily0)
 libreoffice-ogltrans:amd64 (5.0.5~rc2-0ubuntu2, 5.1.1~rc2-0ubuntu1~wily0)
 libreoffice-sdbc-hsqldb:amd64 (5.0.5~rc2-0ubuntu2, 5.1.1~rc2-0ubuntu1~wily0)
Comment 7 Julien Nabet 2016-03-23 20:27:53 UTC
Thomas/Usama: do you reproduce this if you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#Windows)?
Comment 8 Thomas Hehl 2016-03-24 11:51:40 UTC
Renamed profile and problem persists.
Comment 9 Caolán McNamara 2016-09-23 15:16:05 UTC

*** This bug has been marked as a duplicate of bug 100151 ***