Bug Hunting Session
Bug 98709 - DirectWrite for OpenGL incorrect glyph positioning for SMP codepoint glyphs
Summary: DirectWrite for OpenGL incorrect glyph positioning for SMP codepoint glyphs
Status: RESOLVED DUPLICATE of bug 97319
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha0+
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: OpenGL
  Show dependency treegraph
 
Reported: 2016-03-16 16:05 UTC by V Stuart Foote
Modified: 2016-03-29 22:29 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
BMP and SMP glyphs with OpenGL and DirectWrite rendering (38.49 KB, image/png)
2016-03-16 16:17 UTC, V Stuart Foote
Details
BMP and SMP glyphs with Default rendering (34.29 KB, image/png)
2016-03-16 16:18 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2016-03-16 16:05:36 UTC
On Windows 10 Pro 64-bit en-US with
Version: 5.2.0.0.alpha0+ (x64)
Build ID: 042f16a19e3d5f884759dae71264433b988df0e6
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; 
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2016-03-16_10:03:38
Locale: en-US (en_US)

The new DirectWrite implementation for OpenGL rendering seems to be mispositioning glyphs for multi-byte codepoints drawn from SMP or higher.

Multiple glyphs are being positioned a top each other when a glyph from the SMP is selected--either the Special Character dialog or as a bracketed :emoji: autocorrect entry.

Using glyphs for BMP codepoints does not cause the misplacement, but they are affected once a glyph from the SMP is inserted onto a line.
Comment 1 V Stuart Foote 2016-03-16 16:17:54 UTC
Created attachment 123629 [details]
BMP and SMP glyphs with OpenGL and DirectWrite rendering
Comment 2 V Stuart Foote 2016-03-16 16:18:22 UTC
Created attachment 123630 [details]
BMP and SMP glyphs with Default rendering
Comment 3 V Stuart Foote 2016-03-16 17:07:36 UTC
@Tor, should this be closed duplicate of bug 97319 cmts 9-10?
Comment 4 V Stuart Foote 2016-03-29 22:29:27 UTC

*** This bug has been marked as a duplicate of bug 97319 ***