Bug Hunting Session
Bug 98728 - Remember last saved location
Summary: Remember last saved location
Status: RESOLVED DUPLICATE of bug 89969
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.5.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Dialog-Remember-Settings
  Show dependency treegraph
 
Reported: 2016-03-17 15:43 UTC by hawran.diskuse
Modified: 2017-11-07 10:50 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hawran.diskuse 2016-03-17 15:43:13 UTC
When I try to save a new file (after some new files before), Calc still offer me my Documents directory.

I would expect it offers my last used directory instead to me.

Version: 5.0.5.2
Build ID: 55b006a02d247b5f7215fc6ea0fde844b30035b3
Locale: en-GB (en_US.UTF-8)

Distributor ID: Ubuntu
Description:    Ubuntu 14.04.4 LTS
Release:        14.04
Codename:       trusty
Comment 1 Buovjaga 2016-03-27 10:49:41 UTC
Not only Calc, so adjusting summary. Could not find a duplicate request for this, which is kind of strange..

Arch Linux 64-bit, KDE Plasma 5
Version: 5.2.0.0.alpha0+
Build ID: 96c1ae1d8e78ae8b9bd7d4001645cad24d62b720
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Built on March 25th 2016
Comment 2 Yousuf Philips (jay) (retired) 2016-03-27 11:31:25 UTC
We do remember the folder the last file was opened from, as a user may want to open another file within the same folder, and save as opens the folder where the current file is stored, but would a user expect to save a new document in the same folder as a previous saved document was saved in?

For me it could go either way, as the new file i wanted to save could be unrelated to the previous file i saved, so opening the My Documents folder where all my documents are likely stored in would be the best place to start.
Comment 3 V Stuart Foote 2016-03-27 16:38:44 UTC
This issue seems rather similar to bug 89969 - "Current directory selection"

Believe the handling of filepicker/folderpicker is handled differently for Linux, OS X, and Windows--so actual results are OS build and DE dependent.

But also we get different behavior depending on if the dialog is for a Save/Save Copy action or is for performing a Export/Save As "conversion".

For example these two issues are Export/Save As related

bug 89192 - "FILESAVE, UI: improve export process efficiency" (it started as a Draw issue, but handling the is applicable to all modules).

bug 34303 - "PDF export predefined destination folder"  has different folderpick logic for the export to PDF

Seems like this behavior should be a bit more consistent across the UI, and should be user configurable (GUI or Expert Config).

=-refs-=
http://opengrok.libreoffice.org/xref/core/fpicker/source/
http://opengrok.libreoffice.org/xref/core/svtools/source/uno/fpicker.cxx
Comment 4 Robinson Tryon (qubit) 2016-08-25 05:49:20 UTC Comment hidden (obsolete)
Comment 5 Heiko Tietze 2017-11-07 10:50:40 UTC
Let's keep things together -> dup of bug 89969

My take is to keep the last used directory on all systems. Not only for the actual document but also when exporting a graphic as PNG, for example. There is likely a ticket about this issue.

*** This bug has been marked as a duplicate of bug 89969 ***