Download it now!
Bug 98830 - FILEOPEN DOCX Drawing object (with table) is drawn on the top of the paragraph
Summary: FILEOPEN DOCX Drawing object (with table) is drawn on the top of the paragraph
Status: RESOLVED DUPLICATE of bug 84678
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks:
 
Reported: 2016-03-23 06:26 UTC by sha
Modified: 2016-09-19 21:41 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
7th chapter is rendered wrongly (414.82 KB, application/x-zip-compressed)
2016-03-23 06:26 UTC, sha
Details
screen shot of table in 4.0.0.1 (131.45 KB, image/png)
2016-05-03 14:00 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sha 2016-03-23 06:26:27 UTC
Created attachment 123784 [details]
7th chapter is rendered wrongly
Comment 1 Buovjaga 2016-04-03 13:38:50 UTC
Confirmed.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.2.0.0.alpha0+
Build ID: 9b0069c2833313ba9fab91f45edd354ba334f94b
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Built on April 3rd 2016
Comment 2 Cor Nouws 2016-05-03 13:59:38 UTC
the problem is not present in 4.0.0.1
I will attach a screen shot
Comment 3 Cor Nouws 2016-05-03 14:00:06 UTC
Created attachment 124816 [details]
screen shot of table in 4.0.0.1
Comment 4 raal 2016-05-04 09:59:09 UTC
reproducible : Version: 4.5.0.0.alpha0+
Comment 5 Xisco Faulí 2016-08-27 16:44:34 UTC
Regression introduced in range fd8cee8c1fb34432b786d54651f33b6c961ca7fe..75ae6c9105b19cf2adf3921b4ba17b8e46f32b55
Comment 6 Xisco Faulí 2016-09-01 12:03:02 UTC
Regression introduced by

    commit d379d18666aa42031359ca8eb34b0021960347ae
    Author:     Miklos Vajna <vmiklos@collabora.co.uk>
    AuthorDate: Wed Jun 18 11:57:31 2014 +0200
    Commit:     Miklos Vajna <vmiklos@collabora.co.uk>
    CommitDate: Wed Jun 18 12:09:15 2014 +0200
    
        oox: import WPS shape with text as shape with textbox
    
        This allows having real shapes (like having rounded corners) and complex
        content (like containing a table) at the same time.
    
        WPS shapes are wrappers around drawingML markup in DOCX files, so this
        only affects the DOCX import.
    
        Change-Id: Iad1c1c61233be1c17efa1821e680927aa9587215

Adding Miklos to the CC list.
Comment 7 Xisco Faulí 2016-09-19 21:41:56 UTC
The commit that introduced this regression is the same as in bug 84678, thus closing this bug a RESOLVED DUPLICATE of 84678.

*** This bug has been marked as a duplicate of bug 84678 ***