Download it now!
Bug 99002 - FILEOPEN DOCX Text frame does not have left padding
Summary: FILEOPEN DOCX Text frame does not have left padding
Status: RESOLVED DUPLICATE of bug 84678
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.5.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DOCX-Frames
  Show dependency treegraph
 
Reported: 2016-03-31 12:22 UTC by jackolantern
Modified: 2020-05-15 16:15 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Word 2016 document to use for pdf conversion text box bug (382.00 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-03-31 12:22 UTC, jackolantern
Details
Word 2016 docx file (379.78 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-05-09 07:04 UTC, jackolantern
Details
Pdf file generated by LibreOffice (372.02 KB, application/pdf)
2016-05-09 07:05 UTC, jackolantern
Details
Screenshot of word 2016 file opened in LibreOffice. See how the text is positioned. (220.53 KB, image/jpeg)
2016-05-09 07:06 UTC, jackolantern
Details
Word 2016 file opened in word 2016. See how the text is positioned. This is how I want it to be positioned. (255.02 KB, image/jpeg)
2016-05-09 07:08 UTC, jackolantern
Details
Word 2016 file that has been converted to PDF by LibreOffice (168.30 KB, image/jpeg)
2016-05-09 07:09 UTC, jackolantern
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jackolantern 2016-03-31 12:22:00 UTC
Created attachment 123988 [details]
Word 2016 document to use for pdf conversion text box bug

I have Word 2016 document that contains a text box with some text. After conversion to pdf with the command line the text inside the textbox is not outlined correctly.
I have attached the Word 2016 document so you can reproduce the bug in the pdf conversion.
Comment 1 jackolantern 2016-04-12 07:01:10 UTC
There is no difference between opening the file in Writer and converting it to PDF. The outlining in the text box is already wrong in Writer.
Comment 2 Buovjaga 2016-04-14 12:30:53 UTC
I am looking at the file in Word 2013 and LibreOffice and I don't understand what you mean.
Please attach PDF files from Word 2016 and LibreOffice.
Comment 3 jackolantern 2016-05-09 07:04:57 UTC
Created attachment 124922 [details]
Word 2016 docx file
Comment 4 jackolantern 2016-05-09 07:05:48 UTC
Created attachment 124923 [details]
Pdf file generated by LibreOffice
Comment 5 jackolantern 2016-05-09 07:06:35 UTC
Created attachment 124924 [details]
Screenshot of word 2016 file opened in LibreOffice. See how the text is positioned.
Comment 6 jackolantern 2016-05-09 07:08:45 UTC
Created attachment 124925 [details]
Word 2016 file opened in word 2016. See how the text is positioned. This is how I want it to be positioned.
Comment 7 jackolantern 2016-05-09 07:09:25 UTC
Created attachment 124926 [details]
Word 2016 file that has been converted to PDF by LibreOffice
Comment 8 jackolantern 2016-05-09 07:12:48 UTC
Hello Buovjaga

I made some screen shots so you can see what I mean. I also added the Word 2016 docx file and the pdf generated by LibreOffice. If you have more questions let me know.
Comment 9 Buovjaga 2016-05-09 10:58:40 UTC
Ok, the text in the frame should be left-padded a bit. In LibO, it is right next to the left border of the frame.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha1+
Build ID: 3d27afd26f7b85c46a7c7d08498000b9dbcea1c8
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-05-09_02:42:15
Locale: fi-FI (fi_FI)
Comment 10 QA Administrators 2017-05-22 13:39:49 UTC Comment hidden (obsolete)
Comment 11 NISZ LibreOffice Team 2020-05-14 17:13:25 UTC
Frame internal border looks good since:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=c761df1e42fd11acc5fc05b0baacd803c3788ca6

author	Miklos Vajna <vmiklos@collabora.co.uk>	2016-10-25 09:05:47 +0200
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2016-10-25 09:32:01 +0000

tdf#84678 DOCX import: fix handling of textbox margins

*** This bug has been marked as a duplicate of bug 84678 ***