Bug 99023 - [FORMATTING, FILESAVE] Missing text background when saved as .doc (in MSO 2007 + 2016)
Summary: [FORMATTING, FILESAVE] Missing text background when saved as .doc (in MSO 200...
Status: RESOLVED DUPLICATE of bug 138345
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.0.beta3
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:doc, regression
Depends on:
Blocks: DOC
  Show dependency treegraph
 
Reported: 2016-04-01 13:31 UTC by Nicolas Mailhot
Modified: 2021-03-17 09:28 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
testcase (85.71 KB, application/vnd.oasis.opendocument.text)
2016-04-01 13:31 UTC, Nicolas Mailhot
Details
sample .doc with text highlightning (9.00 KB, application/msword)
2019-12-28 13:22 UTC, Roman Kuznetsov
Details
Screenshot from MSO 2007 (80.47 KB, image/jpeg)
2019-12-28 13:23 UTC, Roman Kuznetsov
Details
Stripped down testcase (70.52 KB, application/vnd.oasis.opendocument.text)
2019-12-29 02:39 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas Mailhot 2016-04-01 13:31:07 UTC
Created attachment 124010 [details]
testcase

The attached testcase, when saved as .doc and opened in word 2007, is missing blue text background on page 3 for example

As a result the white-on-blue text becomes white on white and vanishes
Comment 1 raal 2016-04-04 19:35:30 UTC
I can confirm with Version: 5.2.0.0.alpha0+
Build ID: ef34535ceb60d7d63b8d8671e4c6e9e43ffbd17d
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-03-27_09:53:05

works in LibreOffice 3.5.0, regression
Comment 2 raal 2016-04-05 10:01:48 UTC
This seems to have begun at the below commit.
Adding Cc: to Zolnai Tamás; Could you possibly take a look at this one? Thanks

ec78525bebb30d59f690b1cb2b48288fa476d95d is the first bad commit
commit ec78525bebb30d59f690b1cb2b48288fa476d95d
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Wed May 27 23:41:46 2015 -0500

    source sha:8519d51b3a06a84d0d6418651e66e9bb534f1788

    source sha:8519d51b3a06a84d0d6418651e66e9bb534f1788
author	Zolnai Tamás <zolnaitamas2000@gmail.com>	2015-03-18 09:31:11 (GMT)
committer	Zolnai Tamás <zolnaitamas2000@gmail.com>	2015-03-21 15:19:09 (GMT)
commit	8519d51b3a06a84d0d6418651e66e9bb534f1788 (patch)
tree	bba32ae5e640194ee0e2fd86e0c0a7ef16f42dbd
parent	89399a6ba7c1817dfdc7676603f3fa1106d398c5 (diff)
Char highlight: export character background to MSO formats based on settings
Comment 3 Cor Nouws 2016-05-20 15:26:36 UTC
looking at the commit, likely introduced with 5.0
Comment 4 Björn Michaelsen 2016-08-02 11:22:13 UTC
Was this retested on master? Because 587315ebd5e4417e85eb3ffafd978fcddb09b19f looks related, and possibly a fix. => NEEDINFO
Comment 5 Aron Budea 2016-08-15 04:46:51 UTC
Björn, isn't 587315ebd5e4417e85eb3ffafd978fcddb09b19f from 2015-03-21?
Raal confirmed with 5.2 master build (2016-03-27) in Comment 1.
Comment 6 Nicolas Mailhot 2016-08-24 12:37:14 UTC
Still broken in 5.2.0.4 (x86_64, windows)
Comment 7 Xisco Faulí 2017-05-31 08:37:57 UTC
Please read: https://bugs.documentfoundation.org/show_bug.cgi?id=107793#c4

*** This bug has been marked as a duplicate of bug 107793 ***
Comment 8 Tamás Zolnai 2017-05-31 11:44:39 UTC
(In reply to Xisco Faulí from comment #7)
> Please read: https://bugs.documentfoundation.org/show_bug.cgi?id=107793#c4
> 
> *** This bug has been marked as a duplicate of bug 107793 ***

It's not a duplicate. If I open the saved DOC with LO or with MSO 2013 the highlighting is there.
I don't see what causes the issue, but it might be some difference how MSO 2007 handles highlighting property. A workaround can be not to export LO highlighting as MSO highlighting, but as MSO shading. You can change this at Tools -> Options -> Load/Save -> Microsoft Office.
Comment 9 Tamás Zolnai 2017-05-31 11:46:23 UTC
(In reply to Tamás Zolnai from comment #8)
> (In reply to Xisco Faulí from comment #7)
> > Please read: https://bugs.documentfoundation.org/show_bug.cgi?id=107793#c4
> > 
> > *** This bug has been marked as a duplicate of bug 107793 ***
> 
> It's not a duplicate. If I open the saved DOC with LO or with MSO 2013 the
> highlighting is there.
> I don't see what causes the issue, but it might be some difference how MSO
> 2007 handles highlighting property. A workaround can be not to export LO
> highlighting as MSO highlighting, but as MSO shading. You can change this at
> Tools -> Options -> Load/Save -> Microsoft Office.

I don't have MSO 2007, so can't test it, but MSO shading used to be imported earlier, so it must be working.
Comment 10 QA Administrators 2019-11-29 03:45:18 UTC Comment hidden (obsolete)
Comment 11 Roman Kuznetsov 2019-12-28 13:21:29 UTC
I created a test case .doc and opened it in to MSO 2007 (see attach). It looks fine.

Version: 6.5.0.0.alpha0+
Build ID: e22a3f596ce50b5166063e217d96ef674a54d380
CPU threads: 4; OS: Mac OS X 10.15.2; UI render: GL; VCL: osx; 
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded
Comment 12 Roman Kuznetsov 2019-12-28 13:22:34 UTC
Created attachment 156814 [details]
sample .doc with text highlightning
Comment 13 Roman Kuznetsov 2019-12-28 13:23:07 UTC
Created attachment 156815 [details]
Screenshot from MSO 2007
Comment 14 Roman Kuznetsov 2019-12-28 13:25:28 UTC
closed as WFM.

Nicolas, if you disagree then you feel free to reopen it. But before please retest it yourself
Comment 15 Luke 2019-12-29 02:39:42 UTC
Created attachment 156824 [details]
Stripped down testcase

Previous reduced testcase was over simplified. 

I can still reproduce this on MSO 2016 with both the original bugdoc and this stripped-down version.
Comment 16 Roman Kuznetsov 2019-12-29 08:53:08 UTC
(In reply to Luke from comment #15)
> Created attachment 156824 [details]
> Stripped down testcase
> 
> Previous reduced testcase was over simplified. 
> 
> I can still reproduce this on MSO 2016 with both the original bugdoc and
> this stripped-down version.

What's version of your LibreOffice, Luke?
Comment 17 Luke 2019-12-30 00:06:09 UTC
I can still reproduce this with Version: 6.5.0.0.alpha0+ (x64)
Build ID: 122598af564082786f01b4eafdb9f09f0cffdf5f

When my stripped-down and the original test case are saved as Word 97-2003 (.doc) and Opened in MSO 2013
Comment 18 Luke 2019-12-31 15:00:21 UTC
I have verified this bug against Word 2007, 2013, 2016 with LO 6.5. At least with current builds of LO, this does not seem to be related to the version of MS Office used for viewing.


Tamás Zolnai,
Did you test against the original test case or Roman's? I could not get any version of Word to display an exported file correctly with the *default* setting Tools -> Options -> Load/Save -> MSO : "Export as highlighting"
Comment 19 Aron Budea 2020-07-05 22:27:16 UTC
Looks fine in Word after saving as DOC with LO 7.0 beta2, Luke, Nicolas, please retest.
Comment 20 Justin L 2021-03-17 09:28:20 UTC
(In reply to Luke from comment #18)
> setting Tools -> Options -> Load/Save -> MSO : "Export as highlighting"

This is the key to reproducing the problem after 7.0 (where the default change to be "export as shading").

The blue background comes from the CHARACTER style Surbrillance. MS Word ignores w:highlight in character styles.

This is fixed in 7.2, most likely by tdf#138345 sw ms export: Char highlight: no export to char-style.  I tested with Word 2016.

*** This bug has been marked as a duplicate of bug 138345 ***