Bug 99059 - Simplify and upgrade the page numbering system
Summary: Simplify and upgrade the page numbering system
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Fields-Page-Number
  Show dependency treegraph
 
Reported: 2016-04-03 12:09 UTC by David Kremer
Modified: 2020-04-02 09:06 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Kremer 2016-04-03 12:09:31 UTC
Hello everybody, this request for enhancement has been carefully thinked after I encounter major drawbacks in the numbering system of libreoffice.

I found it *way* to complex, and absolutely difficult to deal with for 

* skipping arbitrary page in the numbering of your document
* simply reinitialize the page numbering at any point of your document


Basically, page numbering is just a counter that increments at each new page.

Here are some suggestions to help relieving libreoffice of its drawbacks :

-- 

* Simplify and upgrade the page style system. The page style should not depend on the previous page as it is already the case. 

* The page style should be editable for any single page (ie, you should be able to easily 
  - create new style
  - assign this new style to a given page
  - change the page style for each page of a document without other effect than updating the page numbering of the rest of the document

* The page style should maintain all the information about the numbering. If one want to reinitialize the numbering arbitrary at a given page for a given page style, it should subsequently update the following page number for pages of this given style.

--

Let me conclude : 

the page style system is actually way too clumsy to work efficiently and to be simple and intuitive from the user point of view. See above suggestions for improvement.
Comment 1 Buovjaga 2016-04-10 16:19:30 UTC
Moving to UX.
Comment 2 Heiko Tietze 2016-04-11 07:17:50 UTC
I guess you figured out finally how to restart the page numbering (paragraph > text flow > breaks...). What did you expect exactly? Something like right click the inserted page number with access to a special dialog?

Please add use cases for the two requirements. For example, "I want to hide the page number on some pages to ...". This shows the relevance of your request since it sounds not too interesting for the majority of users.

And please keep in mind that we rely on ODF (http://docs.oasis-open.org/office/v1.2/os/OpenDocument-v1.2-os-part1.html#element-text_page-number). Not everything is possible.
Comment 3 RGB 2016-04-13 11:47:26 UTC
Writer is not a page layout program like Scribus, but it is centred on "content flow": the content defines how pages are used and not the other way round. In fact, page breaks on Writer are a paragraph/object property (Text flow tab on the paragraph/object format or style definition), not a page property. 

With a 320 pages Writer document opened right now behind my browser (and the other 400+ pages Writer documents on my hard drive) I think the page numbering system used by Writer is great, far better and powerful than Word's system. It's not perfect, of course, but there are already other reports about its problems (linked page styles, for example...).

I think you are looking for a DPT tool like Scribus, something that Writer will never be: Writer is for a different kind of documents were automated formatting is far more important than manual adjustments. 

*Almost Off Topic note*: it would be possible to turn Draw into a simple DPT tool by adding to it text frames (not just text boxes as it have now, but full frames like in Writer) and the possibility to use different page styles on the same document. Not sure if someone else have already proposed something like this (or if it's even possible): if not, this is your chance :)
Comment 4 David Kremer 2016-04-13 14:16:48 UTC
Mm, sorry. What I thought is that the page numbering should behave a little bit like in Latex, with the explicit possibility to create new counters (supposingly attached to a given page style) or to reset a counter.

I just noted that my problem with page numbering was that an export to PDF does not have the same numbering as the one in LibreOffice (I should open a new bug report, this is a different topic).

However, yes, the current method to deal with page numbering is a little bit clumsy.

The method to deal with page style is also a little bit clumsy and counter-intuitive from the user point of view in my humble opinion.

I don't know, if some users are sharing this point of view, why not upgrade this ? I don't mean to change the core system, but to adapt the user interface to have something more explicit and user friendly.

Just a suggestion.
Comment 5 David Kremer 2016-04-13 14:23:44 UTC
As for user test case, I see plenty :


Situation 1 :
=============

Imagine that I want to write a document with the first three pages not numbered, because they are title-like page, each chapter page being not numbered.

#1, #2, #3 : no numbering, because "title-like pages"

#4 : chapter title page, not included in numbering

#5, #6, #7, #8 : numbered as 1/8, 2/8, 3/8, 4/8

#9 : chapter title page, not included in numbering

#10, #11, #12, #13 : numbered as 5/8, 6/8, 7/8, 8/8

I think it is possible to do such a thing with libreoffice, although a bit tricky. I'll try to fill an example with lorem ipusm to see if everything comes fine.
Comment 6 Yousuf Philips (jay) (retired) 2016-04-13 21:33:33 UTC
Hi David,

I believe if you've created the various page styles you want in your document and use Insert > Manual Break's style drop down menu and change page number field, you should easily be able to create the document you mentioned in comment 5.

(In reply to Heiko Tietze from comment #2)
> I guess you figured out finally how to restart the page numbering (paragraph
> > text flow > breaks...).

Never knew that route. :D
Comment 7 Robinson Tryon (qubit) 2016-08-25 05:49:39 UTC Comment hidden (obsolete)
Comment 8 Heiko Tietze 2020-04-02 09:06:51 UTC
Page numbering in combination with page style is a powerful tool. And if we change something it has to comply with the format definition to allow cross-application consistency. You may use fields for special cases perhaps using an extension.