Bug Hunting Session
Bug 99141 - Text written in AndikaFrenchTight-R Font disappears when printing
Summary: Text written in AndikaFrenchTight-R Font disappears when printing
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.1.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.2.0 target:5.1.4
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2016-04-07 15:33 UTC by Thierry Seewald
Modified: 2016-10-25 19:02 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Font causing the pb. (1.34 MB, application/x-font-ttf)
2016-04-07 15:33 UTC, Thierry Seewald
Details
file with two fonts, andika causing the pb. (35.29 KB, application/vnd.oasis.opendocument.text)
2016-04-07 15:35 UTC, Thierry Seewald
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thierry Seewald 2016-04-07 15:33:43 UTC
Created attachment 124165 [details]
Font causing the pb.

Hi,
I use a peculiar font andika-frentight, made up from andika font.
Since recently (2.1.1?) everything worked fine.
But currently, when I print, the parts or the file using these font are blank on the paper (parts using another font (times new roman, arial ... show up fine).
When I make a .doc file and print it with ms-word, it's ok,
When I make a .pdf file and print it it's okay,
it's only when printing the file with LOO that it does not work.

attached : 
- the font

ps I would like to send you a file example, but it seems I can only attach one file so I choose the font file.

regards
Comment 1 Thierry Seewald 2016-04-07 15:35:14 UTC
Created attachment 124166 [details]
file with two fonts, andika causing the pb.
Comment 2 Buovjaga 2016-04-21 08:55:52 UTC
Confirmed with PDF printer. It works in 5.0.2.2.

Win 7 Pro 64-bit, Version: 5.1.2.2 (x64)
Build ID: d3bf12ecb743fc0d20e0be0c58ca359301eb705f
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: fi-FI (fi_FI)
Comment 3 Thierry Seewald 2016-04-23 16:40:14 UTC
I have made a test with the andika regular font.

It has the same pb : not printing with libreoffice, but printing with ms-word and works when making a pdf file with the libreoffice built-in pdf maker (but not when using pdfcreator in libreoffice).
Comment 4 Thierry Seewald 2016-04-25 05:46:06 UTC
I think "Bug 99207 - Graphite fonts render in negative colors" which also affect Andika font (and which I also have (discovered today)) is related.
Regards
Comment 5 tomaskeb 2016-04-28 16:38:58 UTC

*** This bug has been marked as a duplicate of bug 99207 ***
Comment 6 Tim Eves 2016-05-02 04:01:52 UTC
(In reply to tomaskeb from comment #5)
> 
> *** This bug has been marked as a duplicate of bug 99207 ***
Whilst this bug is in the same body og new code that bug 99207 is in, it's not caused by the same error, so I'm removing it as a duplicate. In addition it has already been fixed in commit 0eea1465a06119903fca5f5b6dfe5b05a80546ba tagged for libreoffice-5.2.0.0.alpha1. I'll ask for it to be applied to 5.1.