Download it now!
Bug 99150 - Writer freezes when changing font (gen and gtk backends)
Summary: Writer freezes when changing font (gen and gtk backends)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.5.2 release
Hardware: All Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Fonts GTK2
  Show dependency treegraph
 
Reported: 2016-04-08 06:54 UTC by Hakeem
Modified: 2017-08-02 19:18 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hakeem 2016-04-08 06:54:07 UTC
OS: Ubuntu 14.04 (i386 and amd64), Gnome flashback.
LibreOffice Version: 5.0.5 and 5.1.1
Writer and Calc freeze when change the font of selected text. Selecting the font again solves the problem.
Comment 1 raal 2016-04-19 10:18:24 UTC
No repro 5.0.5.2, Unity

Please try to run writer with different backends:
 SAL_USE_VCLPLUGIN=gtk lowriter
SAL_USE_VCLPLUGIN=gen lowriter
SAL_USE_VCLPLUGIN=gtk3 lowriter

if it makes better.
Comment 2 Buovjaga 2016-04-21 09:01:11 UTC
Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided more information.
Comment 3 QA Administrators 2016-11-08 12:21:19 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2016-12-07 12:24:04 UTC Comment hidden (obsolete)
Comment 5 Guillaume 2017-01-27 16:03:49 UTC
Hi. I can reproduce this issue using LibreOffice Calc. 

Since this appears to affect multiple programs, I changed the product from "Writer" to "LibreOffice".

As requested by raal, I have tried reproducing this with different backends, the results are: 

SAL_USE_VCLPLUGIN=gtk localc -> freeze
SAL_USE_VCLPLUGIN=gen localc -> freeze for several seconds, then unfreeze, then freeze again in loops
SAL_USE_VCLPLUGIN=gtk3 localc -> no freeze

Software versions: 

* LibreOffice Version: 5.2.4.2.1+
* LibreOffice Build ID: 1:5.2.4-2
* Gnome Shell version: 3.22.2
* OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile 
* OpenGL core profile version string: 3.3 (Core Profile) Mesa 13.0.3
* OpenGL version string: 3.0 Mesa 13.0.3
* Operating system: Debian GNU/Linux testing
Comment 6 Buovjaga 2017-01-27 16:15:06 UTC
Guillaume: thanks. You could try getting a valgrind log of the trace: https://wiki.documentfoundation.org/QA/BugReport/Debug_Information

Note that you need debug symbols.

To get the valgrind log, after entering the frozen state, you can kill the soffice process.
Comment 7 Guillaume 2017-01-27 16:35:34 UTC
Debug informations are not available for Debian testing amd64. Sorry, I can't install them. 

https://packages.debian.org/search?keywords=libreoffice-calc-dbgsym
Comment 8 Buovjaga 2017-01-27 16:42:15 UTC
(In reply to Guillaume from comment #7)
> Debug informations are not available for Debian testing amd64. Sorry, I
> can't install them. 
> 
> https://packages.debian.org/search?keywords=libreoffice-calc-dbgsym

Ok, you could try this, if you have enough disk space: http://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@70-TDF-dbg/current/
You can just extract it with tar -xvzf and then run program/soffice
Comment 9 Guillaume 2017-06-25 17:01:20 UTC
I think I forgot to reply when the test was suggested.

So the result was:
I could not reproduce when I ran a daily build back in february.

Guillaume
Comment 10 Buovjaga 2017-06-25 17:49:58 UTC
(In reply to Guillaume from comment #9)
> I think I forgot to reply when the test was suggested.
> 
> So the result was:
> I could not reproduce when I ran a daily build back in february.

Ok that is promising. Maybe you can try 5.4 when it is released later this summer: https://wiki.documentfoundation.org/ReleasePlan/5.4#5.4.0_release
Comment 11 Guillaume 2017-08-02 19:00:11 UTC
Libreoffice 5.4 is available today in Debian buster -aka testing. 

I could not reproduce the issue in Libreoffice 5.4 on Debian buster :)
Comment 12 Buovjaga 2017-08-02 19:07:45 UTC
(In reply to Guillaume from comment #11)
> Libreoffice 5.4 is available today in Debian buster -aka testing. 
> 
> I could not reproduce the issue in Libreoffice 5.4 on Debian buster :)

Fantastic news as freezing is a serious issue. Let's close as WFM.