Bug Hunting Session
Bug 99229 - Scroll bar redraws incorrectly on scroll (Adwaita, GTK+ 3.20)
Summary: Scroll bar redraws incorrectly on scroll (Adwaita, GTK+ 3.20)
Status: RESOLVED DUPLICATE of bug 98726
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.1.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-11 19:04 UTC by hg.crazed
Modified: 2016-04-23 11:48 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Illustration of redraw problem (256.74 KB, image/gif)
2016-04-11 19:04 UTC, hg.crazed
Details

Note You need to log in before you can comment on or make changes to this bug.
Description hg.crazed 2016-04-11 19:04:47 UTC
Created attachment 124260 [details]
Illustration of redraw problem

In the previous last-most recent version of libreoffice-fresh from the archlinux extra repository, the scrollbar didn't appear at all. In the latest update, the bar is present, but does not redraw properly (the bar "paints" the pane as it move, not erasing its prior position). This occurs in all applications in the LibreOffice suite.

Using adwaita theme on gnome 3.20.1 (gtk3 is 3.20.2).

GIF representing problem attached (please ignore black bar on left; problem with screen capture, not LibreOffice rendering).
Comment 1 Roberto 2016-04-11 21:19:06 UTC
Same issue here. Using LibreOffice 5.1.2.2.0+ (compilation ID 5.1.2.2 Arch Linux build-1), on Antergos (an Archlinux-based distro), 64 bits.
Comment 2 parchd 2016-04-14 17:07:58 UTC
Confirmed here too. Same build and distribution.
Comment 3 ailin.nemui 2016-04-18 13:55:17 UTC
hi, can you confirm if you're also affected by #99319 ? I can confirm the scrollbar issue on opensuse
Comment 4 Volker Sobek 2016-04-18 14:31:40 UTC
The scroll bar is broken on fedora 24 as well with these versions:
libreoffice-base-5.1.2.1-4.fc24.x86_64
gtk3-3.20.3-1.fc24.x86_64

Bug for fedora 24 with video attached:
https://bugzilla.redhat.com/show_bug.cgi?id=1328101
Comment 5 Caolán McNamara 2016-04-18 16:41:21 UTC
probably a dup of #98726 but now affecting a main stream theme
Comment 6 hg.crazed 2016-04-18 18:16:30 UTC
(In reply to ailin.nemui from comment #3)
> hi, can you confirm if you're also affected by #99319 ? I can confirm the
> scrollbar issue on opensuse

Hi, yes, I'm also affected by that bug.
Comment 7 Caolán McNamara 2016-04-23 11:48:50 UTC

*** This bug has been marked as a duplicate of bug 98726 ***