Download it now!
Bug 99294 - Words autocompleting without pressing Enter (or arrow button)
Summary: Words autocompleting without pressing Enter (or arrow button)
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: AutoCorrect-Complete
  Show dependency treegraph
 
Reported: 2016-04-14 12:26 UTC by mikhail.maidin
Modified: 2016-10-19 23:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mikhail.maidin 2016-04-14 12:26:17 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0 Iceweasel/38.7.1
Build Identifier: LibreOffice 5.1.2.1.0

Word completion function turned off. Autoinput function also turned off. But when I type in cell some words that i have typed before Calc autocomplete input after 3-4 letters and ends cell editing process and also select 2 to 4 cells to the right or to the left including edited cell. So, for example if I want to type the word "react" and don't watch on the screen I will get only "t" because Calc ends the word, ends input, select 4 cells and when I press last "t" letter I start editing the first of selected cells.

Reproducible: Always




[Information automatically included from LibreOffice]
Locale: en-US
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes


Reset User Profile?No
Comment 1 raal 2016-04-14 14:33:19 UTC
Please could you write step by step instruction how to reproduce the bug? Thanks
Comment 2 mikhail.maidin 2016-04-15 09:48:39 UTC
I just type any word and if this word have been typed before, it completes without my command. Then I see 4 selected cells in a row including edited cell.
Comment 3 Buovjaga 2016-04-26 10:09:40 UTC
Does this happen only, when: "Word completion function turned off. Autoinput function also turned off."?
How do you turns these off?
Comment 4 mikhail.maidin 2016-05-03 19:01:26 UTC
unticking "Tools/AutoInput" option
unticking everything in "Tools/AutoCorrect Options..."

But this bug seems doesn't depends on this options. Maybe it is due to something in Mate DE?
Comment 5 raal 2016-05-11 08:20:18 UTC
Tested turn off autoinput and for me it works as intended.

For the test, could you rename your LibreOffice directory profile (see https://wiki.documentfoundation.org/UserProfile) and give it a new try? Thank you
Comment 6 mikhail.maidin 2016-05-14 12:27:13 UTC
I renamed the folder "/home/<user name>/.config/libreoffice/4/user",
started Calc, and the bug still there.
Also updated office to 5.1.3.2
Comment 7 mikhail.maidin 2016-07-13 09:23:55 UTC
All this shit is due to xneur!