Bug Hunting Session
Bug 99339 - FORMATTING: Add text wrapping around images in Draw
Summary: FORMATTING: Add text wrapping around images in Draw
Status: RESOLVED DUPLICATE of bug 35563
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval, needsUXEval
Depends on:
Blocks: DTP Draw-Images
  Show dependency treegraph
 
Reported: 2016-04-16 03:18 UTC by Dave Koelmeyer
Modified: 2017-11-01 21:31 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Koelmeyer 2016-04-16 03:18:34 UTC
As far as I can tell based on a look at all available options and other forum posts online, there is no way to wrap text around another object such as an image in an easy and intuitive way.

By "easy and intuitive" I mean a text wrap setting + options, such as what is present in Writer (or if we have to perform a comparison what is also found in Microsoft Publisher).

An example use case would be a newsletter containing text boxes into which an image is inserted. The text should wrap around the object automatically (with user control over wrapping options).

The workarounds available (custom shapes+aligning to contours) are user-hostile and labour intensive by comparison.
Comment 1 Heiko Tietze 2016-04-27 10:58:00 UTC
This feature was requested frequently in the recent survey, reference to meta bug set.

I'm not sure if your suggestion to adopt the text wrapping options is enough. It would be okay for rectangular objects such as images but not in case of circles and polylines. What we need is "wrap around object" which ignores the boundary but takes the object's outline.

Keeping status as unconfirmed unless feasibility is clear -> needsDevEval
Comment 2 Dave Koelmeyer 2016-04-27 11:21:36 UTC
I agree yes, and as I was reading back over my original bug description today it should indeed be wrapping around objects which is needed.
Comment 3 Yousuf Philips (jay) (retired) 2016-04-27 18:27:13 UTC
As objects are stacked one on top of the other in layers, two objects dont reside on the same layer, so there isnt any interaction between them, as you have in writer.

Tried different methods to achieve text wrapping and the only means i could figure out was to draw a polygon shape and added text inside of it.
Comment 4 Regina Henschel 2017-11-01 21:31:53 UTC

*** This bug has been marked as a duplicate of bug 35563 ***