Bug 99410 - SEH Exception ILLEGAL INSTRUCTION on new document create
Summary: SEH Exception ILLEGAL INSTRUCTION on new document create
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.1.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Markus Mohrhard
QA Contact:
URL:
Whiteboard: target:5.3.0 target:5.2.0.1
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2016-04-20 09:33 UTC by mezencevrv
Modified: 2016-10-25 18:54 UTC (History)
6 users (show)

See Also:
Crash report or crash signature: ["`anonymous namespace'::doubleToString<`anonymous namespace'::UStringTraits,_rtl_uString>(_rtl_uString * *,long *,long,double,rtl_math_StringFormat,long,wchar_t,long const *,wchar_t,bool)"]


Attachments
event windows log (458.00 KB, image/png)
2016-04-20 09:33 UTC, mezencevrv
Details
memory dump (4.17 MB, application/vnd.tcpdump.pcap)
2016-04-20 09:36 UTC, mezencevrv
Details
stack trace of the dump with 64-bit symbols (21.29 KB, text/plain)
2016-04-20 13:48 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mezencevrv 2016-04-20 09:33:44 UTC
Created attachment 124524 [details]
event windows log

At the 4 computers (from 100) in our organization reproduced an error: when create a new document application is terminated with an error:

SEH Exception ILLEGAL INSTRUCTION

Configuration:
OS: Windows 7 SP1
CPU: Intel Core i5-4570T

I took a dump in error and open in VS2013:

The thread tried to execute an invalid instruction.
msvcr120.dll!log10() Line 420

Disassembly:
000007FEF0C93143 vpsrlq xmm3,xmm0,34h
Comment 1 mezencevrv 2016-04-20 09:36:12 UTC
Created attachment 124526 [details]
memory dump
Comment 2 mezencevrv 2016-04-20 09:38:24 UTC
I think it is connected with
https://connect.microsoft.com/VisualStudio/Feedback/Details/981479
Comment 3 raal 2016-04-20 10:43:09 UTC
Hello,

Thank you for filing the bug. For the test, could you rename your LibreOffice directory profile (see https://wiki.documentfoundation.org/UserProfile) and give it a new try?
Comment 4 mezencevrv 2016-04-20 11:00:33 UTC
After renaming the same error
Comment 5 V Stuart Foote 2016-04-20 13:48:15 UTC
Created attachment 124533 [details]
stack trace of  the dump with 64-bit symbols

For what it is worth, here is a stack trace with symbols and analysis of the dump.
Comment 6 Julien Nabet 2016-04-20 22:09:41 UTC
Tor Thought you might be interested in this one.
Indeed, according to http://opengrok.libreoffice.org/search?q=avx&project=core&defs=&refs=&path=&hist=, avx seems disabled, so it might confirm https://bugs.documentfoundation.org/show_bug.cgi?id=99410#c2
Now, I don't know why only 4 computers (on 100) would be impacted.

mezencevrv: is there any specific difference (hardware or software) between the 4 and the others?
Comment 7 mezencevrv 2016-04-21 05:05:13 UTC
I found several completely identical pc (this lenovo c560)
have completely identical equipment, one of them does not work libreoffice. 

aida64 shows that:

IA AVX Support, Forbidden
IA AVX2 Support, Forbidden

I do not know how to turn on AVX. I used the command (bcdedit /set xsavedisable 0), but it does not help.
Comment 8 mezencevrv 2016-04-21 06:38:30 UTC
I found differences in the software. I gave incorrect data on machines running Windows 7 without the service pack 1, and therefore not working AVX.
Comment 9 V Stuart Foote 2016-04-29 12:23:43 UTC
@mezencevrv,

Did you resolve by applying Win7 SP1 (or reloading) those systems that were having the exception?
Comment 10 mezencevrv 2016-04-29 14:08:32 UTC
the problem is solved applying sp1, avx instructions are now working
Comment 11 Julien Nabet 2016-04-29 14:09:30 UTC
Thank you for your feedback, let's put this one to WFM then.
Comment 13 Markus Mohrhard 2016-06-15 21:21:30 UTC
I have a fix that I'm currently testing in a 64 bit build. This bug only affects 64 bit builds.
Comment 14 Commit Notification 2016-06-15 22:49:22 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4f32fcf59854fe1abe375c8702cc5c4258abbf3d

work around MSVCR2013 bug around AVX, tdf#99410

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2016-06-16 00:49:33 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=638e149eb6740bfec22cec9f0511e1471a99bb5a&h=libreoffice-5-2

work around MSVCR2013 bug around AVX, tdf#99410

It will be available in 5.2.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2016-06-18 14:25:32 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=909d87cc6187ecffa2704e67ffbe372fd2d90e49

move the code for tdf#99410 to the sal init windows code

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2016-06-20 00:42:49 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e076dca074a581480046b37485ea3f5f8184c247&h=libreoffice-5-2

move the code for tdf#99410 to the sal init windows code

It will be available in 5.2.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.