Download it now!
Bug 99416 - Copy/paste and adding/removing columns or lines is slow
Summary: Copy/paste and adding/removing columns or lines is slow
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.1.3 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf
Depends on:
Blocks: Cell-Management
  Show dependency treegraph
 
Reported: 2016-04-20 14:02 UTC by Sébastien Guyader
Modified: 2017-11-24 19:10 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Table in Writer (19.29 KB, application/vnd.oasis.opendocument.text)
2016-04-20 14:02 UTC, Sébastien Guyader
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sébastien Guyader 2016-04-20 14:02:06 UTC
Created attachment 124534 [details]
Table in Writer

I created a table writer (72 lines by 20 columns). When trying to copy/paste a selection, or to add/remove a line or column, Writer freezes for quite a long time, taking one full CPU thread to accomplish the job.
Examples:
- copy/paste a selection of 18 lines by 10 columns takes 42 seconds
- adding a line takes 5 seconds, but undoing this (ctrl+z) took more than 2 minutes.

The computer (Toshiba laptop):
- 4 GB Ram (more than 2 GB free during the test)
- Intel i5 2520m CPU (2.5 GHz, 2 cores, 4 threads)
- uname -a: Linux sgport 4.4.6-1-MANJARO #1 SMP PREEMPT Sat Mar 19 06:00:37 CET 2016 x86_64 GNU/Linux

Libreoffice binary is installed from the Arch linux "extra" repository (libreoffice-fresh).
Comment 1 Buovjaga 2016-05-01 11:12:07 UTC Comment hidden (obsolete)
Comment 2 Telesto 2017-03-23 18:23:19 UTC
I can't confirm the initial report (related to 5.1.2.2) but I do notice a decrease in performance in LibO5.4

Steps to reproduce:
1. Open attached file
2. Select a row/column within the table
3. Click multiple times on rows above below (or add multiple columns).

Actual results
Compared to Libo5.3Alpha everything a bit slow responding

---
Found in
Version: 5.4.0.0.alpha0+
Build ID: 1670cc25bc2771e87f7956a4b0dd634abaa4128b
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-03-22_23:28:42
Locale: nl-NL (nl_NL); Calc: CL

and in
Versie: 5.3.0.2 
Build ID: 5ad7b2889021c491af62f7930a4b1cb631392f16
CPU Threads: 4; Versie besturingssysteem:Windows 6.2; UI Render: GL; Layout-Engine: nieuw; 
Locale: nl-NL (nl_NL); Calc: CL

but not in
Version: 5.3.0.0.alpha1
Build ID: f4ca1573fcf445164c068c1046ab5d084e1b005f
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 3 Buovjaga 2017-03-26 17:17:13 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2017-03-26 17:17:34 UTC
I recommend this to anyone experiencing slowness: https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_callgrind_trace
Comment 5 Buovjaga 2017-03-27 16:52:12 UTC
Apologies, I did not read carefully enough. I failed to notice how you said 5.3.0.2 already shows the slowness.

Now I tested with these:

Version: 5.4.0.0.alpha0+ (x64)
Build ID: 193f8966135064a32164c9da08d01dab9c1fc15d
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-03-25_02:08:45
Locale: fi-FI (fi_FI); Calc: group

Version: 5.3.0.0.alpha1 (x64)
Build ID: f4ca1573fcf445164c068c1046ab5d084e1b005f
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
Locale: fi-FI (fi_FI); Calc: group

..and I do notice a slight lag with 5.4 compared with 5.3 alpha. The way I do it is to click'n'drag up and down with the row selection.. so it continously selects rows.
Comment 6 halima 2017-08-10 03:12:50 UTC
I did not experienced the slowness of the new version

I compared it with those two version

Version: 5.4.0.3 (x64)
Build ID: 7556cbc6811c9d992f4064ab9287069087d7f62c
Threads CPU : 4; OS : Windows 6.19; UI Render : par défaut; 


Version: 5.3.5.2
Build ID: 50d9bf2b0a79cdb85a3814b592608037a682059d
Threads CPU : 4; OS : Windows 6.2; UI Render : par défaut; Layout Engine: new;
Comment 7 Xisco Faulí 2017-11-24 18:13:34 UTC Comment hidden (obsolete)
Comment 8 Sébastien Guyader 2017-11-24 19:03:49 UTC
It looks like the issue is solved (Version: 5.4.3.2; Build ID: 5.4.3-1; CPU threads: 4; OS: Linux 4.14; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.utf8); Calc: group)

I'm changing the status to resolved. Thanks!