Download it now!
Bug 99435 - Most tool bar buttons are useless
Summary: Most tool bar buttons are useless
Status: RESOLVED DUPLICATE of bug 92218
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL: https://bugs.launchpad.net/ubuntu/+so...
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2016-04-21 13:51 UTC by Alberto Salvia Novella
Modified: 2016-04-21 21:10 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alberto Salvia Novella 2016-04-21 13:51:49 UTC
Most tool bar buttons are never or rarely used.

Only frequently used buttons shall be shown by default. And only when it is not more intuitive than the right click menu, like when copying and pasting or per object action.

The status bar can also be hidden in some of these applications, the same as the sidebar contracted by default.

Here are some suggested defaults:
https://launchpadlibrarian.net/254847787/Writer.png
https://launchpadlibrarian.net/254849290/Impress.png
https://launchpadlibrarian.net/254846207/Calc.png
https://launchpadlibrarian.net/254849096/Math.png

Good interface design shows what is currently in use in that very moment, or used constantly. And gets rid of everything else.
Comment 1 V Stuart Foote 2016-04-21 14:22:25 UTC
Hi Alberto, thanks for posting.

But, would observe that if they were useless--button widgets (and other toolbar GUI controls)--they would not exist to link to the .uno commands they control.

Would say this is back to our ongoing Benjamin vs. Eve discussion. What minimum set of features should be presented in a default UI to provide a well functioning and intuitive UI but at the same time not annoy experienced users by requiring excessive UI customization beyond defaults.

And of course this is compounded by our hybrid mix of static and dynamic or modal toolbars that assert depending on the object with focus--or task being performed.

So, hope you see that handling Toolbar default configurations are not as simple as you have put forward.
Comment 2 V Stuart Foote 2016-04-21 14:30:40 UTC
As it is against Ubuntu "Wily Werewolf" setting version to 5.0.2.2
Comment 3 Alberto Salvia Novella 2016-04-21 15:34:20 UTC
Sure all these features have some functionality to someone. But the idea here is to keep at view features that are only used right in that moment, or use constantly by most people. Then allow users to freely change things if they have uncommon needs.

Also note that any improvement takes a side apart from what is common till that moment, and that inherently means taking the risk of disappointing someone. So I would pursue satisfying 90% of people, instead of 99%.

(https://gettingreal.37signals.com/ch04_Make_Opinionated_Software.php)
Comment 4 Yousuf Philips (jay) (retired) 2016-04-21 18:14:48 UTC
seems similar to the single toolbar concept i'm working on in bug 92218.
Comment 5 Cor Nouws 2016-04-21 20:14:41 UTC
(In reply to Yousuf (Jay) Philips from comment #4)
> seems similar to the single toolbar concept i'm working on in bug 92218.

May be. But does it make sense to keep this issue alive? Better direct input to the place where it is used..
Comment 6 V Stuart Foote 2016-04-21 21:10:45 UTC
OK then, duping it off to bug 92218

*** This bug has been marked as a duplicate of bug 92218 ***