Bug Hunting Session
Bug 99460 - layout splits table that is followed by fly frame across many pages
Summary: layout splits table that is followed by fly frame across many pages
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:5.2.0 target:5.1.4
Keywords:
Depends on:
Blocks: Matters-to-Caolan
  Show dependency treegraph
 
Reported: 2016-04-22 20:15 UTC by Michael Stahl (CIB)
Modified: 2016-10-25 19:02 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
reproducer (12.15 KB, application/vnd.oasis.opendocument.text)
2016-04-22 20:17 UTC, Michael Stahl (CIB)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Stahl (CIB) 2016-04-22 20:15:10 UTC
if a table has "Allow table to split across pages and columns" enabled
and "Allow row to break across pages and columns" disabled,
and there is a frame anchored to the paragraph following the table
that is so big that it doesn't fit in the space below the table,
then the layout will erroneously split the table into one row
per page until the last page has so few rows that the frame
fits below the table.

this is not a regression, happens since OOo 3.0.1.
Comment 1 Michael Stahl (CIB) 2016-04-22 20:17:16 UTC
Created attachment 124579 [details]
reproducer
Comment 2 Commit Notification 2016-04-27 13:55:30 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e1fc96df40cb758399ca3b6e74660f381ef16916

tdf#99460 sw: layout: don't split table before fly

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Michael Stahl (CIB) 2016-04-27 14:05:32 UTC
fixed on master

running convwatch on 2000 ODTs didn't find any change due to the fix
Comment 4 Commit Notification 2016-04-28 06:50:30 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ec1a2322b862468621ce45500d74dac252bf1714&h=libreoffice-5-1

tdf#99460 sw: layout: don't split table before fly

It will be available in 5.1.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.