Download it now!
Bug 99462 - CRASH after deleting photo album caption box
Summary: CRASH after deleting photo album caption box
Status: RESOLVED DUPLICATE of bug 99450
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.0.5.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Julien Nabet
URL:
Whiteboard: target:5.2.0 target:5.1.4 target:5.0.6
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-23 01:08 UTC by David F Smith
Modified: 2016-10-25 19:02 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
crash during closing file (140.45 KB, text/x-log)
2016-04-23 07:23 UTC, Julien Nabet
Details
could not file save (448.08 KB, image/png)
2016-04-23 08:34 UTC, Shinji Enoki
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David F Smith 2016-04-23 01:08:39 UTC
1. Create a new presentation.
2. Select the first slide, then select Blank Slide in Layouts.  (This step is probably not required.)
3. Choose Insert - Media - Photo Album.  In the Create Photo Album box, make sure "Add caption to each slide" is checked.  Click Add.  Browse and select one or more  images.  Click Insert Slides.
4. Select the new slide containing your chosen image.  There is a caption panel at the bottom of the slide, labeled "Click to add Title."  Move the mouse into that panel, but NOT over the words "Click to add Title," so that the pointer is a four-headed arrow, then click.  The panel will be outlined, with small square handles on the sides and corners.  Press the Delete key.  The panel is no longer outlined, but it is not deleted.
5. Click in the caption panel again.  LibreOffice crashes with no message.
(6. When you restart LibreOffice, it offers to recover the document, showing that it crashed unexpectedly.)

Variations:
After clicking on the caption panel, you can change its area and boundary line color, or its size and position, just like any other box.  And, of course, if you click on the words, you can enter a caption.  But if you try to delete the caption box, LibreOffice crashes the next time you click in it.  The caption panel is clearly a different animal.

If the photo album is inserted WITHOUT the "Add caption" option, there is no problem.

This bug is probably related to 99450, which describes a crash when the presentation is closed.

Windows 7 Pro SP1, v6.1.7601
Comment 1 David F Smith 2016-04-23 01:49:50 UTC
For the record, this bug also existed in v5.0.5.2.  It probably came in with that "Add caption" option on the Photo Album insert.
Comment 2 Julien Nabet 2016-04-23 07:15:51 UTC
On pc Debian x86-64 with master sources updated yesterday, I don't reproduce the crash but I noticed these logs first:
warn:vcl.gdi:7768:1:vcl/headless/svpgdi.cxx:116: non default depth bitmap, slow convert, upscale the input
warn:vcl.layout:7768:1:vcl/source/window/builder.cxx:1755: probably need to implement GtkCellRendererText or add a makeGtkCellRendererText function
warn:vcl:7768:1:vcl/source/window/builder.cxx:269: missing elements of combobox/liststore
warn:ucb.ucp.gio:7768:1:ucb/source/ucp/gio/gio_content.cxx:399: ignoring GError "Operation not supported" for <$(work)>
warn:ucb.ucp.gio:7768:1:ucb/source/ucp/gio/gio_content.cxx:399: ignoring GError "Operation not supported" for <>
warn:legacy.tools:7768:1:svx/source/svdraw/svdpage.cxx:335: ZObjekt already has the status Inserted.
warn:legacy.tools:7768:1:svx/source/svdraw/svdpage.cxx:335: ZObjekt already has the status Inserted.

then:
warn:vcl.gdi:7768:1:vcl/headless/svpgdi.cxx:99: unsupported SvpSalGraphics::blendAlphaBitmap case
warn:legacy.osl:7768:1:editeng/source/items/frmitems.cxx:464: unknown MemberId
warn:legacy.tools:7768:1:sfx2/source/control/statcach.cxx:400: setting state of dirty message
warn:vcl:7768:1:vcl/source/window/mouse.cxx:470: Window::ReleaseMouse(): window doesn't have the mouse capture

java stack trace:
	at com.sun.star.bridges.jni_uno.JNI_proxy.dispatch_call(Native Method)
	at com.sun.star.bridges.jni_uno.JNI_proxy.invoke(JNI_proxy.java:185)
	at com.sun.proxy.$Proxy21.getByIndex(Unknown Source)
	at oxygenoffice.extensions.smart.Controller.getSelectedShape(Controller.java:467)
	at oxygenoffice.extensions.smart.Controller.selectionChanged(Controller.java:243)

warn:svx:7768:1:svx/source/svdraw/svdedtv2.cxx:487: Object somehow has no ObjList
warn:vcl.layout:7768:1:vcl/source/control/fixed.cxx:423: Only endellipsis support for now
warn:legacy.osl:7768:1:include/cppuhelper/interfacecontainer.h:479: object is disposed
warn:legacy.osl:7768:1:include/cppuhelper/interfacecontainer.h:479: object is disposed
warn:vcl:7768:1:vcl/source/window/mouse.cxx:470: Window::ReleaseMouse(): window doesn't have the mouse capture
warn:vcl.gdi:7768:1:vcl/headless/svpgdi.cxx:99: unsupported SvpSalGraphics::blendAlphaBitmap case
warn:legacy.tools:7768:1:sfx2/source/control/statcach.cxx:400: setting state of dirty message
Comment 3 Julien Nabet 2016-04-23 07:23:16 UTC
Created attachment 124584 [details]
crash during closing file

I finally had a crash but during closing file.
Comment 4 Shinji Enoki 2016-04-23 08:34:53 UTC
Created attachment 124586 [details]
could not file save

I was nearly reproduced, but it was a little different.

1. Start Impress
2. Choose menu [insert]-[Media]-[Photo Album]
3. Click "Add" and Select Photo
4. Click "Insert Slides"
5. Select new slide
6. Select Photo's caption box ("Click to add Title") and delete caption box
-> The color of the caption box becomes thinner.
7. Choose menu [File]-[Save] , Click "Save" (save dialog)
-> I could not file save.
8. Click [X] Button (or Choose menu [File]-[Exit LibreOffice]
9. Click "Don't Save"
-> Crash and Launch "LibreOfficeDev Document Recovery" dialog


Env
OS: Debian jessie (64bit)
Version: 5.2.0.0.alpha1
Build ID: 902b28a39528b6c92602e9b521a1d0861be1caf9
CPU Threads: 4; OS Version: Linux 3.16; UI Render: default; 
Locale: en-US (ja_JP.utf8)
Comment 5 David F Smith 2016-04-23 19:33:13 UTC
Here's a video of the steps leading up to the crash:
https://drive.google.com/open?id=0B9HusC1zbjioVjVtLTNiWTZkZjg

Things to note:
In this video, I used Cut from the context menu instead of the Delete key.
After I attempt to Cut the caption box, its black background becomes partially transparent.
At that point, the pointer still changes back and forth between text cursor (over "Click to add Title") and four-headed arrow, but when I click the caption box with either one, LibreOffice crashes.
Comment 6 raal 2016-04-23 19:55:58 UTC
No repro Version: 5.2.0.0.alpha0+
Build ID: 5bb308a9ad16f6002486a60e4a753693818580b6
CPU Threads: 1; OS Version: Windows 6.2; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-04-20_19:07:06
crash only when closing file.
Comment 7 Julien Nabet 2016-04-23 23:03:28 UTC
This bug has the same root cause of the one I put on cc.
With the patch of the other one, the caption could be deleted and the file closed without crash.
Comment 8 Julien Nabet 2016-04-23 23:06:49 UTC

*** This bug has been marked as a duplicate of bug 99450 ***
Comment 9 Commit Notification 2016-04-24 07:16:27 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=618e7622d08b20f6ea5f38144b61a187aced86af

tdf#99450/tdf#99462: fix insert twice the same object in Photo album

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2016-04-26 15:57:57 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2aa8be5936cab3fa2a0d895b414cd0dc9dc3f319&h=libreoffice-5-0

tdf#99450/tdf#99462: fix insert twice the same object in Photo album

It will be available in 5.0.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2016-04-26 16:01:00 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ad9e36fe992868c9a5bf2b457f55b93f44843447&h=libreoffice-5-1

tdf#99450/tdf#99462: fix insert twice the same object in Photo album

It will be available in 5.1.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2016-04-26 19:47:06 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-5-0-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8dbca99ed148158924a5e4e29e43e87062f030b1&h=libreoffice-5-0-6

tdf#99450/tdf#99462: fix insert twice the same object in Photo album

It will be available in 5.0.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.