Bug Hunting Session
Bug 99500 - FILEOPEN DOCX Overflowing image displayed inconsequently
Summary: FILEOPEN DOCX Overflowing image displayed inconsequently
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Images
  Show dependency treegraph
 
Reported: 2016-04-26 00:37 UTC by csongor
Modified: 2018-07-19 14:07 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
two-page document with big X, saved from LO (16.82 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-04-26 00:37 UTC, csongor
Details
big X logo on both pages (75.91 KB, image/png)
2016-04-26 00:38 UTC, csongor
Details
big X logo on first page only (72.89 KB, image/png)
2016-04-26 00:39 UTC, csongor
Details

Note You need to log in before you can comment on or make changes to this bug.
Description csongor 2016-04-26 00:37:56 UTC
Created attachment 124631 [details]
two-page document with big X, saved from LO

I got a two-page-long report in a docx document from a colleague of mine which had been created by Microsoft Office. The document contains a huge red X log on the opening page.

If I open it in LO then the document zoom factor is 45% and the two pages are displayed besides each other. In this case the red X appears on both pages, a bit more precisely, it overflows from the left page to the right one. 

If I change the zoom factor to 50% then the pages don't fit besides each other so the second page will go under the first one. This is fine. However, in this case the red X is displayed only on the first page. 

This is quite a contradiction, I don't think the displayed elements should depend on the zoom factor.

As much as I know, the intended behaviour is to display the big X on the first page only.

I removed every textual content from the document with LO and saved back in docx. See the docx attachment. It still produces the symptom, as you can see from the two png screenshots. 

If the issue is not reproducable on other computers with the docx saved from LO then I can upload the original MSO-saved docx as well.
Comment 1 csongor 2016-04-26 00:38:45 UTC
Created attachment 124632 [details]
big X logo on both pages
Comment 2 csongor 2016-04-26 00:39:28 UTC
Created attachment 124633 [details]
big X logo on first page only
Comment 3 Buovjaga 2016-05-03 11:12:10 UTC
Confirmed.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.2.0.0.alpha1+
Build ID: 540fee2dc7553152914f7f1d8a41921e765087ef
CPU Threads: 8; OS Version: Linux 4.5; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Built on April 30th 2016
Comment 4 Aron Budea 2016-05-03 14:22:56 UTC
Repdorucable in Windows 7, too.
It seems the behavior was the same since the feature's introduction:
-no X shown in v3.6.0.4
-X is there in v4.0.0.3 with further graphical glitches,
-looks the same as now since v4.2.0.1.
Comment 5 csongor 2016-12-08 01:39:27 UTC
I checked this right now on a Mac with the following LO version:

Version: 5.1.4.2
Build ID: f99d75f39f1c57ebdd7ffc5f42867c12031db97a
CPU Threads: 8; OS Version: Mac OS X 10.12; UI Render: default; 
Locale: en-AU (en_AU.UTF-8)

The bug is still there. 
- in Single Page View the big red X is displayed only on the first page (which is the expected behaviour)
- in Multi-page View, 
    - if the zoom factor makes the pages to appear under each other then the X is displayed only on the first page
    - if the pages fit besides each other then the X is displayed on both pages.
Comment 6 QA Administrators 2018-07-19 02:40:52 UTC Comment hidden (obsolete)
Comment 7 csongor 2018-07-19 04:15:46 UTC
I tried it at my workplace with the currrently installed LO on a Mac. It seems to work fine.

Version: 6.0.4.2
Build ID: 9b0d9b32d5dcda91d2f1a96dc04c645c450872bf
CPU threads: 4; OS: Mac OS X 10.11.6; UI render: default; 
Locale: en-US (en.UTF-8); Calc: group

Within a day I will check it on my home computer as well. After that I wioll set the Status accordingly.
Comment 8 csongor 2018-07-19 14:07:08 UTC
I checked in my LO at home as well:

Version: 6.0.1.1 (x64)
Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
CPU threads: 4; OS: Windows 6.1; UI render: default; 
Locale: hu-HU (hu_HU); Calc: group

It works without any issues. 

I think the bug can be closed.

Thank you, whoever fixed it. :)