Bug Hunting Session
Bug 99624 - FILESAVE: Field cross-reference lost when saving as DOCX
Summary: FILESAVE: Field cross-reference lost when saving as DOCX
Status: RESOLVED DUPLICATE of bug 42346
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-02 11:33 UTC by Lars Jødal
Modified: 2016-05-04 15:58 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
ODT file with field and cross-reference to the field (10.06 KB, application/vnd.oasis.opendocument.text)
2016-05-02 11:33 UTC, Lars Jødal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Jødal 2016-05-02 11:33:36 UTC
Created attachment 124780 [details]
ODT file with field and cross-reference to the field

In order to get correct numbering of illustrations, I use numbered field in this way:

Insert > Fields > Other > Variable, choosing Number range > Illustration

and them refer to it using a cross-reference:

Insert > Fields > Other > Cross reference, choosing Illustrating > Number

This works fine within LO, but if I save as .docx then the cross-reference is lost in the saved file. When I open the file (in LO or in Word), the cross-reference number is replaced by the word "Illustration" (and is no longer a field).

A sample ODT file is attached. To see the bug, open the file in LO, save it as .docx, close and re-open the file in LO or Word.

Lars J

Using LibreOffice version 5.1.2.2 on Windows 10
Comment 1 Terrence Enger 2016-05-04 15:58:42 UTC
I am setting this RESOLVED DUPLICATE 42346.

Lars J,
If you think this bug is different from bug 42346, please set the status back to UNCONFIRMED.

*** This bug has been marked as a duplicate of bug 42346 ***