Bug 99631 - DOCX import/export: with embedded XLSX loaded but incorrectly scaled when edit
Summary: DOCX import/export: with embedded XLSX loaded but incorrectly scaled when edit
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: interoperability target:6.3.0 target:...
Keywords: bibisected, bisected, filter:docx, filter:ooxml, regression
: 103277 103675 (view as bug list)
Depends on:
Blocks: DOCX-OLE-Objects
  Show dependency treegraph
 
Reported: 2016-05-02 13:51 UTC by Marina Latini (SUSE)
Modified: 2019-02-13 11:25 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
affected file (522.66 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-05-02 13:51 UTC, Marina Latini (SUSE)
Details
How it looks on master compared to LibreOffice 6.1.3.2 (124.94 KB, image/png)
2018-12-20 11:34 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marina Latini (SUSE) 2016-05-02 13:51:55 UTC
Created attachment 124792 [details]
affected file

Try to open the attached file and edit one embbedded objects. (For example edit the table on page 8).
When click outside the embbedded spreadsheet the table is incorrectly scaled.

NOTE: if the embedded file is an XLSX it's incorrectly scaled, while if the file is a XLS it's opened as a new read-only document. (Different bug report to be filled)

IDEA: Something related to bug 93635
------------------------

Works fine on:
Version 3.6.7.2 (Build ID: e183d5b)

Do not work on:
Version: 5.1.2.2.0+
Build ID: 10m0(Build:2)
Thread CPU: 4; Versione SO: Linux 4.5; Resa interfaccia: predefinito; 
Locale: it-IT (it_IT.UTF-8)
OS: openSUSE Tumbleweed (20160422) (x86_64)

Version: 5.0.5.2
Build ID: 55b006a02d247b5f7215fc6ea0fde844b30035b3
Locale: it-IT (it_IT.UTF-8)
OS: openSUSE Tumbleweed (20160422) (x86_64)

Version: 4.4.7.2
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: it_IT.UTF-8
OS: openSUSE Tumbleweed (20160422) (x86_64)

Version: 4.2.8.2
Build ID: 48d50dbfc06349262c9d50868e5c1f630a573ebd
Locale: it_IT.UTF-8
OS: openSUSE Tumbleweed (20160422) (x86_64)
Comment 1 Buovjaga 2016-05-07 11:32:00 UTC
Repro with document.

64-bit, KDE Plasma 5
Build ID: 5.1.2.2 Arch Linux build-1
CPU Threads: 8; OS Version: Linux 4.5; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Comment 2 Marina Latini (SUSE) 2016-05-09 08:57:08 UTC
also see bug 99632.
Comment 3 Aron Budea 2016-09-04 20:44:12 UTC
Adjusting earliest version to 4.1.0.4, tried editing 2nd table on page 8 (strangely, nothing happens if I click on 1st table).
Interestingly, I can't edit that table in 4.0.0.3 at all.
Comment 4 Xisco Faulí 2016-10-06 17:15:10 UTC
Regression introduced by

author	David Tardon <dtardon@redhat.com>	2014-07-16 13:13:36 (GMT)
committer	David Tardon <dtardon@redhat.com>	2014-07-16 13:32:07 (GMT)
commit	c10390a681a4d4696d45a6d38f7d01829f368daa (patch)
tree	b4797585f963f9eaf122d25081ab5d5cb6b2865c
parent	cc1bea8692ad44dcc795766118b4b75c690e2655 (diff)
fdo#81113 always run the actual detection
The old code only run detection if an UCBContent property was passed.
That means that any time the function got only InputStream, it claimed
that it was a Keynote presentation.

Change-Id: I377828229e7e95384257bde247612d7768307581

Adding Cc: to David Tardon
Comment 5 David Tardon 2016-10-07 07:42:46 UTC
Hmm, it sounds weird that this should have any effect on embedded objects at all...
Comment 6 David Tardon 2016-10-07 17:48:13 UTC
dtardon->xiscofauli: I think you've made a mistake somewhere during bisection... Even when I make KeynoteImportFilter::detect a dummy (to rule out a possible uncaught exception), the 1st table on page 8 still fails to open for editing.
Comment 7 Xisco Faulí 2016-10-08 10:22:03 UTC
I do confirm that in bibisect-44max, if I do:

-git checkout a3504bf4d8f26bd18a1558a1a0fc122a455a1b13 I move to:

commit a3504bf4d8f26bd18a1558a1a0fc122a455a1b13
Author: Matthew Francis <mjay.francis@gmail.com>
Date:   Sat Mar 14 23:23:55 2015 +0800

    source-hash-c10390a681a4d4696d45a6d38f7d01829f368daa
    
    commit c10390a681a4d4696d45a6d38f7d01829f368daa
    Author:     David Tardon <dtardon@redhat.com>
    AuthorDate: Wed Jul 16 15:13:36 2014 +0200
    Commit:     David Tardon <dtardon@redhat.com>
    CommitDate: Wed Jul 16 15:32:07 2014 +0200

and I see that the embedded file is incorrectly scaled.
Then If I do: git checkout HEAD~1 and I move to the previous commit:

commit 562c5d3383b40a2a2c022a0a1c8625ca852fd48d
Author: Matthew Francis <mjay.francis@gmail.com>
Date:   Sat Mar 14 23:23:52 2015 +0800

    source-hash-cc1bea8692ad44dcc795766118b4b75c690e2655

then the file is opened in a new read-only document
Comment 8 David Tardon 2016-10-10 06:47:45 UTC
At this point I no longer understand what you're trying to reproduce...
Comment 9 Buovjaga 2016-10-10 07:04:37 UTC
(In reply to David Tardon from comment #8)
> At this point I no longer understand what you're trying to reproduce...

1. Open document and go to page 8
2. Double click the lower table for editing and it becomes zoomed in
3. Click outside and it remains zoomed in

This does not happen with 3.6.7.2

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha0+
Build ID: ff2a399b61f34f7920e594e8cbb6c19045b24956
CPU Threads: 8; OS Version: Linux 4.7; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on October 7th 2016

Arch Linux 64-bit
Version 3.6.7.2 (Build ID: e183d5b)
Comment 10 Xisco Faulí 2016-10-10 09:19:01 UTC
I've just bibisected it with lo-linux-dbgutil-daily-till44 to double check it and it says that the regression was introduced in this range: https://cgit.freedesktop.org/libreoffice/core/log/?id=c10390a681a4d4696d45a6d38f7d01829f368daa&qt=range&q=6b00bfeefde972beea947da66e07b59794717e4f..98fb5f98d84474103a04cbad824febecb25407c2
Comment 11 Buovjaga 2016-10-26 09:43:04 UTC
*** Bug 103277 has been marked as a duplicate of this bug. ***
Comment 12 Xisco Faulí 2016-11-03 11:58:48 UTC
*** Bug 103675 has been marked as a duplicate of this bug. ***
Comment 13 QA Administrators 2018-05-05 02:40:47 UTC Comment hidden (obsolete)
Comment 14 Marina Latini (SUSE) 2018-05-06 07:46:08 UTC
CONFIRMED on:

Version: 6.0.4.1
Build ID: 00m0(Build:1)
CPU threads: 4; OS: Linux 4.16; UI render: default; VCL: gtk3; 
Locale: it-IT (it_IT.UTF-8); Calc: group
Comment 15 Marina Latini (SUSE) 2018-05-06 08:01:19 UTC
CONFIRMED on:

Versione: 6.1.0.0.alpha1
Build ID: cb47f0d320994e001bc38dc2ee9b7d957b15e6ab
Thread CPU: 4; SO: Linux 4.16; Resa interfaccia: predefinito; VCL: gtk2; 
Versione locale: it-IT (it_IT.UTF-8); Calc: group
Comment 16 Commit Notification 2018-12-17 14:20:42 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/75656a933e7a503f114aa64c67397cb375c9dbe8%5E%21

tdf#99631 DOCX import: set 1:1 scale in embedded XLSX

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2018-12-19 06:58:35 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/69ce3374f90847f357249a41118314508da6bb98%5E%21

tdf#99631 DOCX import: keep zoom of embedded XLSX

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2018-12-19 21:37:30 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/fc50869a818f5411bf2bbd34db398078308f2ba3%5E%21

tdf#99631 DOCX export: keep zoom of embedded XLSX

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Xisco Faulí 2018-12-20 11:34:06 UTC
Created attachment 147693 [details]
How it looks on master compared to LibreOffice 6.1.3.2

The blurred problem in the first table is reported in bug 119180
Comment 20 Xisco Faulí 2018-12-20 11:41:49 UTC
Setting as VERIFIED FIXED

Version: 6.3.0.0.alpha0+
Build ID: 1b7bcaa714f0af45c6a9660d1f0940cb7931ba0f
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@László Németh, thanks for fixing this!!
Comment 21 Commit Notification 2019-01-21 09:36:13 UTC
László Németh committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/5db1b9e519e1af16d3faf98465b5a901c6bdbb36%5E%21

tdf#99631 DOCX: keep zoom of embedded XLSX

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 László Németh 2019-01-21 11:54:36 UTC
@Xisco, Miklós and all: Thanks for your feedbacks!