Bug Hunting Session
Bug 99644 - Automatically set text size when inserting Math formulas
Summary: Automatically set text size when inserting Math formulas
Status: RESOLVED DUPLICATE of bug 32419
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
5.0.5.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-03 09:19 UTC by Yan Pas
Modified: 2016-05-03 21:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yan Pas 2016-05-03 09:19:32 UTC
Currently all math formulas inserted in Writer have predefined text size (currently 12). I suggest the following:
You type some bold text in writer with size 20 and press Inser Formula:
Formula inserted with following line "bold size 20 {}" and the cursor is between { and }. Two \n also may be added
Comment 1 V Stuart Foote 2016-05-03 16:56:47 UTC
Set your font size preference in a Math formula editor session, they'll carry over as you call the OLE formula insertion.

Personally, I prefer to prepare my formulas external to a Writer session in Math, and then insert each preformatted OLE formula as I need them in the manuscript.
Comment 2 Yan Pas 2016-05-03 17:38:48 UTC
Yes, I can set default font and size in Math setttings. But I can set it for formula or userprofile-wide. I cannot at least set it document-wide. What I suggest is context-style formulas. I see only advantages.

If I create commit with such possibilities will it be rejected?
Comment 3 V Stuart Foote 2016-05-03 17:52:58 UTC
Sure, work it up.

Over to new enhancement against formula editor.

Ask here, or post to Dev ML for help list if you get stuck with the source code or UI design.
Comment 4 V Stuart Foote 2016-05-03 18:03:33 UTC
@Takeshi, any thoughts or pointers for Yan? 

Not sure how it can be accomplished, but expect setting a font size per document  for formula would need to end up asserted against each formula object OLE recorded into the .ODT archive.
Comment 5 Yan Pas 2016-05-03 18:11:24 UTC
No, it won't require additional settings, it's simplier:
1) You type text on some line, text has some attributes (size, isbold, isital, color, font etc.)
2) I grab size, isbold, isital from current line
3) I insert OLE object and edit it, pasting, for example "bold size 35 {}"

Seems to be achievable, the only thing in whch I'm not sure is possibility to place cursor in needed position.

Is placing user's cursor musthave possibility?

I also guess that this feature should be triggered in settings
Comment 6 Regina Henschel 2016-05-03 19:12:18 UTC
That sounds duplicate to bug 32419 'When inserted on Writer, get "Base size" for formulas from underlining paragraph'.
Comment 7 Yan Pas 2016-05-03 20:49:32 UTC
Yep, they are similar, but my approach isn't so careful :) May merked as DUP
Comment 8 V Stuart Foote 2016-05-03 21:08:08 UTC
OK then to dupe of bug 32419

*** This bug has been marked as a duplicate of bug 32419 ***