Bug 99646 - Make default type of anchoring optional
Summary: Make default type of anchoring optional
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard: target:7.2.0 target:7.1.0.0.beta2
Keywords:
: 132962 (view as bug list)
Depends on:
Blocks: Anchor-and-Text-Wrap Object-Selection-Alignment
  Show dependency treegraph
 
Reported: 2016-05-03 12:27 UTC by Mamoth
Modified: 2021-02-23 18:02 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mamoth 2016-05-03 12:27:27 UTC
Hello.

I am here to suggest a new setting.

When one inserts an object into a LO Writer document, either through the Insert menu or by copy-pasting, the object (be it an image or a graph from LO Calc) is inserted with by default the type of anchoring (right-click on object and select 'Object' or 'Format image' or 'Image' depending on the version of LO) set to "to paragraph".

This has been so since I started using LO more than ten years ago.
And since then, I have almost always had to change manually the anchoring of nearly all the images and objects I have inserted in Writer documents to "as character".

For years I have been searching for a way to change this default setting and set it so that the default type of anchoring when inserting an object is "as character". It would be handy if it was possible to set this default value for the software somewhere in its settings (menu Tools > Options).

I believe I am not the only one in this situation and that others would also find it handy.
Comment 1 Cor Nouws 2016-05-03 18:26:20 UTC
Thanks for filing Mamoth

Set to New.

(I would swear I've seen a similar issue, but cannot find it..)
Comment 2 Cor Nouws 2016-05-03 18:26:31 UTC Comment hidden (obsolete)
Comment 3 Ahiijny 2018-10-25 06:08:40 UTC
I would also like this. I normally anchor images as character, so it's a real hassle having to change the anchor every time I paste something into my document. MS Word by default pastes images in line with text, and that's what I'm used to.

See also:
- (2012-10-30) AskLO: https://ask.libreoffice.org/en/question/7295/how-do-i-change-the-default-image-anchoring-to-as-character/
- (2013-02-12) SU.SE: https://superuser.com/questions/550240/make-libreoffice-writer-insert-pictures-as-character-by-default
- (2015-05-29) AskLO: https://ask.libreoffice.org/en/question/51311/libreoffice-writer-428-how-do-i-change-the-default-image-anchor-to-character-has-this-bug-been-fixed/
- (2016-08-12) AskLO: https://ask.libreoffice.org/en/question/75019/change-default-template-image-anchor-to-as-character/
- (2017-04-27) AskLO: https://ask.libreoffice.org/en/question/93610/image-as-character-as-default/
Comment 4 csongor 2018-11-06 12:48:13 UTC
(In reply to Cor Nouws from comment #1)
> Thanks for filing Mamoth
> 
> Set to New.
> 
> (I would swear I've seen a similar issue, but cannot find it..)

Here is it from the OOo ages: https://bz.apache.org/ooo/show_bug.cgi?id=19814

As it can be seen, this request is more than 15 years old. 

I would put this setting under the newly created Tools -> Options -> LibreOffice Writer -> Clipboard Options dialog. There could be a couple of things:

- Paste Image:
 - Anchor: To Page / To Paragraph / To Character / As Character
 - Wrap: Wrap Off / Page Wrap / ...
 - Alignment: Align Left / Centre Horizontally / Align Right / ...
- Paste Spreadsheet
 - Anchor: To Page / To Paragraph / To Character / As Character
 - Wrap: Wrap Off / Page Wrap / ...
 - Alignment: Align Left / Centre Horizontally / Align Right / ...
 - Formulas: Keep Formulas / Substitute With Current Value
- ...

Seeing for how long users wish this feature, it would really be nice to have it.
Comment 5 laurens 2019-06-09 19:38:14 UTC
Also want this - I write technical reports with lots of images (10-40 per document)

LO handling of images only works (for me) when I anchor as character - otherwise it's a mess (and has some bad CPU usage bugs as well that I have reported). 
Suffice to say that anchor as character is mandatory for me to use LO.

Workflow would be much better if this was a default setting.

L
Comment 6 Cor Nouws 2020-02-22 21:17:51 UTC
Hi Mamoth,

Can you pls test in a recent version (6.4.0).
There have been done recent changes in this area...
thanks!
Comment 7 Heiko Tietze 2020-04-16 13:35:54 UTC
We discussed this topic in the design meeting. While we intentionally decided to change the default to "To Character" there might be also scenarios where other anchors make sense. The idea discussed in bug 87720 to just remember the last used option is not ideal since, for example, user want to change anchoring for just one image but have to reset the default next time. So we decided to introduce radio buttons under Tools > Options > Writer > Formatting Aid that allow to change the default from _To Character_ to any other option.
Comment 8 Regina Henschel 2020-05-11 23:45:11 UTC
*** Bug 132962 has been marked as a duplicate of this bug. ***
Comment 9 Telesto 2020-05-12 07:09:37 UTC
(In reply to Heiko Tietze from comment #7)
> We discussed this topic in the design meeting. While we intentionally
> decided to change the default to "To Character" there might be also
> scenarios where other anchors make sense. The idea discussed in bug 87720 to
> just remember the last used option is not ideal since, for example, user
> want to change anchoring for just one image but have to reset the default
> next time. So we decided to introduce radio buttons under Tools > Options >
> Writer > Formatting Aid that allow to change the default from _To Character_
> to any other option.

To be clear.. this only about images... and only for the ones inserted in Writer (not copy paste ones from Impress/Draw)
Comment 10 Andrea Piovesana 2020-11-25 22:52:05 UTC
idem for me

I would also like this. I normally anchor images as character, so it's a real hassle having to change the anchor every time I paste something into my document.
Comment 11 Gabriele Ponzo 2020-11-25 22:56:31 UTC
(In reply to Heiko Tietze from comment #7)
> We discussed this topic in the design meeting. While we intentionally
> decided to change the default to "To Character" there might be also
> scenarios where other anchors make sense. The idea discussed in bug 87720 to
> just remember the last used option is not ideal since, for example, user
> want to change anchoring for just one image but have to reset the default
> next time. So we decided to introduce radio buttons under Tools > Options >
> Writer > Formatting Aid that allow to change the default from _To Character_
> to any other option.

In which version of LO is it planned to find this "Formatting Aid" branch in Writer's options section?
Comment 12 Heiko Tietze 2020-11-26 08:20:00 UTC
(In reply to Gabriele Ponzo from comment #11)
> In which version of LO is it planned to find this "Formatting Aid" branch in
> Writer's options section?

The version that comes after a developer becomes interested in this topic :-)
(will try to do it myself)
Comment 13 Commit Notification 2020-12-09 07:51:13 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c220d97e22001db116f6f8204922b25a9e61e26f

Resolves tdf#99646 - Make default type of anchoring optional

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Telesto 2020-12-09 08:37:23 UTC
@Heiko
Thanks for making this possible!

1) the scope is for this is limited to Images only? The whole anchoring implementation kind of odd as far I can recall. Chart having an 'image' anchor. Shapes having a different type of anchor [me still advocating single standard, and maybe split out ability configuring it individually as done here for 'images' [not totally sure about the actual scope]]. So harmony code-wise couldn't hurt. I even have the feeling some objects having their own "to paragraph" anchor. So different implementation (behaviour characteristics)  with the same name (but that's kind of out of scope here)

2) I hope this get backported to 7.1 too..
Comment 15 Heiko Tietze 2020-12-09 08:58:46 UTC
(In reply to Telesto from comment #14)
> the scope is for this is limited to Images only? 
Not sure, please reply if it works also for other types so we can adjust the label.

> I hope this get backported to 7.1 too..
I disagree, this needs testing.
Comment 16 Telesto 2020-12-09 09:13:22 UTC
(In reply to Heiko Tietze from comment #15)
> > I hope this get backported to 7.1 too..
> I disagree, this needs testing.

Please be bit more convinced about you're own work :P. And it's kind of buried in setting anyhow :-). The whole jumbo sheet got into 7.0; being broken from the start..

Note: I do get you're idea trying to be 'safe'. Not sure if this gonna work.. Most people do change those settings.. So as long default still doing their job :-).. And we are still 7.0b1.. so enough room for improvement, IMHO. 

But it's your commit, so you're choice. 

I grand you permission to point to me for every complain you get :P. I didn't want to push it into 7.0 . I was old and wise, but Telesto made me against my objection.. The only issue is I'm likely not able to solve occurring problems
Comment 17 Heiko Tietze 2020-12-09 09:15:31 UTC
(In reply to Telesto from comment #16)
> (In reply to Heiko Tietze from comment #15)
> > > I hope this get backported to 7.1 too..
> > I disagree, this needs testing.

Xisco, what do you think?
Comment 18 Xisco Faulí 2020-12-09 09:25:34 UTC
(In reply to Heiko Tietze from comment #17)
> (In reply to Telesto from comment #16)
> > (In reply to Heiko Tietze from comment #15)
> > > > I hope this get backported to 7.1 too..
> > > I disagree, this needs testing.
> 
> Xisco, what do you think?

Technically this is doable. the question is, do you want, as the author of the commit, to backport it? the feature has been missing forever, should we wait a bit longer or not ?
Comment 19 Commit Notification 2020-12-14 09:26:25 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/504f651e8240d17b366cd970ded7110803d28070

Resolves tdf#99646 - Make default type of anchoring optional

It will be available in 7.1.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Marina Latini (SUSE) 2020-12-16 22:30:31 UTC
VERIFIED FIXED

Version: 7.2.0.0.alpha0+
Build ID: 59301a1cadd87a63276650975252d14e8477e632
CPU threads: 2; OS: Linux 5.3; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-12-16_04:38:36
Calc: threaded
Comment 21 Cor Nouws 2020-12-26 22:05:00 UTC
thanks for fixing this!

For the Help

Under Options > LibreOffice > Advanced > Expert Configuration ..
search for 'Anchor'
org.openoffice.Office.Writer > Content > Display

Value  | Anchor 
  0      FLY_TO_PARA
  1      FLY_TO_CHAR
  2      FLY_AS_CHAR
Comment 22 Heiko Tietze 2021-01-04 11:27:41 UTC
(In reply to Cor Nouws from comment #21)
> For the Help
> 
> Under Options > LibreOffice > Advanced > Expert Configuration ...

Why send users to the expert settings? The default anchor is exposed as dropdown under Tools > Options > LibO Writer > Formatting Aids > Image: Anchor