Download it now!
Bug 99673 - Pasting into searchbar via menubar Edit > Paste pastes into document instead of searchbar
Summary: Pasting into searchbar via menubar Edit > Paste pastes into document instead ...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: MacOS-Wishlist
  Show dependency treegraph
 
Reported: 2016-05-04 12:52 UTC by steve -_-
Modified: 2016-10-20 17:04 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description steve -_- 2016-05-04 12:52:55 UTC
This bug is a follow up to #49853.

Original bug was about copy pasting into search bar was broken. This has been fixed by Maxim for keyboard shortcuts. Pasting via menubar still pastes into document.

**Reproduce**
    1. open writer document and type "test"
    2. copy word with ⌘+V
    3. ⌘+F or open search bar otherwise
    4. select Edit > Paste from the menubar

**Currently**
    String will be pasted into document. (Pasting with ⌘+C will work as expected in master thanks to Maxim's fix)

**Expected**
    String should be pasted into search bar, where mouse pointer is located.

**Additional info**
Maxims remarks from https://bugs.documentfoundation.org/show_bug.cgi?id=49853#c151:
    "Mouse click on Edit->Paste menu will still paste to the document. This is not trivial to fix for various reasons, so leaving this for a future investigation. Whoever interested in this part too - please open a new bug, as this one is too long already."
Comment 1 Adolfo Jayme 2016-05-04 13:11:39 UTC
→ NEW
Comment 2 steve -_- 2016-10-20 11:11:12 UTC
reproduced in kubuntu as well. so this is not a macOS specific issue. adjusting specifics.
Comment 3 Maxim Monastirsky 2016-10-20 11:51:27 UTC
(In reply to steve -_- from comment #2)
> reproduced in kubuntu as well. so this is not a macOS specific issue.
I'm not sure that Edit > Paste should work with the search widget on platforms other than Mac, at least Bug 49853 comment 66 and Bug 49853 comment 96 suggests it should not. Such change would need at least an approval from UX.

Anyway - changing the behavior of the .uno:Paste commands is IMHO a no-go, because it can easily break existing macros, toolbar button etc., so any change here would need to be done in the menu code, be it in the cross-platform or the platform-dependant part.
Comment 4 Heiko Tietze 2016-10-20 14:51:52 UTC
No question that paste should be kept as it is: it inserts the text/object from the clipboard where the current focus is. When I open the quick search panel (ctrl+f) having a selection this text is inserted in the panel. Pasting works also as expected and inserts the content of the clipboard.

Version: 5.2.2.2.0+
Build ID: 5.2.2-2
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 5 Heiko Tietze 2016-10-20 15:10:52 UTC
(In reply to Heiko Tietze from comment #4)
> *snip*

After talking to Steve I can confirm the issue. There is a difference between pasting per shortcut (ctrl+V or shift+ins) and using the menu (edit > paste) or the toolbar. The latter enters the text from the clipboard to the document independently from where the focus is. But per shortcut the text goes into the search field that has the focus.
The issue is of course not limited to the search bar. Paste per toolbar/menu goes always into the document. That's wrong IMHO.
Comment 6 Yousuf Philips (jay) (retired) 2016-10-20 15:45:13 UTC
With the ability to paste through the context menu and shortcut key, i dont think the menubar paste entry should be pasting into the field, or should menubar paste also work in the style, font name and font size toolbar fields as well? With such logic, the special character dialog should also insert into the field.

The menubar isnt available always (e.g. dialogs), so users shouldnt be looking for that means for pasting text into fields. So i agree with Maxim and would say no-go.
Comment 7 Buovjaga 2016-10-20 17:04:06 UTC
Yep, being in the Edit menu along with Paste special & unformatted text conveys the meaning that the target is the document. Let's close.