Download it now!
Bug 99695 - Table of Contents (ToC) can't index Character style so as to generate APA Styled ToC with Heading 3
Summary: Table of Contents (ToC) can't index Character style so as to generate APA Sty...
Status: RESOLVED DUPLICATE of bug 48459
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-05 16:05 UTC by Marc Grober
Modified: 2016-05-06 18:00 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Grober 2016-05-05 16:05:38 UTC
Table of Contents feature only indexes Paragraph styles, while indexing feature can index selected terms.  As a result, one cannot effectively generate a ToC with more than two headings in an APA styled document.

The APA Publication Manual (Section 3.03, Pg 62) mandates a Heading 3
style that that is bold and indented (1/2 an inch like a normal
paragraph), and then followed on the same line by the text.

That means one cannot use a paragraph style, as the paragraph needs to
actually be normal body text (Default in most cases).  If  one uses a
generated ToC, then text that is styled with a Heading style is
used in the ToC, so you don't want a paragraph that looks like normal
but for which you bold the first bit.

It would be handy if the ToC generator would provide the option to add non-Paragraph styles to materials that are included in the generated ToC (it does this for other Paragraph styles).  The only alternative solution is for users to kludge their own custom index to use as a ToC in place of that provided. In as much as a substantial portion of those who might have recourse to use Writer will have reason to use APA or APA consistent style, it would seem a no-brainer to add this functionality.
Comment 1 Marc Grober 2016-05-05 16:16:16 UTC
There are numerous threads regarding this issue with respect to the various code branches, but many are confusing or confused because of the language employed. I had thought that a character style could be added to the ToC, but on exploration in the current version, the styles available in the menu seem to be limited to paragraph styles. 

In other words, if one creates a new Character Style, let's call it "APA Heading 3", and makes that style bold, and then goes to Insert -> Index or Table of Contents, and clicks on Additional Styles, one cannot add anything but a Paragraph style. 

So the questions are, is there any functional reason why a character style could not be added to the TOC so that this issue could be resolved, and if there is no such reason, what would it take to accomplish same.
Comment 2 Marc Grober 2016-05-05 20:23:57 UTC
Discussion in the user forum brought this to my attention: https://forum.openoffice.org/en/forum/viewtopic.php?f=71&t=709

An innovative and intriguing effort to accomplish something that should not be so difficult.
Comment 3 V Stuart Foote 2016-05-05 20:58:40 UTC
Any reason not to simply use Zotero or Mendeley to handle this facet of authoring documents best left to extensions?

With some 8,000 current styles defined in CSL [1] its a fools errand to try to provide paragraph formatting for any individual "standard", be it CMOS, APA, MLA, IEEE, etc.

Rather, it makes far more sense to validate the work being done on integrating these extensions and ensure that LibreOffice responds correctly with style formatting applied from the CSL.


=-ref-=
Citation Style Language
[1] https://github.com/citation-style-language/styles
Comment 4 Marc Grober 2016-05-05 21:51:57 UTC
While one could provide extensions that tagged and generated material for LO (as Zotero does for Bibliographies for example), why abandon what LO already does to build something to parrot what LO already accomplishes. While this might make some sense in the Google Doc environment (where Google termination of the ability to add styles has resulted in apps that provide that service) where Google apps is now specifically designed without internal extensibility, it makes no sense where, as in the case of LO, the extensibility is already not only built in, but the user is provided tools to extend and modify. 

LO already has the built-in ability to generate tables.  ToC is a subset of the general ability that by default uses certain outline paragraph styles. Unfortunately, the ToC also excludes the ability to include character styles for someone reason I have yet to discover. If LO did allow the inclusion of Character formats in ToCs,  it would resolve all formatting problems where a Heading was part of the paragraph (as one sees in the APA style for headings.

So, a) we are not talking about providing 8000 paragraph formats; we are talking about allowing the user to include as a ToC Heading a style other than a paragraph style; b) it makes no sense to try to build extensions along the line of zotero to do what LO already does; c) the solution I suggest would allow the greatest flexibility for the user to accomplish his aims with the least effort.
Comment 5 Marc Grober 2016-05-06 17:49:20 UTC
On further research I find that MS Word suffers from the same problem, but manages a work around by allowing the user to select a paragraph symbol, and then hide it. See, http://www.k-state.edu/grad/etdr/word/APAheadings.html.  That is not possible in LO.
Comment 6 Marc Grober 2016-05-06 18:00:07 UTC
https://bugs.documentfoundation.org/show_bug.cgi?id=48459

*** This bug has been marked as a duplicate of bug 48459 ***