Download it now!
Bug 99696 - Build for x64 fails unit tests using ADODB
Summary: Build for x64 fails unit tests using ADODB
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha1
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.3.0 target:5.2.0.1
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-05 16:56 UTC by Mark_T2016
Modified: 2016-09-26 12:00 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark_T2016 2016-05-05 16:56:07 UTC
Unable to complete build for x64 on windows due to failing unit tests:-

ole_dfltObjDflMethod
ole_ObjAssignNoDflt.vb
ole_ObjAssignToNothing.vb

(D:\lode\dev\x64\basic\qa\vba_tests)

Also copied ole_ObjAssignNoDflt.vb into basic module using downloaded x64 release 5.1.2.2, which also fails.

At the line "cn.Open conStr":-

BASIC runtime error.
'1'

Type: com.sun.star.uno.RuntimeException
Message: [automation bridge] unexpected exception in IUnknownWrapper_Impl::invoke ! Message : 
[automation bridge]: [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified

Using the above ole_ObjAssignNoDflt.vb with win32 build of 5.2.0.0.alpha1, compiled from source, does not show the problem.

Suspect this may be due to trying to use a win32 object from an x64 application.

I have 32 bit version of Microsoft Office 2010, on a 64 bit windows 8.1, compiling with Visual Studio Community 2015.

Autogen.input flags:-
--enable-64-bit
--enable-pch
--disable-ccache
--with-visual-studio=2015
--disable-firebird-sdbc
--disable-cve-tests

Current workaround to allow me to complete an x64 build is to force the three test modules listed above to return "OK".
Comment 1 Tomofumi Yagi 2016-05-07 00:00:01 UTC
I can reproduce the problem with master on Windows 10(64 bit).

Version: 5.2.0.0.alpha1+ (x64)
Build ID: 945064c0b7ad4da6e215668ae7e4edb14945f00c
CPU Threads: 8; OS Version: Windows 6.19; UI Render: default; 
Locale: ja-JP (ja_JP)

I installed 32 bit version of Microsoft Office 2016.

My autogen.input is as follows.
--with-distro=LibreOfficeWin64
--with-visual-studio=2013
--with-ant-home=/opt/ant
--disable-firebird-sdbc
--enable-debug
--with-lang=ja
Comment 2 Tomofumi Yagi 2016-05-07 04:29:28 UTC
(In reply to Mark_T2016 from comment #0)
 
> Suspect this may be due to trying to use a win32 object from an x64
> application.

I think so,too.
Comment 3 Commit Notification 2016-05-30 09:31:19 UTC
Tomofumi Yagi committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d2a44e62704f185a0acecbb6320b92a4df3063b9

tdf#99696 fix build error for 64bit Windows in unit tests using ADODB

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2016-06-07 07:24:24 UTC
Tomofumi Yagi committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=63ee1bafe2ec37c65b7f1e25fcb10761bf8f309e&h=libreoffice-5-2

tdf#99696 fix build error for 64bit Windows in unit tests using ADODB

It will be available in 5.2.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Xisco Faulí 2016-09-15 22:39:08 UTC
Hello,
Is this bug fixed?
If so, could you please close it as RESOLVED FIXED?
Comment 6 Tomofumi Yagi 2016-09-26 12:00:39 UTC
(In reply to Xisco Faulí from comment #5)
> Hello,
> Is this bug fixed?
> If so, could you please close it as RESOLVED FIXED?

I can't reproduce in
Windows 10 x86_64(installed 32 bit version of Microsoft Office 2016)
Version: 5.3.0.0.alpha0+ (x64)
Build ID: dad35b0463a16d3d6eca068100e95822ae466a9a
Locale: ja-JP (ja_JP)

I change the status to RESOLVED FIXED.