Download it now!
Bug 99753 - Text referenced from cells in different sheet is capitalised in some cases
Summary: Text referenced from cells in different sheet is capitalised in some cases
Status: RESOLVED DUPLICATE of bug 75387
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: OpenCL
  Show dependency treegraph
 
Reported: 2016-05-09 23:54 UTC by Christoph Anton Mitterer
Modified: 2016-06-05 03:58 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
file.ods (139.92 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-05-17 12:00 UTC, Christoph Anton Mitterer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Anton Mitterer 2016-05-09 23:54:43 UTC
Hi.

This issue started already some libreoffice versions earlier (I'd guess around 5.0 but don't really remember exactly).

In calc, when I set the contents of cells via e.g. Sheet2.A1 is set to "=Sheet1.A1" or similar, and when Sheet1.A1 contains Text (maybe also in other cases, didn't check), then this text is capitalised in Sheet2.A1 (in the above example).

Cheers,
Chris.
Comment 1 tommy27 2016-05-10 00:49:00 UTC
please tell your O/S
Comment 2 Jean-Baptiste Faure 2016-05-10 07:18:36 UTC
Not reproducible for me with LO 5.1.4.0.0+ built at home under Ubuntu 16.04
x86-64.

Please answer the question in comment #1. Status set to NEEDINFO.

Best regards. JBF
Comment 3 Christoph Anton Mitterer 2016-05-14 02:24:13 UTC
It's Debian sid.
Comment 4 Christoph Anton Mitterer 2016-05-14 02:44:41 UTC
I just tried few things... it seems that when I create a new sheet, it doesn't happen for me either.

Even on the same sheet where I have it, it doesn't happen when I set the "=..." in other cells... only in a range of cells in some collumn (but even there not in all rows)...

It seems as if something would have set capital letters for these cells, but I think that's not possible in Calc, is it?
At least I wouldn't know how to remove it again.
Comment 5 Christoph Anton Mitterer 2016-05-14 02:54:59 UTC
That's kinda weird:

Simplified, I when my one calc file would have this:
Sheet1:
A1: foo
A2: bar
A3: baz

Sheet2:
A1: =Sheet1.A1, giving "FOO"
A2: =Sheet1.A2, giving "BAR"
A3: =Sheet1.A3, giving "BAZ"


When I now change e.g. Sheet2.A2 to "=Sheet1.A1" it gives "foo", but when I change it back to "=Sheet1.A2" it gives again "BAR".


WTF?
Comment 6 Jean-Baptiste Faure 2016-05-14 05:49:22 UTC
Version 5.1.3 is released. Did you try it?

Best regards. JBF
Comment 7 Jean-Baptiste Faure 2016-05-14 05:49:57 UTC
Please, could you attach your test file ?

Best regards. JBF
Comment 8 Buovjaga 2016-05-17 10:39:03 UTC
Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the document.
Comment 9 Christoph Anton Mitterer 2016-05-17 12:00:35 UTC
Created attachment 125112 [details]
file.ods

It also happens with 1:5.3.1-1 in Debian sid.

Attached is my sheet. I removed the content of most cells (except the =General.A<n>),.. but the issue still happens (here) - I've added three rows with foo, bar and baz which get FOO, BAR, BAZ.

Cheers,
Chris.
Comment 10 Buovjaga 2016-05-17 12:14:37 UTC
I changed the ones in Data sheet that were uppercase back and forth and they stayed lowercase (foo was lowercase already on opening).
Stayed ok after saving and reloading.

Seems like a glitch.

Win 7 Pro 64-bit, Version: 5.1.3.2 (x64)
Build ID: 644e4637d1d8544fd9f56425bd6cec110e49301b
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: fi-FI (fi_FI)

Version: 5.2.0.0.alpha1+
Build ID: 3d27afd26f7b85c46a7c7d08498000b9dbcea1c8
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-05-09_02:42:15
Locale: fi-FI (fi_FI)
Comment 11 raal 2016-05-17 12:43:25 UTC
(In reply to Buovjaga from comment #10)
> I changed the ones in Data sheet that were uppercase back and forth and they
> stayed lowercase (foo was lowercase already on opening).
> Stayed ok after saving and reloading.
> 
> Seems like a glitch.

The same findings as you. In content.xml:
-<table:table-row table:style-name="ro1">-<table:table-cell table:style-name="ce107" calcext:value-type="string" office:value-type="string" office:string-value="BAR" table:formula="of:=[General.A11]"><text:p>BAR</text:p></table:table-cell>

as you can see the text "BAR" is capitalized. If we cannot reproduce the problem from scratch, I think we can close the bug. In some previous version was the bug, but seems to be fixed in current version.
Comment 12 Christoph Anton Mitterer 2016-05-18 03:08:12 UTC
You mean it's fixed in >5.1.3? Any idea in which version (or better commit) exactly?
Comment 13 raal 2016-05-18 05:47:54 UTC
(In reply to Christoph Anton Mitterer from comment #12)
> You mean it's fixed in >5.1.3? Any idea in which version (or better commit)
> exactly?

I think the problem was in previous version, where the text was saved in uppercase in xml structure. If you delete the cell and create the formula  (=General.A11) again, the bug doesn't occurs in current version. Please try it. Thanks
Comment 14 Christoph Anton Mitterer 2016-05-19 13:41:16 UTC
No that doesn't work for me.
In 5.1.3 it's still as described in comment 5.

When I delete e.g. the cell on Data.A11 with content "=General.A11" and then re-set it, it's again capitalised.
However, when I set the same cell to "=General.A10" (which is of course not how it should be), it's not capitalised.
Even when I clear the General.A11, and re-set it, then it's still capitalised on the other sheet.
Comment 15 Aron Budea 2016-05-26 07:52:51 UTC
(In reply to Christoph Anton Mitterer from comment #14)

> When I delete e.g. the cell on Data.A11 with content "=General.A11" and then
> re-set it, it's again capitalised.
> However, when I set the same cell to "=General.A10" (which is of course not
> how it should be), it's not capitalised.
> Even when I clear the General.A11, and re-set it, then it's still
> capitalised on the other sheet.

I could reproduce these using the attached file in LO 5.1.3.2/Ubuntu 15.10.
Also, if I add text in the line below in the General sheet, it appears capitalized in the Data sheet.

Not reproduced in LO 5.0.5.2. Also not reproduced in Windows 7 with 5.1.3.2.
Also not reproduced by typing the text/references in an empty file.

An interesting difference between 5.1.3.2 and 5.0.5.2 right after opening the file is that while BAR/BAZ are capitalized in the Data sheet in both, FOO is only capitalized in 5.1.3.2.
Comment 16 Aron Budea 2016-05-27 00:26:03 UTC
To be precise about what I mean about reproducible/not reproducible. In both cases BAR/BAZ appear capitalized in the Data sheet initially, but:

-in 5.1.3.2 they remain capitalized after editing them as described in comment 14,
-in 5.0.5.2 they won't be capitalized anymore after such edits.
Comment 17 Thomas Boehm 2016-05-31 16:56:46 UTC
I can reproduce the bug as following:

- create new calc document
- fill one or more cells in column A with text
- add a new sheet
- put "=Sheet1.A1" into cell A1 of Sheet2
- copy down A1 until A100 or more

All text is converted to UPPERCASE in Sheet2. The bug does not appear if I copy down only to A99 or less.
Comment 18 Aron Budea 2016-06-01 00:24:54 UTC
Thanks for the simplified reproduction steps. Apart from the versions mentioned before I also reproduced the bug in:
-5.2 beta1,
-5.1.2.2 (didn't test with earlier 5.1 versions).
Comment 19 Thomas Boehm 2016-06-01 11:34:43 UTC
Just to add the versions I can reproduce the behavior with:

LO 5.1.3.2, Ubuntu 14.04
LO 5.1.4.0.0+, Ubuntu 14.04
LO 5.2.0.0.beta1+, Ubuntu 14.04

I CANNOT reproduce the bug with

LO 5.1.2.2 and 5.1.3.2 both on Windows 7 Pro
Comment 20 Thomas Boehm 2016-06-01 13:27:35 UTC
It appears to be a problem with OpenCL.

http://nabble.documentfoundation.org/copying-down-references-to-other-cells-turns-text-to-UPPERCASE-tp4184881p4184992.html

Increasing the value in Options -> LibreOfficeCalc -> Formula -> Detailed Calculation Settings -> Custom -> OpenCL Settings -> Minimum data size for OpenCL use: changes the point where the bug occurs too.
Comment 21 Aron Budea 2016-06-05 03:58:50 UTC
It's a problem with the OpenCL software interpreter. If 'Tools -> Options... -> LibreOffice -> OpenCL -> Allow use of OpenCL' is disabled, but 'Allow use of Software Interpreter (even when OpenCL is not available)' is enabled, this issue occurs in Windows 7 for me as well. In fact, it occurred in Linux in the first place because I have no OpenCL in the VM.

Note that despite the lack of warning, Calc has to be restarted after clearing 'Allow use of OpenCL' (reported as bug 100222).

I was referred to bug 75387 as a suggested duplicate when creating the other report, but as it turns out, this is the duplicate of that bug. Oh well, we all learned something.

*** This bug has been marked as a duplicate of bug 75387 ***