Download it now!
Bug 99761 - Major, debilating freeze when "File -> recent documents" refers unmounted SMB shared documents
Summary: Major, debilating freeze when "File -> recent documents" refers unmounted SMB...
Status: RESOLVED DUPLICATE of bug 89394
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-10 13:25 UTC by fanf42
Modified: 2016-05-11 08:26 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fanf42 2016-05-10 13:25:15 UTC
Hello, 

This bug is always killing me at the worst time. It could be a version of #71447. 

I saw it on all my Linux on the past 5 years or so (Debian, Ubuntu, now Archlinux). 
I saw it since libreoffice 3.x to 5.1.2 - it seems even worse in 5.1.2 than in 5.0.6, at least in the latter the libreoffice screen (i.e, not writter, the one coming up with the "libreoffice" command without argument) is working. 

So, basically, libreoffice is unusable if "recent changes" has pointers to files that are on a SMB shared directory that is currently not mounted, or not accessible due to network split. To be clear: the shared directory is not mounted, trying to access it with ls or a files browser correctly report an error (or an empty directory, depending how the SMB directory is mounted), but libreoffice freeze forever, trying to do I don't know what with them. 

The most beautiful part is that the freeze happen EVEN IF YOU DON'T NEED recent files. Just by trying to see "File" menu freezes. 

And of course, it always happen when I'm not at my desk, and urgently need to correct something on a document or give a presentation to a major customer. And its impossible. 

With a lot of luck, sometime, I'm succeding at mounting the faulty share with my smartphone network, and between two lag I click on "clear recent changes" and everything is normal again. 

I also saw that problem on several of my coworker, so it can't be only a configuration problem on my part. 



Update: as I was writting, which took me a lot of time (> 10 minutes), libreoffice writter (5.0.6-1), which was frozed because I attempted to see "recent changes" for the bug, claimed focus and came back to live. It seemed to have removed document that were not accessible, and now I can use it normally. OK, actually, I tried to close writter, it crashed, I opened it up again, I clicked on file, it froze for ~1min, I want to "recent files", it froze my whole system for a couple of minutes, it removed the files, I closed it (whitout a crash!), and now when I'm opening it again, the "recent files" list is still clean and I can use it. So 5.0.6 is better than a lot of previous one, even if I never waited the long minutes to see it before writting that bug report. In all case, a delay OF SEVERAL MINUTES, on a quad-core i7 with 8Go of ram is just madness and alienating users.
Comment 1 fanf42 2016-05-10 13:37:46 UTC
Update to my update: I didn't looked carefully enought. The document on the SMB share are not removed from the "recent documents" list after the freeze/unfreeze, or perhaps they were added again when I mounted my share again. At least, they are here, now. 

And with a bad network, there is little freeze every now and then, even if the document I'm editing is local. Seriously, why do you even need to try to look to the (unused) files when I just want to work on a local one ?
Comment 2 Maxim Monastirsky 2016-05-10 13:59:33 UTC
See Bug 89394 comment 10
Comment 3 fanf42 2016-05-10 14:06:12 UTC
Thanks Maxim, it is clearly linked.
Comment 4 Aron Budea 2016-05-10 21:49:25 UTC
Thanks for the report, and to Maxim for pointing to a previous report of the same issue.

*** This bug has been marked as a duplicate of bug 89394 ***
Comment 5 fanf42 2016-05-11 07:29:47 UTC
Aron Budea: you may have misread my report: the problem is still there, with huge delays, on both 5.0.6 and 5.1.2. So it may be a variation of #89394, but it was certainly not corrected by it. 


Stating it in an other way: I don't want that libre office try to resolve any properties of objects I don't care of, because you CAN'T know how long it will take. Or at least, do it professionnaly, specifying timeout (anything taking more than 100ms is certainly wrong and should be an error. I can accept a few lags in the range of 100s ms). 

Again: I don't care of anything but what I specifically asked for. 
For example, there is NO reasons to try to open (or whatever is done) recent documents, freezing the UI for minutes, when I want to display a slideshare I gave as parameter of the command line to a client. 

And there is no reason to try to get properties for recent documents BUT if I actually clicked on one of the entries, and even then, there is no reason to try to get properties for other entries! As an user, as far I'm concerned, these other documents DON'T exists - please make libre office behave like that.
Comment 6 Aron Budea 2016-05-11 08:26:42 UTC
(In reply to fanf42 from comment #5)

The report was put into RESOLVED DUPLICATE status because the same issue was already reported in another bug report. It does not mean it's fixed, please monitor the status of the other bug report.

*** This bug has been marked as a duplicate of bug 89394 ***