Bug 99770 - Open Remote File for LotusLive does not work
Summary: Open Remote File for LotusLive does not work
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
5.1.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.3.0 target:5.2.0.1
Keywords:
Depends on:
Blocks: CMIS
  Show dependency treegraph
 
Reported: 2016-05-11 04:53 UTC by Shauns
Modified: 2018-09-21 02:47 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shauns 2016-05-11 04:53:31 UTC
When using the "Open Remote File" option from the File menu and selecting "Add Service", then select LotusLive Files, enter a valid logon and password, press the refresh button on repository and an error appears stating "The specified device is invalid".

This may be due to the use of SAML for authentication for logons now.

Would appreciate if someone can test to understand what the issue with the logon is.

In addition, the service is no longer called LotusLive, it is now called IBM Connections Cloud. This needs to be updated.
Comment 1 Adolfo Jayme 2016-05-18 00:47:48 UTC
Please always report a single issue per bug report.

Re: the authentication failure:

> This may be due to the use of SAML for authentication for logons now.

I suppose this should be reported at https://github.com/tdf/libcmis as we seem to lack a Bugzilla component for libcmis.


Re: the name:

According to this page [1], the service’s new name is “IBM Connections Files on Cloud”. I’ve also seen the terms “IBM Connections Files Cloud” and “IBM Connections Files” mentioned in other IBM pages. Which is the proper name?!
The relevant string is this [2].

[1] http://www-03.ibm.com/software/products/en/connections-files-cloud
[2] http://opengrok.libreoffice.org/xref/core/officecfg/registry/data/org/openoffice/Office/Common.xcu#588
Comment 2 Commit Notification 2016-06-11 06:10:31 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f9a8d57028d6de9b1f11d7a1dbc42305fab2e21e

tdf#99770 Update service name from “LotusLive” to “IBM Connections Cloud”

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2016-06-11 06:16:19 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=78db6f5ab915442346bff4f8a55dd2ff15e6dd7f&h=libreoffice-5-2

tdf#99770 Update service name from “LotusLive” to “IBM Connections Cloud”

It will be available in 5.2.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Xisco Faulí 2016-09-15 22:39:42 UTC
Hello,
Is this bug fixed?
If so, could you please close it as RESOLVED FIXED?
Comment 5 Shauns 2016-09-26 08:31:08 UTC
The issue of logging into Connections Cloud is still unresolved. Error is "The Specified Device is Invalid" when using Writer 5.2.1.2 on Ubuntu 16.04 LTS when selecting "Open remote file"

The 2nd part of the issues that relates to the name of the service has been correctly renamed as "IBM Connections Cloud".
Comment 6 QA Administrators 2018-09-21 02:47:48 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug