Bug Hunting Session
Bug 99774 - "Basic script not found" error on auto macro event "Close application"
Summary: "Basic script not found" error on auto macro event "Close application"
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
5.1.2.2 release
Hardware: All Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-11 11:49 UTC by Andreas
Modified: 2017-05-22 18:06 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
This is a TXT file containing macro text for replicating the problem (171 bytes, text/plain)
2016-05-13 09:40 UTC, Andreas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas 2016-05-11 11:49:44 UTC
Hello,

I have found another bug in LibO, that doesn't exist in LibO 5.0.5 but does in LibO 5.1.2.2 and LibO 5.1.3.2:
I have assigned a macro to the event "Close application". In fact the macro is being executed on that event. But straight afterwards I receive the following error message:

"A Scripting Framework error occurred while running the Basic script vnd.sun.star.script:DM_Bib01.mAuto.pProgrammende?language=Basic&location=application.
Message: The following Basic script could not be found:
library: 'DM_Bib01'
module: 'mAuto'
method: 'pProgrammende'
location: 'application'"

This error doesn't occure for other macros being assigned to events (e.g. to the event "Start application").

Andreas
Comment 1 Terrence Enger 2016-05-13 01:25:41 UTC
Can you please attach a document which will make it easy for us to see the error happen?  Remember that your attachment with be available to the whole world.

It would help, as well, if you tell us what version of Windows you are using.

When you have replied, please set the bug status back to UNCONFIRMED.
Comment 2 Andreas 2016-05-13 09:40:25 UTC
Created attachment 125031 [details]
This is a TXT file containing macro text for replicating the problem
Comment 3 Andreas 2016-05-13 09:58:37 UTC
Hello,

The bug occures under Windows 7 and Windows 8.1.

Sending a document? Sorry, but I don't know how I could, as the problem is reported for a user defined macro (d.i. stored in the user's standard library) and not for a document macro. Moreover the problem occures on the event "Close application" - and I guess, all documents would have been already closed at the stage of leaving the application, so it makes no sense to store the macro in a document.

But here I give you an instruction for replicating the situation:
1. Make LibO create a new user directory (by renaming the existing one).
2. Create a macro module "mAuto".
3. Into that module paste the content of the attached TXT file (so you will have a module with two procedures, "pOnStart" and "pOnExit"). Leave the macro editor.
4. Go to the menu "Tools - Customise - Events" and assign the macro pOnExit to event "Close application" and the macro pOnStart to event "Start application".
5. Last, go to "Tools - Options - LibreOffice - Memory" and deactivate option "Load LibreOffice during system start-up".

Now close, start, close etc. the application. On starting the application you will get the message "Aplication is starting." from the macro, and nothing else. But on closing the application you will get the message "Application is closing" (as part of the macro) and afterwards the following error message:

"A Scripting Framework error occurred while running the Basic script vnd.sun.star.script:Standard.mAuto.pOnExit?language=Basic&location=application.
Message: The following Basic script could not be found:
library: 'Standard'
module: 'mAuto'
method: 'pOnExit'
location: 'application'"

Thank you,

Andreas
Comment 4 Buovjaga 2016-05-17 10:10:11 UTC
Confirmed on 5.1.3, but not 5.2

Win 7 Pro 64-bit, Version: 5.1.3.2 (x64)
Build ID: 644e4637d1d8544fd9f56425bd6cec110e49301b
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: fi-FI (fi_FI)

Version: 5.2.0.0.alpha1+
Build ID: 3d27afd26f7b85c46a7c7d08498000b9dbcea1c8
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-05-09_02:42:15
Locale: fi-FI (fi_FI)
Comment 5 QA Administrators 2017-05-22 13:40:47 UTC Comment hidden (obsolete)
Comment 6 Andreas 2017-05-22 18:06:04 UTC
Hello,

bug is nomore present since LibO 5.1.4.2 (Windows 7, Windows 8).

Thank you!

Andreas