Bug Hunting Session
Bug 99834 - UI: tool bar: adding application/input line results in unusable button instead of input line like in formula bar
Summary: UI: tool bar: adding application/input line results in unusable button instea...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Calc-Formula-Bar
  Show dependency treegraph
 
Reported: 2016-05-14 03:54 UTC by andréb
Modified: 2018-11-28 19:26 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andréb 2016-05-14 03:54:15 UTC
(Note that my Libreoffice is in french, so translations may be approximate.)

Since other items in formula bar aren't useful to me, and the formula bar isn't modifiable, I tried adding only the input line field to another tool bar.
This is to save display space, since in the formula bar the input line is unusefully long, but it is often useful to display.

I found the "input line" field ("Ligne de saisie"[fr]) under applications under the "add" button.
(It shows a popup message "Utilisez cette barre pour saisir des formules"[fr]
 = "Use this bar to enter formulas"[en].)
Once selected, this field displays in the bar the uneditable text
 "Ligne de saisie"[fr] = "Input line"[en].

What was expected : it would show the same field that appears in the formula bar.

Note that if the formula bar were editable like the other tool bars, and/or combinable with other tool bars on the same line, this would no longer be a problem.
Comment 1 V Stuart Foote 2016-05-16 13:12:28 UTC
Adding the "Input Line" button from the Application category of customizing a toolbar simply provides a movement button to position program focus into the Formula Bar's Input Line. It is not intended to create a new instance of the formula input widget. Not a bug.

However, you can already hide the Formula Bar (which is *not* a simple button toolbar and so doesn't have button customization of other toolbars) and then insert the button for the "Function" wizard. It is a pop-out dialog of course unlike the formula bar--but provides all the same integrated functions for manipulating cell/sheet formulas.

It can be used without a button, reachable with the Calc short-cut of <ctrl>+F2, but if you want a toolbar button...

As an enhancement, I'm not sure providing a toolbar widget for just the Input Line part of the Formula Bar/Function wizard for use in other toolbar customization makes any sense. Especially as you can already directly enter the simple formula the Input Line into the target cell, or review it graphically with a selection of the cell--what is gained by having the Input Line show in a toolbar other than the hiding the Formula Bar?
Comment 2 andréb 2016-05-18 05:09:19 UTC
(In reply to V Stuart Foote from comment #1)
> Adding the "Input Line" button from the Application category of customizing
> a toolbar simply provides a movement button to position program focus into
> the Formula Bar's Input Line. It is not intended to create a new instance of
> the formula input widget. Not a bug.

If that is all that "button" is supposed to do, it doesn't seem to work, and is of dubious use on a computer with a mouse.

> 
> However, you can already hide the Formula Bar (which is *not* a simple
> button toolbar and so doesn't have button customization of other toolbars)

?? how does the formula bar differ from other tool bars (such as the format tool bar) except for the single entry line field ??
The rest of the formula bar is buttons or drop-down lists.

> and then insert the button for the "Function" wizard. It is a pop-out dialog
> of course unlike the formula bar--but provides all the same integrated
> functions for manipulating cell/sheet formulas.
> 
> It can be used without a button, reachable with the Calc short-cut of
> <ctrl>+F2, but if you want a toolbar button...
> 
> As an enhancement, I'm not sure providing a toolbar widget for just the
> Input Line part of the Formula Bar/Function wizard for use in other toolbar
> customization makes any sense. Especially as you can already directly enter
> the simple formula the Input Line into the target cell, or review it
> graphically with a selection of the cell--what is gained by having the Input
> Line show in a toolbar other than the hiding the Formula Bar?

Then why have the input line field in the formula bar ?  It does display clearly what is in the input field, often not clear in small cells.
If one doesn't want to see the other fields in the formula bar, why wouldn't it be reasonable to add this field to another tool bar ?  This could allow displaying tool bar items in fewer lines, thus freeing up screen space for the cells + other apps.

As stated in the initial comment, being able to customize the formula bar would also solve the problem.
Comment 3 V Stuart Foote 2016-05-18 11:12:14 UTC
The Formula Bar has unique functions, as does the Input Line. The buttons displayed in the Formula Bar are contextual. And the Input Line is not really a line but has been collapsed from its multi-line window to nominally fit within toolbar height. A toggle is provided to expand the window.

Without major refactoring, function of the Formula Bar/Input Line remains coded in sc source [1] and providing for "customization" of hiding other elements would compromise usability for minimal gain.

Personally would resolve this Wont Fix, but leaving open for other UX comment.

=-ref-=
http://opengrok.libreoffice.org/xref/core/sc/source/ui/app/inputwin.cxx
Comment 4 Cor Nouws 2018-11-28 18:26:33 UTC
(In reply to V Stuart Foote from comment #3)

> Personally would resolve this Wont Fix, but leaving open for other UX
> comment.

Same for me
Comment 5 Heiko Tietze 2018-11-28 19:26:51 UTC
There are only (well founded) opinions against a change. So let's refrain from this enhancement.