Bug 99842 - EDITING: when i use a formula in calc and save in xlsx, the formula is destroyed
Summary: EDITING: when i use a formula in calc and save in xlsx, the formula is destroyed
Status: CLOSED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.6.2 rc
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2016-05-14 17:27 UTC by vlb
Modified: 2016-05-19 16:42 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
destroy formula (9.56 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-05-14 17:27 UTC, vlb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vlb 2016-05-14 17:27:22 UTC
Created attachment 125048 [details]
destroy formula

I use windows 10 64 bits LO 5.1.3.2 (x64):

With reference to bug 86575 i have the problem make small.

Reproduce bug:

1) open attachment "afronden.ods"
2) save as *.xlsx
3) the formula in A2, A3, A4, A5 and B2, B3, B4, B5 are destroyed

I have test in LO 3.5 to 4.4.7 and there was it oke.
In LO 5.1.0.1 there was the first where the bug are precent.
I didn't have LO 5.0.0 and 5.1.0 and didnt have test here.
Comment 1 vlb 2016-05-14 19:40:31 UTC
I have test in LO 5.0.6 and there is also the bug precent.
Comment 2 m.a.riosv 2016-05-15 00:07:51 UTC
Please what do you mean by destroyed?

What I see is FLOOR() changed by FLOOR.MATH() and CEILING() changed by CEILING.MATH()

Related information:
https://wiki.documentfoundation.org/ReleaseNotes/5.0#New_spreadsheet_functions
Comment 3 m.a.riosv 2016-05-15 00:08:29 UTC
Win10x64
Version: 5.1.3.2 (x64)
Build ID: 644e4637d1d8544fd9f56425bd6cec110e49301b
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default;
Comment 4 vlb 2016-05-15 07:59:31 UTC
(In reply to m.a.riosv from comment #2)
> Please what do you mean by destroyed?
> 
> What I see is FLOOR() changed by FLOOR.MATH() and CEILING() changed by
> CEILING.MATH()
> 
> Related information:
> https://wiki.documentfoundation.org/ReleaseNotes/5.
> 0#New_spreadsheet_functions

I have a Dutch version of LO.
There is also change the formula from NL to EN, i didn't know about change in release note.

The change is:
"afronden.beneden()" in "_xlfn.FLOOR.MATH()"
and
"afronden.bboven()" in "_xlfn.CEILING.MATH()"
This shos a error in the result in #name?.
Comment 5 vlb 2016-05-15 08:32:31 UTC
(In reply to vlb from comment #4)
> (In reply to m.a.riosv from comment #2)
> > Please what do you mean by destroyed?
> > 
In version LO 4.4.7 is the formula disappeared in cel A2, A3 and B2, B3.
Here is a celname used.
In LO 4.4.2 isn't the formula disappeared.
Comment 6 vlb 2016-05-15 08:41:01 UTC
When i used the formula "afronden()" in the dutch version LO 5.1.3.2 and open the version Version: 5.1.4.0.0+
Build ID: 33fe9e6da9241aacac6816cbb5211f4d5fa7fba1
LO crashed
Comment 7 vlb 2016-05-15 09:36:57 UTC
> The change is:
> "afronden.beneden()" in "_xlfn.FLOOR.MATH()"
> and
> "afronden.bboven()" in "_xlfn.CEILING.MATH()"
> This shos a error in the result in #name?.
This happens when i save the file in *.xlsx and open in excel 2007.
When i open the *.xlsx file in LO 5.1.3.2 the change are:

LO English
FLOOR() -> FLOOR.MATH()
CELING() -> CEILING.MATH()

LO Dutch
afronden.beneden() -> ONDERGRENS.MATH()
afronden.boven() -> BOVENGRENS.WISKUNDIG()
Comment 8 vlb 2016-05-15 10:24:03 UTC
(In reply to vlb from comment #7)
> > The change is:

> LO Dutch
> afronden.beneden() -> ONDERGRENS.MATH()
> afronden.boven() -> BOVENGRENS.WISKUNDIG()

In Excel 2016 is change in, when open *.xlsx:
LO Dutch
afronden.beneden() -> afronden.beneden.wisk() with error mention
afronden.boven() -> afronden.boven.wisk()     with error mention
Comment 9 Markus Mohrhard 2016-05-17 00:52:22 UTC
Can we please try to limit bug reports to one issue and provide one descriptive set of steps how to reproduce the error.

For this bug report anything happening before 5.0 is irrelevant as the code around FLOOR import/export changed a lot.
Comment 10 Eike Rathke 2016-05-19 16:42:07 UTC
For the relevant changes see https://wiki.documentfoundation.org/ReleaseNotes/5.0#Formula_engine "New spreadsheet functions".

I guess if you use Excel2007 to open .xlsx you're out of luck in this case because Excel2007 doesn't implement FLOOR.MATH() and CEILING.MATH(). If you need compatibility with such old versions then use FLOOR.XCL() and CEILING.XCL() that require 2 parameters, which the others don't, and gets saved as FLOOR() and CEILING() for Excel.