Bug 99854 - Copy contents from cells massively sets capitalized text
Summary: Copy contents from cells massively sets capitalized text
Status: RESOLVED DUPLICATE of bug 75387
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-15 05:20 UTC by Miguel Zúñiga
Modified: 2016-06-23 12:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample, if opened on Calc 5.1.1 or later, the column D goes uppercase (100.30 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-05-15 05:20 UTC, Miguel Zúñiga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Miguel Zúñiga 2016-05-15 05:20:32 UTC
Created attachment 125056 [details]
Sample, if opened on Calc 5.1.1 or later, the column D goes uppercase

From LibreOffice 5.1, if a "=" function is applied to copy contents from a column in 100 or more cells at a time, the text goes to uppercase, no matter what style it has.
LibreOffice 5.0.5rc2 and previous do not behave like this. To reproduce the behaviour:
* Put content in a column. 100 or more cells.
* In a contiguous or non-congiguous column, use the = function referring to the first column.
* Copy and paste the function to 100 or more cells.

The text will be uppercase.

The attached file is saved using Libreoffice Calc 4.4.5 and displays fine in 5.0.5rc2 and 4.4.5, but column D appears uppercase in 5.1+.

If you save this document in 5.1+ and open it again in a previous version it will show the contents uppercase, then if you overwrite the function, it will show the content of the cell (for example, =A1) instead of the result.
Comment 1 Karl 2016-05-15 08:09:21 UTC
I can confirm this behavior.

LO 5.1.2.2 release , x86 Win 7 x64

Create a new file, put a "abc" or else in first column (a lot of cells down)

put in D1 :: =A1

draw "=A1" formula down to D xy

all is in Upper Case
Comment 2 Karl 2016-05-15 08:37:54 UTC
Happens in 5.1.3.2 x64 too
Comment 3 MM 2016-05-15 09:23:42 UTC
Unconfirmed with v5.1.3.2 under ubuntu 16.04 x64.
Unconfirmed with v5.1.3.2 under windows 10 x64.

Can't reproduce, even when I try the steps as in comment 1 everything stays in lowercase.
Comment 4 Miguel Zúñiga 2016-05-15 17:49:27 UTC
Hello, MM. I first noticed the bug on Ubuntu 16.04 64-bit. Just open the attached file and you will see the column D in uppercase. You need to paste the = function in 100 or more cells at a time. With 99 or less, it shows fine. It can be even the same text or different text on the referring column, one or more words, in a given column. The attached file in comment 1 has a little more than 1100 cells in a column.

This does not happen if you paste the = function in 100 or more cells in a row, only if you paste it in 100 or more cells in a column.

I do not have a single MS Windows application at home, I would look for at work if you want me to. I could test it in the following GNU/Linux distributions:

I can reproduce it on:
libreoffice-calc 1:5.1.2-0ubuntu1 (Ubuntu 16.04 64 bit and Lubuntu 16.04 32 bit)
libreoffice-fresh 5.1.3-1 (Arch current 64 bit)
libreoffice-calc 5.1.3.1 (OpenSUSE Tumbleweed, 5.1.3.1, 64 bit)
libreoffice-calc 1:5.1.3~rc2-3 (Debian Stretch testing, 32 bit)

Does not happen in:
1:5.0.6.2-4.fc23 (Fedora 23 64 bit)
1:4.3.3-2+deb8u3 (Debian Jessie stable 32 and 64 bit)
5.0.4.2 (OpenSUSE Leap 42.1, 5.0.4.2, 64 bit)

Thank you for taking the time in solving this.
Comment 5 m.a.riosv 2016-05-16 00:04:53 UTC
Not reproducible:
Win10x64
Version: 5.1.3.2 (x64)
Build ID: 644e4637d1d8544fd9f56425bd6cec110e49301b
CPU Threads: 1; OS Version: Windows 6.19; UI Render: default; 

This looks as a typical OpenCL issue, it acts by default with a data size larger than 100.

Several OpenCL was solved lately.

Please test if disabling OpenCL in:
Menu/Tools/Options/LibreOffice/OpenCL
solves the issue.

The data size can be specified in:
Menu/Tools/Options/LibreOffice calc/Formula - Custom - Details - OpenCL settings.

If disabling OpenCL doesn't solve the issue,
Please try resetting the user profile.
https://wiki.documentfoundation.org/UserProfile
Usually it's enough renaming/deleting the file "user/registrymodifications.xcu",  it affects all the options in Menu/Tools/Options, and the files "user/basic/dialog.xlc" and "scrip.xlc" are overwritten, additionally custom colors in "user/config/standard.soc" are lost.
Comment 6 Aron Budea 2016-06-23 02:55:45 UTC
This is a bug related to the OpenCL Software Interpreter, and has already been reported in bug 75387.
It occurs in either of these cases:

-you have both checkboxes ticked in Tools -> Options... -> LibreOffice -> OpenCL, but don't have an OpenCL-capable device with drivers that support OpenCL,

-you only have OpenCL Software Interpreter enabled in the aforementioned dialog.

I'm closing this as duplicate, please follow the other bug report.

*** This bug has been marked as a duplicate of bug 75387 ***
Comment 7 Tor Lillqvist 2016-06-23 12:17:00 UTC
There is nothing called "OpenCL Software Interpreter". The "Software Interpreter" is used *instead* of OpenCL in some cases, as far as I understand it.