Bug Hunting Session
Bug 99855 - UI - Tools > Accessibility panel Support Assistive technology tools checkbox, does it have a function any longer?
Summary: UI - Tools > Accessibility panel Support Assistive technology tools checkbox,...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility, needsDevEval
Depends on:
Blocks: a11y-Windows Writer-View-Jumps
  Show dependency treegraph
 
Reported: 2016-05-15 11:36 UTC by John
Modified: 2018-07-18 08:15 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John 2016-05-15 11:36:09 UTC
See 73518 and 80332

Lo x86 5.1.3.2 on Win10 Pro x64
Dragon NaturallySpeaking is installed

I noticed, when scrolling in writer such that the cursor insertion point was not visible, that on stoppling scrolling, the displayed page would jump back to the location of the cursor. This annoying behaviour is something I associated in the past with "assistive" technology in Word.

This led me to try to turn off Tools > Options > LibreOffice > Accessibility > Support assistive technology tools only to find that clearing the check-box will not stick. On restarting LO, the box always remains checked. Trying to change the configuration as an administrator made no difference.

My reading of bug 80332 suggests to me that maybe LO has detected NaturallySpeaking and has forcibly turned on assistive technology as a result. I cannot test this as uninstalling NaturallySpeaking and then reinstalling might use up one of my activations.

The bug is the inability to turn off assistive technology but I would be interested to know if the scrolling behaviour noted above has anything to do with assistive technology.
Comment 1 V Stuart Foote 2016-05-16 15:24:33 UTC
With implementation of the final "native" IAccessible2 v1.3 based bridge for Windows (replacing Java JRE JAA bridge) the assistive tools technology support is enabled when an assistive technology is detected present and active. You can not disable it as it is built in.

With your Dragon Natuarlly speaking present and active--LibreOffice will toggle the Tool -> Options -> Accessibility "support assistive technology tools" active.

Otherwise, it can be unchecked disabled--but believe it no longer has any effect as it will enable by design when an assistive technology is in use.

However, that is not the cause of your issue with scrolling repositioning back to the last edit cursor position. That is simply that scrolling the canvas does not reposition the edit cursor. You can click into the document, or you can <PageDown> and <PageUp> to relocate the edit cursor into the currently in view portion of the canvas.

No need to uninstall Dragon speech recognition.
Comment 2 John 2016-05-17 13:14:10 UTC
Thanks for that. If the toggle for assistive technology does nothing, then I suggest it be removed. If it does do something for those without assistive technology, then I suggest it be greyed out for those with assistive technology.

Is there any information as to what is automatically turned on when an assistive technology is detected?
Comment 3 QA Administrators 2017-05-22 13:39:32 UTC Comment hidden (obsolete)
Comment 4 V Stuart Foote 2017-05-22 14:34:57 UTC
Still an issue...
Version: 5.3.3.2 (x64)
Build ID: 3d9a8b4b4e538a85e0782bd6c2d430bafe583448
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; Layout Engine: new; 
Locale: en-US (en_US); Calc: group

@Jay, Adolfo? Michael M?
Comment 5 Yousuf Philips (jay) (retired) 2017-05-22 15:44:23 UTC
(In reply to V Stuart Foote from comment #1)
> With your Dragon Natuarlly speaking present and active--LibreOffice will
> toggle the Tool -> Options -> Accessibility "support assistive technology
> tools" active.

This checkbox only appears in Windows and yep if its unchecked and you start LO with NVDA, it will automatically check it, so not sure what the benefit of displaying it would be if it overrides user deactivation. @Maxim: Any thoughts?

> However, that is not the cause of your issue with scrolling repositioning
> back to the last edit cursor position. That is simply that scrolling the
> canvas does not reposition the edit cursor. You can click into the document,
> or you can <PageDown> and <PageUp> to relocate the edit cursor into the
> currently in view portion of the canvas.

Is this the same autosave issue from bug 41063, as i'm not sure what i should be testing for this bug.
Comment 6 QA Administrators 2018-07-18 02:39:02 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug