Bug 99861 - Broken BASIC example code indentation
Summary: Broken BASIC example code indentation
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha1
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Caolán McNamara
QA Contact:
URL:
Whiteboard: target:5.2.0.1
Keywords: regression
Depends on:
Blocks:
 
Reported: 2016-05-15 15:05 UTC by Johnny_M
Modified: 2016-10-25 19:02 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Broken BASIC example code indentation (107.49 KB, image/png)
2016-05-15 15:05 UTC, Johnny_M
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Johnny_M 2016-05-15 15:05:11 UTC
Created attachment 125061 [details]
Broken BASIC example code indentation

The code example indentation seems broken throughout the BASIC help pages: just two spaces, no sub-indentation for statements.

Confirmed on Debian Jessie, 32-bit, with:
Version: 5.2.0.0.alpha1+
Build ID: a3123cd0105c1feec3a06d071c97cb758b307bf8
CPU Threads: 2; OS Version: Linux 4.3; UI Render: default; 
TinderBox: Linux-rpm_deb-x86@71-TDF, Branch:master, Time: 2016-05-15_10:23:02
Locale: en-US (en_US.UTF-8)
Comment 1 raal 2016-05-17 16:52:59 UTC
I can confirm with Version: 5.2.0.0.alpha1+
Build ID: eb7593daa4bac21bd68182c8bbbd3ee3bd7b64dd
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-05-03_07:06:45
Comment 2 Caolán McNamara 2016-06-16 10:25:28 UTC
This seems to be a regression from...

commit 6614bedceadcc07ec082c5e926107f27903bda5c
Author: Christian Lohmaier <lohmaier+LibreOffice@googlemail.com>
Date:   Mon Jan 25 20:07:10 2016 +0100

    fix validation errors by round-trip through helpauthoring extension
Comment 3 Christian Lohmaier 2016-06-16 11:35:23 UTC
nope, no regression. That string was a single string before already.

-<paragraph role="bascode" id="par_id3150400" xml-lang="en-US" oldref="4">Select Case condition Case expression Statement Block [Case expression2 Statement Block][Case Else] Statement Block End Select</paragraph>

+<paragraph id="par_id3150400" role="bascode" xml-lang="en-US">Select Case condition Case expression Statement Block [Case expression2 Statement Block][Case Else] Statement Block End Select</paragraph>


Reassigning to Olivier to decide what's the best time to fix it/whether to fix for 5.2 or not (next week is string freeze)
Comment 4 Christian Lohmaier 2016-06-16 11:42:21 UTC
sorry, looking closely I see the regression - should have looked at the actual sample below, that indeed loses the indent/did flatten it.

so bug in helpauthoring extension..

changing most of those should not affect translators, as they have localize="false" attribute already.
Comment 5 Caolán McNamara 2016-06-16 14:55:08 UTC
I'll take this for recovering the missing indent in the helpcontent repo, though it appears that the help extension has a bug here in causing the indent to go away in the first place which I won't personally address
Comment 6 Commit Notification 2016-06-16 15:13:35 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=8ff2c5f505ed1f29901313692b8e3ca5d100d225&h=libreoffice-5-2

Resolves: tdf#99861 Recover lost basic in help indentation
Comment 7 Caolán McNamara 2016-06-16 15:19:21 UTC
fix-up is in master too