Download it now!
Bug 99862 - Can't print landscape mode envelopes
Summary: Can't print landscape mode envelopes
Status: RESOLVED DUPLICATE of bug 44932
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-15 15:20 UTC by Lloyd
Modified: 2016-06-09 09:05 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lloyd 2016-05-15 15:20:55 UTC
This seems to be an erratic bug since this feature was working a couple of weeks ago. But using the exact same settings, I have been unable to print envelopes in Landscape mode.

After dealing with various settings a couple of weeks ago, I was able to print a couple of envelopes. I never could set the document orientation for Landscape. But I was finally able to get the Envelope option to print them correctly. Today, I am unable to get this feature to work at all using the same settings.

2nd. I am using two Epson printers and I am having the same problem with both printers. Epson NX415 and Epson Artisan 837.

3rd. As I touched on above, no part of the LibreOffice package will not let me set the orientation for landscape printing. This includes Writer, Drawing, Presentation, Spreadsheet, or Database. The orientation problem is a constant and repeatable problem. I strongly suspect that this is part of the envelope printing problem or a separate issue. I can't even guess what I did to make envelope printing to work a couple of weeks ago.
Comment 1 Regina Henschel 2016-05-15 17:15:21 UTC
Have you tried to set the page layout in Writer, menu Format > Page?
Are you able to print a standard sized page (letter or DIN A4 depending or your location) in landscape?

There are so much to consider for envelope printing, that I suggest, that you first discuss it in a forum or on a mailing list. For example:
(A) Do you use the wizard, or do you define the envelope page template manually?
(B) Do you have checked "Use only paper tray from printer preference" in Options tab of the printing dialog and set the tray in the printer properties or do you use the automatic?
(C) Do you have checked "Use only paper size from printer preferences" in Options tab of the printing dialog and set the paper size in the printer properties or do you use the automatic?
(D) Is the envelope size directly supported by the printer or do you need to use a user-defined format in the printer settings?
(E) Do you use the true paper size of your envelope, or do you have added additional margins to compensate alignment problems?
(F) On Linux? How do you have setup printing?
Comment 2 Lloyd 2016-05-16 12:20:05 UTC
rb.henschel
A: I have been using the Envelope wizard.
B: I have tried both checking and un-checking "Use only paper tray from printer preference". My default setting is unchecked.
C: "Use only paper size from printer preferences" in Options does not show up in my "Options". (Note: I am using version 5.0.3.2, which is the latest version available from the Linux Mint and Linux Ubuntu Repositories. I noticed that the latest version of LibreOffice was available for download from the LibreOffice website, but there is no PPA for automatic updates to the website and newer versions are not being maintained by the Linux Mint or Ubuntu repositories yet.)
D: Printer supports whatever format is submitted to it. Both printers are graphics printers, and the Artisan 837 is a photographic printer. Neither printer is designated as a specific office printer.
E: I have tried both the true paper size and setting the margins manually. Neither has worked.
F: Linux? Simple. There is a version of LibreOffice for all operating systems such as Windows, MACs, all versions of Linux, and all versions of BSD. Epson makes and distributes drivers for their printers for Windows, MACs (Which uses a base BSD operating system called Darwin), and all versions of Linux. Various BSD distributions are usually supported indirectly. However, I am using a Linux system. (If you have received a hardware firmware update recently, chances are that it contained a tiny Linux operating operating system to update your firmware. Something that I accidentally discovered recently myself.)

The same problem persists with all of the LibreOffice suit products on my computer. No Landscape printing, which is required for printing Envelopes.
Comment 3 MM 2016-05-16 21:53:16 UTC
(In reply to Lloyd from comment #2)
>(Note: I am using version 5.0.3.2, which is the latest
> version available from the Linux Mint and Linux Ubuntu Repositories. I
> noticed that the latest version of LibreOffice was available for download
> from the LibreOffice website, but there is no PPA for automatic updates to
> the website and newer versions are not being maintained by the Linux Mint or
> Ubuntu repositories yet.)

1) Well I would say, you don't have to wait for the update on PPA. You can simply remove it from PPA and install it manually, as I did on mint and ubuntu.
2) LO packages on PPA *might* be incomplete. ie: you never know what packages they allow to install and which ones they don't.
Comment 4 Lloyd 2016-05-17 02:43:41 UTC
Found work-around solution. Save file as PDF, then print PDF file in landscape mode.
Comment 5 Alex Thurgood 2016-06-09 09:05:29 UTC

*** This bug has been marked as a duplicate of bug 44932 ***