Bug 99865 - Calc EDITING: Move up Cell Not Working When Editing Formulas
Summary: Calc EDITING: Move up Cell Not Working When Editing Formulas
Status: RESOLVED DUPLICATE of bug 63994
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2016-05-15 19:39 UTC by Joey Reid
Modified: 2016-05-17 11:56 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joey Reid 2016-05-15 19:39:13 UTC
While testing today's daily, I discovered that shift+enter no longer moves up a cell when editing a formula. This is a regression, as it has always worked in Libreoffice 5.1.3 and every other spreadsheet program I have used.

Steps to reproduce:
1. Create a new spreadsheet
2. Enter the formula in the formula bar
3. Press shift+enter

Expected Result:
1. Calculate your formula and move up

Actual Result:
1. It moves down in the current cell

Discovered on: Version: 5.2.0.0.alpha1+
Build ID: 23ad336bfe61316b08f85e827b98fc593ac6908a

5.1 is working perfectly.
Comment 1 Joey Reid 2016-05-15 19:52:30 UTC
Looks like this is caused by Bug 63994. I do not think we should overload shift+enter. Why can't a different shortcut be chosen? Like alt+enter which is what every other spreadsheet uses.
Comment 2 Samuel Mehrbrodt (CIB) 2016-05-17 11:56:14 UTC
Lets continue the discussion in #63994.

*** This bug has been marked as a duplicate of bug 63994 ***