Bug 100031 - FILEOPEN FILESAVE Support Onedrive for Business/Sharepoint Online
Summary: FILEOPEN FILESAVE Support Onedrive for Business/Sharepoint Online
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: SharePoint
  Show dependency treegraph
 
Reported: 2016-05-24 16:41 UTC by Iiro Laiho
Modified: 2022-02-25 12:21 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Iiro Laiho 2016-05-24 16:41:06 UTC
It would be nice if LibreOffice supported Office365 OneDrive for Business/Sharepoint Online.

There is currently no OneDrive for Business client for Linux, but if LibreOffice supported ODfB file access directly, it would help co-operation with Microsoft Office users.

There is a REST API for Onedrive and Onedrive for Business:

https://dev.onedrive.com/getting-started.htm
Comment 1 Buovjaga 2016-05-26 12:53:00 UTC
Setting to NEW.
Comment 2 Iiro Laiho 2016-06-05 11:31:10 UTC
Any idea how much effort this would need? Could it be done with an addon? I am even thinking of paying someone to do this if it won't be a very big (expensive) job.
Comment 3 Buovjaga 2016-06-05 15:27:54 UTC
Hmm. Is OneDrive for Business somehow very different from the regular OneDrive? OneDrive support is still unfinished: bug 62437
If you think it would be all the same, you could close your report as a duplicate of bug 62437
Comment 4 Iiro Laiho 2016-06-06 18:58:48 UTC
They are actually quite different. ODfB is actually more close to SharePoint. But last year Microsoft released the new OneDrive REST API 2.0 that works for both services. I have no idea which API the now-broken and disabled OneDrive integration functionality in LibreOffice utilizes.

I also tried using the SharePoint support in LibreOffice, but didn't get it working, likely because ODfB supports only forms based authentication.
Comment 5 Iiro Laiho 2016-06-12 19:26:37 UTC
I would also mention that in ODfB, files shared by others to you are not synced to the local folder. Microsoft Office accesses them via WebDAV.

I think the best course of action would be make LibreOffice support form-based authentication on WebDAV. Then one would be able to enter the URL of the document to LibreOffice and open it for editing.
Comment 6 rizwankhan 2021-02-01 06:51:01 UTC Comment hidden (spam)
Comment 7 vladyhahavaets 2021-02-28 14:03:10 UTC Comment hidden (spam)
Comment 8 steve 2021-07-28 10:50:27 UTC
There is the possibility this problem got fixed as per cloph's fixes in https://bugs.documentfoundation.org/show_bug.cgi?id=115643#c19 - thanks for you work!

Fixes will be available in 7.1.0.0.beta2 and 7.2.0 main builds.

As a business account is required to re-test this and no LO QA team member has such an account please do retest with 7.1 beta2 builds or 7.2 main builds and report back the situation you encounter.
Comment 9 QA Administrators 2022-01-25 03:40:35 UTC Comment hidden (obsolete)
Comment 10 QA Administrators 2022-02-25 03:34:07 UTC Comment hidden (obsolete)
Comment 11 Iiro Laiho 2022-02-25 12:21:09 UTC
I am sorry, I do not have any OneDrive for Business plans that I could test this with.