Download it now!
Bug 100291 - When using the Copy Sheet to a different document, actions are grayed out when 1 sheet exists in source document
Summary: When using the Copy Sheet to a different document, actions are grayed out whe...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks: Sheet
  Show dependency treegraph
 
Reported: 2016-06-09 12:56 UTC by Terry Kyriss
Modified: 2018-09-20 18:54 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Terry Kyriss 2016-06-09 12:56:15 UTC
User-Agent:       Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2486.0 Safari/537.36 Edge/13.10586
Build Identifier: LibreOffice 5.0.6.3

I download my statements in excel or cvs format from various sites and then put them in a workbook.  When using the Move/Copy Sheet to a different workbook actions are grayed out and copy is the only choice so after I copy the sheet, I have to delete the original.  Besides the extra step from what I'm used to with Office, there's always the chance of deleting the wrong sheet.

Reproducible: Always

Steps to Reproduce:
1. Download a cvs or excel format file from a site.
2. Click on the sheet tab and choose Move/Copy Sheet.
3. Note the Actions are grayed out and the button is set to copy.
Actual Results:  
A copy of the sheet is inserted into the other workbook and then the original sheet will need to be deleted.  

Expected Results:  
A user should be able to move the sheet in one step.

[Information automatically included from LibreOffice]
Locale: en-US
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: no


Reset User Profile?No
Comment 1 Buovjaga 2016-06-11 14:18:11 UTC Comment hidden (obsolete)
Comment 2 Terry Kyriss 2016-06-12 10:28:35 UTC
I haven't found version 5.1 to download yet.  I'm using Version: 5.0.6.3. To be clearer, the steps are:
1. open a sheet that has been saved (.xls or .ods).
2. open a different sheet and right click on the tab of the second sheet.
3. choose Move/Copy sheet.
4.  the actions are grayed out with "copy" as the selection.
Comment 3 Buovjaga 2016-06-12 14:18:12 UTC
http://www.libreoffice.org/download/libreoffice-fresh/(In reply to Terry Kyriss from comment #2)
> I haven't found version 5.1 to download yet.  I'm using Version: 5.0.6.3. To
> be clearer, the steps are:
> 1. open a sheet that has been saved (.xls or .ods).
> 2. open a different sheet and right click on the tab of the second sheet.
> 3. choose Move/Copy sheet.
> 4.  the actions are grayed out with "copy" as the selection.

Ok now I get it, but I don't know if this is intentional.
If you add another sheet to the 2nd document before opening the Move/copy dialog, then the actions are not greyed out.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha0+
Build ID: e1ca24369142af3e721e789bf757be671e1905b7
CPU Threads: 8; OS Version: Linux 4.6; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Built on June 10th 2016
Comment 4 Buovjaga 2016-06-12 15:12:09 UTC
Markus on IRC confirmed that this is a bug and looks like it is caused by this change: https://cgit.freedesktop.org/libreoffice/core/commit/?id=9e96d3e1e53d72453bdd5cfa6447b0d58a3d85c1
Comment 5 Timur 2017-03-10 19:21:02 UTC
Personally, I don't consider this a bug and I'd recommend this be closed as NotaBug or WintFix. I'd do it myself should there be no previous comment. 
LO cannot delete the last sheet and have empty workbook. If there's 1-sheet document, it's normal to have only copy and delete the document. Move the only sheet doesn't make sense.
Comment 6 Kevin Suo 2017-04-19 05:45:01 UTC
This is not a bug. At least one sheet should be exist in a workbook (spreadsheet). If the only sheet is deleted, the spreadsheet is not a spreadsheet anymore.
Comment 7 Buovjaga 2017-04-19 06:51:37 UTC
Well, Timur & Kevin, please talk to Markus about it.
Comment 8 Xisco Faulí 2017-09-14 10:45:31 UTC
Timur & Kevin, did you have the change to talk to Markus?
Comment 9 Timur 2017-09-14 10:53:44 UTC
No, but I think compromise is to rename this to "Copy" only. Move doesn't make sense. Even than it's trivial, because you can add empty sheet.
Comment 10 QA Administrators 2018-09-15 03:10:14 UTC Comment hidden (obsolete)
Comment 11 Roman Kuznetsov 2018-09-15 12:59:33 UTC
Still repro in 6.1.1.1 but

I want add my 5 cents. We can:

Variant 1: In case when we have only one sheet in workbook we should have only one variant "Copy sheet" in dialogue "Move/Copy sheet".

Variant 2: Don't touch dialogue, but if we moved (copy and then delete) sheet when there is only one sheet, then should be insert a new empty sheet in source workbook.

Variant 3: make two different item "Copy sheet" and "Move sheet" and two dialogue. And when there is only one sheet user shouldn't see item "Move sheet"

Variant 4: close this bug as WONTFIX, because it works as expected now and user can't shot in his own leg

@Heiko: what do you think?  We need some UX help
Comment 12 Heiko Tietze 2018-09-16 08:14:03 UTC
(In reply to Roman Kuznetsov from comment #11)
> @Heiko: what do you think?  We need some UX help

Question goes to all UX folks: c4, c5, and c11.
Comment 13 V Stuart Foote 2018-09-16 20:14:41 UTC
Looking at Kohei's commit (comment 4) I don't see this as a bug. The behavior makes sense--you can not move the last sheet from an ODF Spreadsheet document in Calc and have it remain a valid spreadsheet/workbook.

With ref commit, documents containing multiple sheets do allow moving sheet to other document.

IMHO => NAB & WF
Comment 14 Timur 2018-09-17 07:03:46 UTC
Let me remind that I renamed "Move/Copy" to just "Copy" and marked "trivial" because you can add empty sheet and than copy. 
Bug doesn't make much sense, but we may keep it and thus prevent some future duplicates.
Comment 15 Heiko Tietze 2018-09-17 09:31:38 UTC
Okay, so let's close as NAB. Duplicates can be done anyway.
Comment 16 Terry Kyriss 2018-09-17 11:37:11 UTC
I just checked and now both move and copy are grayed out if there is only one sheet in a workbook although the sheet can be moved.


Having the ability to move a sheet is necessary when a user downloads a spreadsheet and wants to put it into a workbook that he/she has already created.  This is a trivial bug but it involves two steps when there could be one (as is the case in Excel).
Comment 17 Buovjaga 2018-09-18 11:34:46 UTC
(In reply to Terry Kyriss from comment #16)
> Having the ability to move a sheet is necessary when a user downloads a
> spreadsheet and wants to put it into a workbook that he/she has already
> created.  This is a trivial bug but it involves two steps when there could
> be one (as is the case in Excel).

All this talk about Excel started bothering me, so I tested with Excel 2013. The claim is false: Excel does not allow you to move a sheet, if it is the sole one in the document. It shows an error dialog, if you attempt it.
Comment 18 Thomas Lendo 2018-09-20 18:54:08 UTC
I'm a bit late but:
I can live with NAB but from usability perspective I prefer proposal (variant) 2 of Roman's comment 11: 'Don't touch dialogue, but if we moved (copy and then delete) sheet when there is only one sheet, then should be insert a new empty sheet in source workbook.'

Technically the actual behavior os logical but not from normal user's perspective. There is no difference between moving one of some sheets and moving of the only sheet of a spreadsheet.

This difference now lead on to questions like this bug report or to an explanation in the help files. For what? We wouldn't need any explanation with the above proposal. The user is free to move whatever wherever he wants. For me that's the best usability solution.