Bug 100314 - EDITING FORMATTING: context sensitive toolbar makes document jump
Summary: EDITING FORMATTING: context sensitive toolbar makes document jump
Status: RESOLVED DUPLICATE of bug 36976
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-10 16:45 UTC by stephen.bungay42
Modified: 2016-06-12 08:48 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description stephen.bungay42 2016-06-10 16:45:05 UTC
Text Formatting tool-bar appears and disappears depending on whether text is being manipulated or not causing the working area to move up and down a distance equivalent to the he height of the tool bar. 

Suggested Enhancement: 
   Keep the "text-formatting" tool-bar on the screen in either an "Enabled" or "disabled" state, depending on if text is being manipulated or not. This will prevent the document from jumping up and down, preserve the end user's sanity, and in general make the whole experience much more productive & enjoyable.
Comment 1 Regina Henschel 2016-06-10 17:46:56 UTC
It helps to enable the "Line and Filling" toolbar as well, because either "Text Formatting" or "Line and Filling" is shown. (Besides little height differences already addressed in bug 78924.)

Another way to avoid jumping is to undock the toolbar, or to dock it to the left or bottom of the window.

Another workaround is to define an own empty bar and put it in the row under the standard bar. This empty bar is always there, because it is a user defined bar. It works then as place holder to keep the edit area from jumping. 

There is a more general discussion of popping up toolbars in bug 36976.
Comment 2 Heiko Tietze 2016-06-12 08:48:52 UTC
After the detailed explanation by Regina we should close this ticket as duplicate of 36976. Feel free to reopen, or join the discussion on the duplicate.

*** This bug has been marked as a duplicate of bug 36976 ***