Download it now!
Bug 100393 - Issue with clone conditional formatting. Not all copied formatting is saved.
Summary: Issue with clone conditional formatting. Not all copied formatting is saved.
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.3.2 release
Hardware: All All
: medium normal
Assignee: Markus Mohrhard
URL:
Whiteboard: target:5.3.0 target:5.2.3 target:5.2.2
Keywords:
: 88790 100099 (view as bug list)
Depends on:
Blocks: Conditional-Formatting
  Show dependency treegraph
 
Reported: 2016-06-15 08:44 UTC by szyb
Modified: 2017-07-17 09:35 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file to reproduce the bug. Use the steps from comment (8.53 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-06-15 08:44 UTC, szyb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description szyb 2016-06-15 08:44:59 UTC
Created attachment 125664 [details]
Sample file to reproduce the bug. Use the steps from comment

Steps to reproduce bug:
1. Create a simple file (attached) with one custom style (name: "Highlight1")
2. Open the file and go to cell C2
3. Edit conditional formatting for cell C2. Set "equal to" to "$A2" and choose style "Highlight1"
4. Go to cell C2 and use Clone Formatting option and clone it to cells D2 to F2 => no visible changes for now.
5. Afterwards go to cell C2 and clone formatting for cells C3:F4
=> now cells C3,C4,E3,E4 and F3 are highlighted with Highlight1 style
6. Save the file
7. Close LibreOffice and reopen saved file
=> The file was not saved well. Conditional formatting are missing for some cells (some cells have proper formatting and some doesn't have formatting at all).
Comment 1 Buovjaga 2016-06-18 12:24:42 UTC
Repro with document.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha0+
Build ID: c13f60e7cd18df6b0ab70289f5b91ee01e4ae126
CPU Threads: 8; OS Version: Linux 4.6; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Built on June 18th 2016
Comment 2 Markus Mohrhard 2016-09-19 15:06:48 UTC
Stupid me. I fixed the same bug already for rows but apparently not for columns.
Comment 3 Commit Notification 2016-09-19 15:20:51 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3a9917b66d6820ec9f2844f8292a46d8b0b9180b

tdf#100393, handle copying one cell to multiple cols with cond format

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Buovjaga 2016-09-19 16:49:01 UTC
Did a new build and verified fix.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha0+
Build ID: 5c8ad526447934a5eae94fa5f40584083a874d9f
CPU Threads: 8; OS Version: Linux 4.7; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on September 19th 2016
Comment 5 Buovjaga 2016-09-19 16:53:38 UTC
*** Bug 100099 has been marked as a duplicate of this bug. ***
Comment 6 Commit Notification 2016-09-20 15:22:53 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1e40b728c647b0539f4c60c84fada638285a9bd5&h=libreoffice-5-2

tdf#100393, handle copying one cell to multiple cols with cond format

It will be available in 5.2.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2016-09-21 09:35:44 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-5-2-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c5b026801c729ab37e2af6a610f31ca2e28b51fe&h=libreoffice-5-2-2

tdf#100393, handle copying one cell to multiple cols with cond format

It will be available in 5.2.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Buovjaga 2016-09-22 19:03:13 UTC
*** Bug 88790 has been marked as a duplicate of this bug. ***
Comment 9 Commit Notification 2016-09-25 23:28:35 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cb64e937139dad31279078ca464157190cb54350

add test for tdf#100393

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.